python-numpy doc related build failure

Bug #664276 reported by Scott Kitterman on 2010-10-21
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
python-numpy (Debian)
Fix Released
Unknown
python-numpy (Ubuntu)
High
Barry Warsaw
Natty
High
Barry Warsaw

Bug Description

Binary package hint: python-numpy

Even if I allow python-numpy to build against Universe, the docs fail to build:

running scons
running build_scripts
  adding 'build/scripts.linux-i686-2.6/f2py2.6' to scripts
   dh_auto_test
# build doc only for default python version
(export MPLCONFIGDIR=. ; make -C doc html PYTHONPATH=../build/lib.linux-i686-2.6)
make[1]: Entering directory `/home/python-numpy-1.4.1/doc'
mkdir -p build
touch build/generate-stamp
mkdir -p build/html build/doctrees
LANG=C sphinx-build -b html -d build/doctrees source build/html
Running Sphinx v1.0.1

Exception occurred:
  File "/home/python-numpy-1.4.1/doc/sphinxext/numpydoc.py", line 136, in get_directive
    raise RuntimeError("No directive named '%s' found" % name)
RuntimeError: No directive named 'function' found
The full traceback has been saved in /tmp/sphinx-err-lDrgdf.log, if you want to report the issue to the developers.
Please also report this if it was a user error, so that a better error message can be provided next time.
Either send bugs to the mailing list at <http://groups.google.com/group/sphinx-dev/>,
or report them in the tracker at <http://bitbucket.org/birkenfeld/sphinx/issues/>. Thanks!
1.4 1.4.1
make[1]: *** [html] Error 1
make[1]: Leaving directory `/home/python-numpy-1.4.1/doc'
make: *** [build-indep] Error 2
dpkg-buildpackage: error: debian/rules build gave error exit status 2
debuild: fatal error at line 1337:

/tmp/sphinx-err-lDrgdf.log:
# Sphinx version: 1.0.1
# Docutils version: 0.7 release
# Jinja2 version: 2.5.4
Traceback (most recent call last):
  File "/usr/lib/pymodules/python2.6/sphinx/cmdline.py", line 172, in main
    warningiserror, tags)
  File "/usr/lib/pymodules/python2.6/sphinx/application.py", line 116, in __init__
    self.setup_extension(extension)
  File "/usr/lib/pymodules/python2.6/sphinx/application.py", line 253, in setup_extension
    mod.setup(self)
  File "/home/python-numpy-1.4.1/doc/sphinxext/numpydoc.py", line 119, in setup
    app.add_directive('np-' + name, wrap_mangling_directive(name, objtype))
  File "/home/python-numpy-1.4.1/doc/sphinxext/numpydoc.py", line 139, in wrap_mangling_directive
    base_directive = get_directive(base_directive_name)
  File "/home/python-numpy-1.4.1/doc/sphinxext/numpydoc.py", line 136, in get_directive
    raise RuntimeError("No directive named '%s' found" % name)
RuntimeError: No directive named 'function' found

Related branches

Changed in python-numpy (Ubuntu Natty):
milestone: none → natty-alpha-3
importance: Undecided → High
assignee: nobody → Barry Warsaw (barry)
Pauli Virtanen (pauli-virtanen) wrote :

The Sphinx extensions in Numpy 1.4.1 probably don't work properly with current versions of Sphinx (>= 1.0).
If you need still to use 1.4.1, you can try grabbing updated content for the `doc/sphinxext` directory
from Numpy Git repo.

Barry Warsaw (barry) on 2011-01-28
tags: added: python27
Changed in python-numpy (Debian):
status: Unknown → Fix Released
Barry Warsaw (barry) on 2011-02-09
Changed in python-numpy (Ubuntu Natty):
status: New → In Progress
Barry Warsaw (barry) wrote :

See comments in bug 664397. python-matplotlib is in universe so I have to figure out what to do about the dependency. I am marking 664397 as a duplicate of this one.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package python-numpy - 1:1.5.1-1ubuntu2

---------------
python-numpy (1:1.5.1-1ubuntu2) natty; urgency=low

  * debian/rules, debian/control:
    - Re-enable documentation binary package. (LP: #664276)
  * debian/control:
    - Add python-sphinx to Build-Depends since it is required to build the
      documentation.
  * debian/patches/20_disable-plot-extension.patch
    - Disable plot_directive extension, and catch ImportErrors when
      matplotlib cannot be imported, which allows us to remove
      python-matplotlib from dependencies.
 -- Barry Warsaw <email address hidden> Thu, 10 Feb 2011 15:12:43 -0500

Changed in python-numpy (Ubuntu Natty):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.