Ubuntu

upstream tarball differs from that of googlecode and pypi

Reported by Dave Walker on 2011-09-16
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
OpenStack Compute (nova)
Medium
Vish Ishaya
python-mox (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned
Precise
Undecided
Unassigned

Bug Description

The diff between the tarballs is causing tests in Ubuntu's nova to erroneously pass which should fail.

Dave Walker (davewalker) wrote :

---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Changed in python-mox (Ubuntu Oneiric):
milestone: none → ubuntu-11.10-beta-2

The attachment "diff between the two tarballs" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Dave Walker (davewalker) on 2011-09-18
tags: removed: patch
tags: added: patch
Dave Walker (davewalker) on 2011-09-23
Changed in python-mox (Ubuntu):
milestone: ubuntu-11.10-beta-2 → ubuntu-11.10
Changed in python-mox (Ubuntu Oneiric):
status: New → Won't Fix
milestone: ubuntu-11.10 → none
Changed in python-mox (Ubuntu Precise):
milestone: ubuntu-11.10 → none
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in python-mox (Ubuntu):
status: New → Confirmed
Changed in nova:
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Vish Ishaya (vishvananda)

Reviewed: https://review.openstack.org/2859
Committed: http://github.com/openstack/nova/commit/613d1dbc87d9af5d07dc277f0264d6fe1e2e073b
Submitter: Jenkins
Branch: master

commit 613d1dbc87d9af5d07dc277f0264d6fe1e2e073b
Author: Vishvananda Ishaya <email address hidden>
Date: Fri Jan 6 02:18:22 2012 +0000

    Adds workaround check for mox in to_primitive

     * Works around bug 852095
     * Can be removed if a consistent mox 5.4 is released

    Change-Id: I3e57b60886a94c5e7a337b73716759c9a6838e04

Changed in nova:
status: In Progress → Fix Committed

Fix proposed to branch: master
Review: https://review.openstack.org/2878

Changed in nova:
status: Fix Committed → In Progress

Reviewed: https://review.openstack.org/2878
Committed: http://github.com/openstack/nova/commit/b27e14dc96014fb99427593b7f6c406ef29006e5
Submitter: Jenkins
Branch: master

commit b27e14dc96014fb99427593b7f6c406ef29006e5
Author: Vishvananda Ishaya <email address hidden>
Date: Fri Jan 6 19:04:16 2012 +0000

    Workaround bug 852095 without importing mox

     * Fixes bug 912828

    Change-Id: Iade4b0aca1d1f28ce46ed25d0b97c08d152554bd

Changed in nova:
status: In Progress → Fix Committed
Thierry Carrez (ttx) on 2012-01-25
Changed in nova:
milestone: none → essex-3
status: Fix Committed → Fix Released
Thierry Carrez (ttx) on 2012-04-05
Changed in nova:
milestone: essex-3 → 2012.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.