Ubuntu

Dependency problem on gutsy

Reported by Almanildo on 2007-08-09
4
Affects Status Importance Assigned to Milestone
python-mode (Debian)
Fix Released
Undecided
Unassigned
python-mode (Ubuntu)
Medium
Matthias Klose

Bug Description

The package python-mode depends on either emacs21, xemacs21 or emacs-snapshot. However, in Gutsy Gibbon, emacs22 is also available for installation. Thus, it is impossible to install the package if you only want emacs22 installed.

Related branches

Scott Kitterman (kitterman) wrote :

Does it work with emacs22 (i.e. have you tested it)?

Almanildo (audunskaugen) wrote :

Yes, as far as I can tell, it works fine. Shouldn't it depend on emacsen, rather than all possible versions of emacs?

Scott Kitterman (kitterman) wrote :

Sounds reasonable to me, but I'm not an emacs person. This problem exists in Debian too and since the Debian and Ubuntu maintainers for python-mode are the same, I'm going to let him decide the best way to fix it. This ought to be fixed, so I've set a milestone for Tribe 6 to help make sure Gutsy doesn't get released without a serious look at this bug. Thanks for reporting it.

Changed in python-mode:
importance: Undecided → Medium
status: New → Triaged
Sebastien Bacher (seb128) wrote :

emacs22 has a python mode as mentionned on http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=424973

Changed in python-mode:
status: Unknown → New
Changed in python-mode:
assignee: nobody → doko
Matthias Klose (doko) wrote :

now depends emacsen as well, but doesn't install for emacs20 and emacs22; not sure if people like this better.

Changed in python-mode:
status: Triaged → Fix Released

late comment : no, some people don't like this better. I want my python-mode (not the python.el that comes with emacs22).

Artur Rona (ari-tczew) wrote :

 python-mode (1:1.0-3.1) unstable; urgency=medium

   * Non-maintainer upload.
   * Update pymacs path and dependency. Closes: #378699.

 -- Matej Vela <email address hidden> Wed, 2 Aug 2006 09:55:09 +0200

Changed in python-mode (Debian):
importance: Unknown → Undecided
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.