[SRU] Installation fails with Python3.7 SyntaxError on Ubuntu Disco

Bug #1823718 reported by Frode Nordahl on 2019-04-08
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
OpenStack hacluster charm
Undecided
Unassigned
python-libmaas (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned
Cosmic
Undecided
Unassigned
Disco
High
Adam Collard

Bug Description

[Impact]
python-libmaas is un-installable with py37

[Test Case]
sudo apt install python3-libmaas

[Regression Potential]
Minimal; internal module already in eoan development.

[Original bug report]
root@direct-tiger:~# lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu Disco Dingo (development branch)
Release: 19.04
Codename: disco
root@direct-tiger:~# apt update && apt -y install python3-libmaas
[ snip ... ]
Setting up python3-libmaas (0.6.0-0ubuntu1) ...
  File "/usr/lib/python3/dist-packages/maas/client/__init__.py", line 8
    from .utils.async import asynchronous
                    ^
SyntaxError: invalid syntax

  File "/usr/lib/python3/dist-packages/maas/client/bones/__init__.py", line 23
    from ..utils.async import asynchronous
                     ^
SyntaxError: invalid syntax

  File "/usr/lib/python3/dist-packages/maas/client/bones/helpers.py", line 31
    from ..utils.async import asynchronous
                     ^
SyntaxError: invalid syntax

  File "/usr/lib/python3/dist-packages/maas/client/flesh/controllers.py", line 16
    from ..utils.async import asynchronous
                     ^
SyntaxError: invalid syntax

  File "/usr/lib/python3/dist-packages/maas/client/flesh/fabrics.py", line 15
    from ..utils.async import asynchronous
                     ^
SyntaxError: invalid syntax

  File "/usr/lib/python3/dist-packages/maas/client/flesh/machines.py", line 26
    from ..utils.async import asynchronous
                     ^
SyntaxError: invalid syntax

  File "/usr/lib/python3/dist-packages/maas/client/flesh/profiles.py", line 28
    from ..utils.async import asynchronous
                     ^
SyntaxError: invalid syntax

  File "/usr/lib/python3/dist-packages/maas/client/flesh/spaces.py", line 15
    from ..utils.async import asynchronous
                     ^
SyntaxError: invalid syntax

  File "/usr/lib/python3/dist-packages/maas/client/flesh/subnets.py", line 15
    from ..utils.async import asynchronous
                     ^
SyntaxError: invalid syntax

  File "/usr/lib/python3/dist-packages/maas/client/flesh/vlans.py", line 15
    from ..utils.async import asynchronous
                     ^
SyntaxError: invalid syntax

  File "/usr/lib/python3/dist-packages/maas/client/viscera/__init__.py", line 49
    from ..utils.async import Asynchronous
                     ^
SyntaxError: invalid syntax

  File "/usr/lib/python3/dist-packages/maas/client/viscera/events.py", line 25
    from ..utils.async import is_loop_running
                     ^
SyntaxError: invalid syntax

dpkg: error processing package python3-libmaas (--configure):
 installed python3-libmaas package post-installation script subprocess returned error exit status 1
Errors were encountered while processing:
 python3-libmaas
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@direct-tiger:~#

Frode Nordahl (fnordahl) wrote :

Note that ``python3-libmaas`` is a dependency of ``charm-hacluster``, which means HA deployments of Ubuntu OpenStack are currently not possible on Ubuntu Disco.

James Page (james-page) wrote :

This issue appears to be fixed in the upstream git repository but has not been released.

I was going to pick the commit but due to the file rename this is a little undesirable.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in python-libmaas (Ubuntu):
status: New → Confirmed
Ryan Beisner (1chb1n) on 2019-06-27
tags: added: mosci
Ryan Beisner (1chb1n) on 2019-06-27
tags: added: uosci
Andres Rodriguez (andreserl) wrote :

Marking as fix released, as this has been fixed in eoan. The fix and/or new upstream needs to be backported.

Changed in python-libmaas (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in python-libmaas (Ubuntu Bionic):
status: New → Confirmed
Changed in python-libmaas (Ubuntu Cosmic):
status: New → Confirmed
Changed in python-libmaas (Ubuntu Disco):
status: New → Confirmed
Felipe Reyes (freyes) on 2019-06-27
tags: added: seg
Ryan Beisner (1chb1n) wrote :

This issue is blocking general OpenStack Stein validation and backports due to the requirement to validate in disco distro ahead of the Ubuntu Cloud Archive.

Is there an ETA for the backport of the libmaas py37 fix to Disco?

James Page (james-page) on 2019-07-18
Changed in charm-hacluster:
status: New → Invalid
Changed in python-libmaas (Ubuntu Disco):
assignee: nobody → Adam Collard (adam-collard)
Adam Collard (adam-collard) wrote :

Attached debdiff should fix this

James Page (james-page) on 2019-07-18
Changed in python-libmaas (Ubuntu Cosmic):
status: Confirmed → Invalid
Changed in python-libmaas (Ubuntu Bionic):
status: Confirmed → Invalid
Changed in python-libmaas (Ubuntu Disco):
importance: Undecided → High
status: Confirmed → In Progress
James Page (james-page) on 2019-07-18
description: updated
summary: - Installation fails with Python3.7 SyntaxError on Ubuntu Disco
+ [SRU] Installation fails with Python3.7 SyntaxError on Ubuntu Disco
Łukasz Zemczak (sil2100) wrote :

From the description I assume this is only an internal module, not part of the public API, right? Since we wouldn't want to break any existing applications, if anything.

Changed in python-libmaas (Ubuntu Disco):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-disco

Hello Frode, or anyone else affected,

Accepted python-libmaas into disco-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/python-libmaas/0.6.0-0ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-disco to verification-done-disco. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-disco. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

On Mon, 22 Jul 2019 at 11:56, Łukasz Zemczak <email address hidden>
wrote:

> >From the description I assume this is only an internal module, not part
> of the public API, right? Since we wouldn't want to break any existing
> applications, if anything.
>

Correct, and it would have been tricky for any existing applications or
users to have used it since it fails to install on Python 3.7 (Disco).

Frode Nordahl (fnordahl) wrote :

# lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 19.04
Release: 19.04
Codename: disco
# apt install python3-libmaas (expect failure)
[ snip ]
dpkg: error processing package python3-libmaas (--configure):
 installed python3-libmaas package post-installation script subprocess returned error exit status 1
Errors were encountered while processing:
 python3-libmaas
E: Sub-process /usr/bin/dpkg returned an error code (1)

# wget https://launchpad.net/ubuntu/+source/python-libmaas/0.6.0-0ubuntu2/+build/17305309/+files/python3-libmaas_0.6.0-0ubuntu2_all.deb
# dpkg -i python3-libmaas_0.6.0-0ubuntu2_all.deb
(Reading database ... 29334 files and directories currently installed.)
Preparing to unpack python3-libmaas_0.6.0-0ubuntu2_all.deb ...
Unpacking python3-libmaas (0.6.0-0ubuntu2) over (0.6.0-0ubuntu1) ...
Setting up python3-libmaas (0.6.0-0ubuntu2) ...
#

(success!)

tags: added: verification-done verification-done-disco
removed: verification-needed verification-needed-disco
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package python-libmaas - 0.6.0-0ubuntu2

---------------
python-libmaas (0.6.0-0ubuntu2) disco; urgency=medium

  * d/p/async_keyword_rename.diff: Rename async module fixing compatibility
    with Python 3.7 (LP: #1823718).

 -- Adam Collard <email address hidden> Thu, 18 Jul 2019 12:01:17 +0100

Changed in python-libmaas (Ubuntu Disco):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for python-libmaas has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers