Ubuntu

Does not save the configuration file under ~/.config/

Reported by Fred on 2011-10-27
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
adobe-flashplugin (Ubuntu)
Undecided
Unassigned
bash (Ubuntu)
Undecided
Unassigned
bzr (Ubuntu)
Undecided
Unassigned
compiz (Ubuntu)
Wishlist
Unassigned
dbus (Ubuntu)
Undecided
Unassigned
dia (Ubuntu)
Undecided
Unassigned
gconf (Ubuntu)
Wishlist
Unassigned
gegl (Ubuntu)
Undecided
Unassigned
gimp (Ubuntu)
Wishlist
Unassigned
gl-117 (Ubuntu)
Undecided
Unassigned
gnome-games (Ubuntu)
Undecided
Unassigned
gnupg (Ubuntu)
Undecided
Unassigned
gvfs (Ubuntu)
Wishlist
Unassigned
hydrogen (Ubuntu)
Undecided
Unassigned
nautilus (Ubuntu)
Wishlist
Unassigned
onboard (Ubuntu)
Undecided
Unassigned
python-launchpadlib (Ubuntu)
Undecided
Unassigned
shotwell (Ubuntu)
Wishlist
Unassigned
synaptic (Ubuntu)
Undecided
Unassigned
thunderbird (Ubuntu)
Undecided
Unassigned
w3m (Ubuntu)
Wishlist
Unassigned
xchat (Ubuntu)
Wishlist
Unassigned

Bug Description

It does not save the configuration file(s) and/or the cache under the right location for configuration file storage which is under ~/.config/ and ~/.cache/

description: updated
description: updated
Sebastien Bacher (seb128) wrote :

it's not likely that the gconf database will be migrated in new version since gconf is deprecated

Changed in gconf (Ubuntu):
importance: Undecided → Wishlist
status: New → Triaged
Changed in nautilus (Ubuntu):
importance: Undecided → Wishlist
status: New → Triaged
Changed in shotwell (Ubuntu):
importance: Undecided → Wishlist
status: New → Confirmed
Changed in gvfs (Ubuntu):
importance: Undecided → Wishlist
status: New → Confirmed
Changed in gimp (Ubuntu):
importance: Undecided → Wishlist
status: New → Confirmed
Adam Dingle (adam-yorba) wrote :

For Shotwell, this is ticketed upstream at http://redmine.yorba.org/issues/421 .

Bryce Harrington (bryce) on 2011-11-19
Changed in xchat (Ubuntu):
importance: Undecided → Wishlist
status: New → Triaged
no longer affects: launchpadlib
Changed in compiz (Ubuntu):
importance: Undecided → Wishlist
status: New → Confirmed
Jelmer Vernooij (jelmer) wrote :

For Bazaar, see bug #195397.

Aren't these all separate bugs (and thus should be separate bug reports) ? This prevents me from marking this bug as a dupe of #195397.

Changed in bzr (Ubuntu):
status: New → Fix Released
Robert Roth (evfool) on 2012-08-10
Changed in synaptic (Ubuntu):
status: New → Triaged
Logan Rosen (logan) on 2012-09-14
affects: gnome-sudoku (Ubuntu) → gnome-games (Ubuntu)
Daniel Hahler (blueyed) wrote :

python-launchpadlib does not have any config, but uses cache files insteaad. I have created bug 1068695 about this.

Changed in python-launchpadlib (Ubuntu):
status: New → Invalid
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in adobe-flashplugin (Ubuntu):
status: New → Confirmed
Changed in bash (Ubuntu):
status: New → Confirmed
Changed in dbus (Ubuntu):
status: New → Confirmed
Changed in gegl (Ubuntu):
status: New → Confirmed
Changed in gnome-games (Ubuntu):
status: New → Confirmed
Changed in gnupg (Ubuntu):
status: New → Confirmed
Changed in w3m (Ubuntu):
status: New → Confirmed
Daniel Hartwig (wigs) on 2013-04-27
Changed in adobe-flashplugin (Ubuntu):
status: Confirmed → New
Changed in bash (Ubuntu):
status: Confirmed → New
Changed in dbus (Ubuntu):
status: Confirmed → New
Changed in gegl (Ubuntu):
status: Confirmed → New
Changed in gnome-games (Ubuntu):
status: Confirmed → New
Changed in gnupg (Ubuntu):
status: Confirmed → New
Changed in w3m (Ubuntu):
status: Confirmed → New
Jim Nelson (yorba-jim) on 2013-04-29
Changed in shotwell (Ubuntu):
status: Confirmed → Fix Released
Steve Langasek (vorlon) on 2013-04-29
no longer affects: skype (Ubuntu)
Robie Basak (racb) wrote :

> the right location for configuration file storage which is under ~/.config/ and ~/.cache/

I understand that this is what the XDG spec says, but has there actually been consensus in Debian or Ubuntu that all packages should migrate to this?

Changed in w3m (Ubuntu):
importance: Undecided → Wishlist
marmuta (marmuta) on 2013-10-23
Changed in onboard (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers