lp-shell crashed with ImportError in _ensure_keyring_imported(): No module named keyring

Bug #724327 reported by Benjamin Drung on 2011-02-24
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
python-launchpadlib (Ubuntu)
High
Barry Warsaw

Bug Description

Binary package hint: ubuntu-dev-tools

lp-shell failed with an ImportError.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: ubuntu-dev-tools 0.118
ProcVersionSignature: Ubuntu 2.6.38-5.32-generic 2.6.38-rc6
Uname: Linux 2.6.38-5-generic x86_64
Architecture: amd64
Date: Thu Feb 24 15:07:54 2011
ExecutablePath: /usr/bin/lp-shell
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Beta amd64 (20100318)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/lp-shell
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LC_MESSAGES=de_DE.utf8
 LANG=de_DE.UTF-8
 LANGUAGE=de_DE:de:en_GB:en
PythonArgs: ['/usr/bin/lp-shell']
SourcePackage: ubuntu-dev-tools
Title: lp-shell crashed with ImportError in _ensure_keyring_imported(): No module named keyring
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Benjamin Drung (bdrung) wrote :
visibility: private → public
Leonard Richardson (leonardr) wrote :

It looks like python-launchpadlib's dependency on python-keyring is not registered.

affects: ubuntu-dev-tools (Ubuntu) → python-launchpadlib (Ubuntu)
Changed in python-launchpadlib (Ubuntu):
status: New → Confirmed
tags: removed: need-duplicate-check
Barry Warsaw (barry) on 2011-02-24
Changed in python-launchpadlib (Ubuntu):
importance: Undecided → High
assignee: nobody → Barry Warsaw (barry)
milestone: none → natty-alpha-3
Barry Warsaw (barry) on 2011-02-24
Changed in python-launchpadlib (Ubuntu):
status: Confirmed → In Progress
Colin Watson (cjwatson) on 2011-03-07
Changed in python-launchpadlib (Ubuntu):
milestone: natty-alpha-3 → ubuntu-11.04-beta-1
Colin Watson (cjwatson) wrote :

This was reported and fixed as bug 724494.

Changed in python-launchpadlib (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers