bughelper crashed with TypeError in __init__() - Read only attribute

Bug #396531 reported by Dennis Craven on 2009-07-07
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Bug Helper
High
Unassigned
python-launchpad-bugs
High
Markus Korn
python-launchpad-bugs (Ubuntu)
High
Unassigned

Bug Description

Binary package hint: bughelper

On first run, bughelper with no arguments crashed with a TypeError: readonly attribute error.

ProblemType: Crash
Architecture: amd64
Date: Tue Jul 7 08:40:18 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/bughelper
InterpreterPath: /usr/bin/python2.6
NonfreeKernelModules: nvidia wl
Package: bughelper 0.2.16
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/bughelper
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_CA.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-1.14-generic
PythonArgs: ['/usr/bin/bughelper']
SourcePackage: bughelper
Title: bughelper crashed with TypeError in __init__()
Uname: Linux 2.6.31-1-generic x86_64
UserGroups: adm admin cdrom dialout libvirtd lpadmin plugdev sambashare

Dennis Craven (dcraven) wrote :
tags: removed: need-duplicate-check
Brian Murray (brian-murray) wrote :

Apparently there is an issue with bughelper or python-launchpad-bugs and python2.6. This can be worked around by using python2.5 instead, for example 'python2.5 bughelper'.

visibility: private → public
Changed in bughelper (Ubuntu):
status: New → Triaged
importance: Undecided → High
Changed in bughelper:
status: New → Confirmed
importance: Undecided → High
Markus Korn (thekorn) wrote :

This seems to be a minimal reproducer for this issue.
Also, I can't reproduce this bug on jaunty with python 2.6.2

For me it looks like a result of this change
"""++- Issue #5890: in subclasses of 'property' the __doc__ attribute was
++ shadowed by classtype's, even if it was None. property now
++ inserts the __doc__ into the subclass instance __dict__.
"""

quote from https://launchpadlibrarian.net/28116487/python2.6_2.6.2-0ubuntu2.diff.gz

Changed in python-launchpad-bugs:
assignee: nobody → Markus Korn (thekorn)
importance: Undecided → High
status: New → Triaged
Markus Korn (thekorn) wrote :

This issue should be fixed in lp:python-launchpad-bugs now

Changed in python-launchpad-bugs:
status: Triaged → Fix Committed
Changed in bughelper:
status: Confirmed → Invalid
Brian Murray (brian-murray) wrote :

Switching the Ubuntu task to a python-launchpad-bugs one.

affects: bughelper (Ubuntu) → python-launchpad-bugs (Ubuntu)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package python-launchpad-bugs - 0.3.6

---------------
python-launchpad-bugs (0.3.6) karmic; urgency=low

  [ Colin Watson ]
  * Ignore quasi-comments containing activity log information (LP: #352543).

  [ Markus Korn ]
  * fixed incompatibility with python 2.6 in karmic (LP: #396531)
  * fixed test runner, output streams for unittest results now need a flush()
    method

 -- Brian Murray <email address hidden> Wed, 22 Jul 2009 14:35:15 -0700

Changed in python-launchpad-bugs (Ubuntu):
status: Triaged → Fix Released
Brian Murray (brian-murray) wrote :

I've tested using the new version of python-launchpad-bugs and it is in fact fixed. Thanks!

Changed in python-launchpad-bugs:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers