[SRU] keystoneauth1 2.4.1 for Xenial/Mitaka

Bug #1586900 reported by Dr. Jens Harbott on 2016-05-30
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu Cloud Archive
Medium
Unassigned
Mitaka
Medium
Unassigned
Newton
Medium
Unassigned
python-keystoneauth1 (Ubuntu)
Medium
Unassigned
Xenial
Medium
Unassigned
Yakkety
Medium
Unassigned

Bug Description

[Impact]
Pretty much every OpenStack service generates warning messages when configuring keystone authentication.

[Test Case]
Install and configure OpenStack services
deprecation warning in message logs.

[Regression Potential]
Minimal - just flips round username/user-name as the supported/deprecated option. Point release also includes a py3 compat fix (already held as a patch) and a typo fix for help.

[Original Bug Report]
This fixes the username deprecation issue, see https://bugs.launchpad.net/python-keystoneclient/+bug/1552634

James Page (james-page) on 2016-05-31
Changed in python-keystoneauth1 (Ubuntu Xenial):
importance: Undecided → Medium
Changed in python-keystoneauth1 (Ubuntu Yakkety):
importance: Undecided → Medium
Changed in python-keystoneauth1 (Ubuntu Xenial):
status: New → Triaged
Changed in python-keystoneauth1 (Ubuntu Yakkety):
status: New → Triaged
James Page (james-page) wrote :

Uploaded to debian unstable; will sync into yakkety and then backport for xenial/mitaka

James Page (james-page) on 2016-05-31
summary: - Please build keystoneauth1 2.4.1 for Xenial/Mitaka
+ [SRU] keystoneauth1 2.4.1 for Xenial/Mitaka
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package python-keystoneauth1 - 2.4.1-1ubuntu1

---------------
python-keystoneauth1 (2.4.1-1ubuntu1) yakkety; urgency=medium

  * Resync with Debian unstable.
  * d/control: Demote runtime dependency on requests-kerberos to a
    Suggests as its an optional dependency.

python-keystoneauth1 (2.4.1-1) unstable; urgency=medium

  [ Ondřej Nový ]
  * Standards-Version is 3.9.8 now (no change)
  * d/rules: Changed UPSTREAM_GIT protocol to https

  [ James Page ]
  * New upstream point release (LP: #1586900).
    - d/p/*: Dropped, included upstream.

 -- James Page <email address hidden> Wed, 01 Jun 2016 18:53:57 +0100

Changed in python-keystoneauth1 (Ubuntu Yakkety):
status: Triaged → Fix Released
Corey Bryant (corey.bryant) wrote :

2.4.1 has been uploaded to the xenial review queue and is awaiting SRU team review.

Martin Pitt (pitti) wrote :

The upload claims to keep the Ubuntu change "Move python(3)-requests-kerberos to Suggests as it is optional.", but still the patch does

@@ -30,10 +31,12 @@
                      python-positional (>= 1.0.1),
                      python-requests (>= 2.8.1),
                      python-requests-mock (>= 0.7.0),
+ python-requests-kerberos (>= 0.6),
                      python-six (>= 1.9.0),
                      python-stevedore (>= 1.5.0),
                      python-testresources,
                      python-testtools (>= 1.4.0),
+ python3-betamax (>= 0.5.1),
                      python3-crypto,
                      python3-fixtures (>= 1.3.1),
                      python3-iso8601,

Both new packages are in universe, so these need to be dropped again. Rejecting the upload

Corey Bryant (corey.bryant) wrote :

Hi Martin, I was under the impression that universe packages could exist in Build-Depends in xenial+, so I dropped some of the delta we had with debian by adding python3-betamax/python3-requests-kerberos back to BDs and dropping patches that skipped tests.

Corey Bryant (corey.bryant) wrote :

Martin and I discussed this in IRC and I've since re-uploaded this package. It should be good to go and ready for sru team review.

Hello Dr., or anyone else affected,

Accepted python-keystoneauth1 into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/python-keystoneauth1/2.4.1-1ubuntu0.16.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in python-keystoneauth1 (Ubuntu Xenial):
status: Triaged → Fix Committed
tags: added: verification-needed
Dr. Jens Harbott (j-harbott) wrote :

Tested 2.4.1-1ubuntu0.16.04.1 on xenial and seems to work fine for me.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package python-keystoneauth1 - 2.4.1-1ubuntu0.16.04.1

---------------
python-keystoneauth1 (2.4.1-1ubuntu0.16.04.1) xenial; urgency=medium

  * Merge from Debian unstable, remaining changes (LP: #1586900):
    - d/control: Move python(3)-requests-kerberos to Suggests as it is optional.

 -- Corey Bryant <email address hidden> Mon, 20 Jun 2016 08:58:57 -0400

Changed in python-keystoneauth1 (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for python-keystoneauth1 has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

James Page (james-page) on 2016-07-20
Changed in cloud-archive:
status: Fix Released → Fix Committed

Hello Dr., or anyone else affected,

Accepted python-keystoneauth1 into mitaka-proposed. The package will build now and be available in the Ubuntu Cloud Archive in a few hours, and then in the -proposed repository.

Please help us by testing this new package. To enable the -proposed repository:

  sudo add-apt-repository cloud-archive:mitaka-proposed
  sudo apt-get update

Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-mitaka-needed to verification-mitaka-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-mitaka-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-mitaka-needed
Corey Bryant (corey.bryant) wrote :

python-keystoneauth 2.4.1-1ubuntu0.16.04.1~cloud0 has been tested successfully.

tags: added: verification-mitaka-done
removed: verification-mitaka-needed

The verification of the Stable Release Update for python-keystoneauth1 has completed successfully and the package has now been released to -updates. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers