Ubuntu

'/org/freedesktop/secrets/aliases/default' object does not exist

Reported by Germar on 2013-10-20
52
This bug affects 7 people
Affects Status Importance Assigned to Milestone
python-keyring (Ubuntu)
High
Dmitry Shachnev

Bug Description

This was done with Kubuntu 13.10 Live CD. But it's the same with installed Kubuntu 13.10

kubuntu@kubuntu:~$ sudo apt-get install python-keyring python-secretstorage
...
kubuntu@kubuntu:~$ dpkg -l | grep -e "python-keyring\|python-secretstorage"
ii python-keyring 1.6-1 all store and access your passwords safely
ii python-secretstorage 1.0.0-1 all Python module for storing secrets - Python 2.x version

kubuntu@kubuntu:~$ python
Python 2.7.5+ (default, Sep 19 2013, 13:48:49)
[GCC 4.8.1] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import keyring
ERROR:dbus.proxies:Introspect error on :1.28:/org/freedesktop/secrets/aliases/default: dbus.exceptions.DBusException: org.freedesktop.Secret.Error.NoSuchObject: The '/org/freedesktop/secrets/aliases/default' object does not exist
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib/python2.7/dist-packages/keyring/__init__.py", line 9, in <module>
    from core import (set_keyring, get_keyring, set_password, get_password,
  File "/usr/lib/python2.7/dist-packages/keyring/core.py", line 166, in <module>
    init_backend()
  File "/usr/lib/python2.7/dist-packages/keyring/core.py", line 65, in init_backend
    keyrings.sort(key = lambda x: -x.supported())
  File "/usr/lib/python2.7/dist-packages/keyring/core.py", line 65, in <lambda>
    keyrings.sort(key = lambda x: -x.supported())
  File "/usr/lib/python2.7/dist-packages/keyring/backends/SecretService.py", line 23, in supported
    secretstorage.Collection(bus)
  File "/usr/lib/python2.7/dist-packages/secretstorage/collection.py", line 43, in __init__
    self.collection_props_iface.Get(COLLECTION_IFACE, 'Label')
  File "/usr/lib/python2.7/dist-packages/secretstorage/util.py", line 27, in function_out
    raise ItemNotFoundException(e.get_dbus_message())
secretstorage.exceptions.ItemNotFoundException: The '/org/freedesktop/secrets/aliases/default' object does not exist
>>>

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in python-secretstorage (Ubuntu):
status: New → Confirmed
Changed in python-secretstorage (Ubuntu):
status: Confirmed → In Progress
importance: Undecided → High
assignee: nobody → Dmitry Shachnev (mitya57)
Dmitry Shachnev (mitya57) wrote :

Actually it turned out to be a bug in python-keyring, not in secretstorage.

Fixed in <https://bitbucket.org/kang/python-keyring-lib/commits/b6257215041a9c7f>.

affects: python-secretstorage (Ubuntu) → python-keyring (Ubuntu)

When or how can I have the fix on my ubuntu ? Maybe there is a ppa supporting it?

Dmitry Shachnev (mitya57) wrote :

Martin, the fix will land soon.

Dmitry Shachnev (mitya57) wrote :

Fixed in 3.3-1.

Changed in python-keyring (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions