trying to overwrite '/usr/bin/glance', which is also in package glance-client

Bug #1030914 reported by Jamie Strandboge
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
python-glanceclient (Ubuntu)
High
Unassigned

Bug Description

In trying to workaround bug #1024326, if I try to install python-glanceclient with glance already installed, I get:
dpkg: error processing /var/cache/apt/archives/python-glanceclient_1%3a0.1.1-0ubuntu1_all.deb (--unpack):
 trying to overwrite '/usr/bin/glance', which is also in package glance-client 2012.2~f2~20120531.1560-0ubuntu1

Revision history for this message
Jerico Revote (jrevote) wrote :

Also getting the same error:

Unpacking python-glanceclient (from .../python-glanceclient_1%3a0.2.0.5.5f5d8ee+git201208012031~precise-0ubuntu1_all.deb) ...
dpkg: error processing /var/cache/apt/archives/python-glanceclient_1%3a0.2.0.5.5f5d8ee+git201208012031~precise-0ubuntu1_all.deb (--unpack):
 trying to overwrite '/usr/bin/glance', which is also in package glance-client 2012.2+git201208012131~precise-0ubuntu1
Errors were encountered while processing:
 /var/cache/apt/archives/python-glanceclient_1%3a0.2.0.5.5f5d8ee+git201208012031~precise-0ubuntu1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in python-glanceclient (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers