backport eventlet exception context fix

Bug #1199037 reported by Edward Hope-Morley on 2013-07-08
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
python-eventlet (Ubuntu)
Undecided
Edward Hope-Morley
Raring
Undecided
Edward Hope-Morley
Saucy
Undecided
Edward Hope-Morley

Bug Description

A bug was found in python-eventlet which affects a lot of Oepnstack code. The issue and test case are detailed here:

https://bitbucket.org/eventlet/eventlet/issue/149/yield-in-except-clause-with-wilcard-raise

The following fix needs to be backported from v0.13 into cloud archive:

https://github.com/eventlet/eventlet/commit/0195326cbec83e5358d18f03f0189daff593dac3

[Impact]

 * This patch will fix lost exception context when a yield occurs within a
   Python except clause.

 * The issue fixed here affects many Openstack services.

 * More info can be found here: http://goo.gl/mGyuD

[Test Case]

 * Please see http://goo.gl/mGyuD for information on how to reproduce this bug

 * I have tested this on Raring using the above test.

[Regression Potential]

 * This issue is not expected to introduce any regression. The test case above
   has been tested.

Related branches

summary: - need to get python-eventlet 0.13 into cloud archive
+ backport eventlet exception context fix
description: updated
Chuck Short (zulcss) wrote :

Ed,

We have discussed it on IRC but can you provide more information in the bug report please.

chuck

Edward Hope-Morley (hopem) wrote :

Chuck, I have documented the issue in a separate ticket - please see above. It also includes a test.

description: updated
Changed in python-eventlet (Ubuntu Raring):
assignee: nobody → Edward Hope-Morley (hopem)
Changed in python-eventlet (Ubuntu Saucy):
assignee: nobody → Edward Hope-Morley (hopem)
Changed in python-eventlet (Ubuntu Raring):
status: New → In Progress
description: updated
description: updated
Chuck Short (zulcss) on 2013-07-15
Changed in python-eventlet (Ubuntu Raring):
status: In Progress → Confirmed
status: Confirmed → In Progress
Changed in python-eventlet (Ubuntu Saucy):
status: New → Fix Released
Changed in python-eventlet (Ubuntu Saucy):
status: Fix Released → Confirmed
status: Confirmed → Fix Released
Changed in python-eventlet (Ubuntu Raring):
status: In Progress → Fix Committed
status: Fix Committed → Confirmed
Chuck Short (zulcss) wrote :

I uploaded it this morning.

Brian Murray (brian-murray) wrote :

I rejected Chuck's upload due of the patch due to the Launchpad bug reference being improperly formatted and uploaded a fixed version of the changelog to raring.

Adam Stokes (adam-stokes) wrote :

Thanks Brian,

Ed this should be good to go now and in process of being reviewed by SRU team.

Adam

Hello Edward, or anyone else affected,

Accepted python-eventlet into raring-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/python-eventlet/0.12.1-0ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in python-eventlet (Ubuntu Raring):
status: Confirmed → Fix Committed
tags: added: verification-needed
Dmitry Shachnev (mitya57) wrote :

Unsubscribed sponsors, the fix is now in -proposed.

Edward Hope-Morley (hopem) wrote :

I have now tested on Raring using test case provided with this bug with package:

python-eventlet:
  Installed: 0.12.1-0ubuntu1.1
  Candidate: 0.12.1-0ubuntu1.1
  Version table:
 *** 0.12.1-0ubuntu1.1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ raring-proposed/main amd64 Packages

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package python-eventlet - 0.12.1-0ubuntu1.1

---------------
python-eventlet (0.12.1-0ubuntu1.1) raring; urgency=low

  * Added patch for lost exception context fix from upstream v0.13
    (LP: #1199037)
 -- Edward Hope-Morley <email address hidden> Thu, 18 Jul 2013 10:57:26 +0100

Changed in python-eventlet (Ubuntu Raring):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers