Sync python-evdev 0.7.0+dfsg-2 (universe) from Debian unstable (main)

Bug #1720525 reported by Luca Weiss on 2017-09-30
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
python-evdev (Ubuntu)
Undecided
Unassigned

Bug Description

Please sync python-evdev 0.7.0+dfsg-2 (universe) from Debian unstable (main)

This sync request is (obviously) targeted for BB once the development archive opens.

Explanation of the Ubuntu delta and why it can be dropped:
So far the package has been packaged in Ubuntu only¸ but it is now available in Debian as well.
The Debian maintainer commented in comment #2 that there doesn't seem to be any changes added in the Ubuntu package which isn't in upstream.
(I haven't investigated the details)

Changelog entries in Debian:

python-evdev (0.7.0+dfsg-2) unstable; urgency=medium

  * Limit the architecture to linux-any. Closes: #875624.
  * Switch to Python 3 Docutils and Sphinx, build-conflicting on
    python-sphinx to avoid issues with that being picked in preference to
    python3-sphinx.
  * Clean up debian/control with cme.
  * Drop the new-package-should-not-package-python2-module override
    since this is no longer a new package.
  * Standards-Version 4.1.1, no change required.

 -- Stephen Kitt <email address hidden> Sat, 07 Oct 2017 11:49:45 +0200

python-evdev (0.7.0+dfsg-1) unstable; urgency=medium

  * Initial release. Closes: #709988.

 -- Stephen Kitt <email address hidden> Fri, 01 Sep 2017 13:56:02 +0200

Original description:

In Artful (and older releases) the version of the package is 0.4.7 even though 0.7.0 is already out. Debian Buster and Sid has 0.7.0 in the repos.
The changes are bug fixes and features (see http://python-evdev.readthedocs.io/en/latest/changelog.html).

Hans Joachim Desserud (hjd) wrote :

Thanks for taking your time to report this issue and help making Ubuntu better.

Indeed, Debian Sid contains a newer version of this package. However, I don't know whether that could be synced as-is or if there are any additional changes in the current Ubuntu package which would require a merge.

tags: added: upgrade-software-version
Stephen Kitt (steve-sk2) wrote :

I'm pretty sure the Debian package can be synced as-is, there are no additional changes that would need to be kept in the current Ubuntu package. (The only patch is included in the upstream code in newer versions, including that packaged in Debian.)

Hans Joachim Desserud (hjd) wrote :

Sounds good. If there's no Ubuntu-only changes, then this report can probably be converted to a sync request https://wiki.ubuntu.com/SyncRequestProcess#Content_of_a_sync_request

(Unless someone beats me to it, I can probably do this once the new development cycle starts)

summary: - Update package to newer version
+ Sync python-evdev 0.7.0+dfsg-2 (universe) from Debian unstable (main)
description: updated
Jeremy Bicha (jbicha) wrote :

This bug was fixed in the package python-evdev - 0.7.0+dfsg-2
Sponsored for Luca Weiss (z3ntu)

---------------
python-evdev (0.7.0+dfsg-2) unstable; urgency=medium

  * Limit the architecture to linux-any. Closes: #875624.
  * Switch to Python 3 Docutils and Sphinx, build-conflicting on
    python-sphinx to avoid issues with that being picked in preference to
    python3-sphinx.
  * Clean up debian/control with cme.
  * Drop the new-package-should-not-package-python2-module override
    since this is no longer a new package.
  * Standards-Version 4.1.1, no change required.

 -- Stephen Kitt <email address hidden> Sat, 07 Oct 2017 11:49:45 +0200

python-evdev (0.7.0+dfsg-1) unstable; urgency=medium

  * Initial release. Closes: #709988.

 -- Stephen Kitt <email address hidden> Fri, 01 Sep 2017 13:56:02 +0200

Changed in python-evdev (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers