contrib.auth tests fail if the app provides templates

Bug #650473 reported by James Westby on 2010-09-28
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Django
Fix Released
Unknown
python-django (Ubuntu)
Undecided
Unassigned
Lucid
Medium
Unassigned

Bug Description

Binary package hint: python-django

Hi,

Impact: If you write a django project that uses contrib.auth and provides templates for those views, then your tests cannot pass.
Development branch: the bug was fixed when we got 1.2, as this was already found and fixed upstream.
Patch: taken from upstream, see below
Test Case:
  bzr branch lp:~james-w/+junk/django-test
  cd django-test
  python dashboard_server/manage.py test
  - This should give 6 errors
  - Install the updated package
  python dashboard_server/manage.py test
  - Should give 0 errors
Regression Potential: Low as in test code only, and a blessed upstream fix that is verified to work.

Reported and fixed at:

  http://code.djangoproject.com/ticket/10976

Thanks,

James

James Westby (james-w) on 2010-09-28
Changed in python-django (Ubuntu):
status: New → Triaged
status: Triaged → Fix Released
Changed in python-django (Ubuntu Lucid):
status: New → Triaged
importance: Undecided → Medium
James Westby (james-w) on 2010-09-28
description: updated
Changed in django:
status: Unknown → Fix Released

Accepted python-django into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in python-django (Ubuntu Lucid):
status: Triaged → Fix Committed
tags: added: verification-needed
James Westby (james-w) wrote :

This works for me, thanks, at least at fixing this particular bug. I will ask some of
my colleagues to test as well.

Thanks,

James

Jamie Strandboge (jdstrand) wrote :

A pending security upload is going to supersede the package in lucid-proposed.

Rolf Leggewie (r0lf) wrote :

lucid has seen the end of its life and is no longer receiving any updates. Marking the lucid task for this ticket as "Won't Fix".

Changed in python-django (Ubuntu Lucid):
status: Fix Committed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.