FTBFS: test_instance_is_maintained fails

Bug #1231923 reported by Adam Conrad on 2013-09-27
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
python-django (Debian)
Fix Released
Unknown
python-django (Ubuntu)
Undecided
Unassigned

Bug Description

Imported from Debian bug http://bugs.debian.org/724637:

Package: python-django
Version: 1.5.4-1

As discussed in http://lists.debian.org/debian-python/2013/09/msg00129.html,
under certain (random?) circumstances, I get the following test failure
when building python-django from Debian source:

======================================================================
FAIL: test_instance_is_maintained
(django.contrib.formtools.tests.wizard.wizardtests.tests.WizardFormKwargsOverrideTests)
----------------------------------------------------------------------
Traceback (most recent call last):
  File
"/tmp/brian/tmp.rJDf6JJXaz/python-django-1.5.4/django/contrib/formtools/tests/wizard/wizardtests/tests.py",
line 375, in test_instance_is_maintained
    self.assertEqual(2, User.objects.count())
AssertionError: 2 != 3

----------------------------------------------------------------------

Displaying User.objects.all() shows:

 [<User: johndoe>, <User: test1>, <User: test2>]

This user is created in tests/regressiontests/utils/simplelazyobject.py,
but not destroyed afterwards.

It is possible this is as a result of using unittest.TestCase instead
of django.test.TestCase

Thanks
--
Brian May <email address hidden>

Changed in python-django (Debian):
importance: Undecided → Unknown
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in python-django (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package python-django - 1.5.4-1ubuntu1

---------------
python-django (1.5.4-1ubuntu1) saucy; urgency=low

  * Pull patch from git to isolate a DB test in testsuite (LP: #1231923)
 -- Adam Conrad <email address hidden> Fri, 27 Sep 2013 04:51:31 -0600

Changed in python-django (Ubuntu):
status: Confirmed → Fix Released
Changed in python-django (Debian):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.