Rebuild with Python 2.7

Bug #670188 reported by Alessio Treglia on 2010-11-03
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
python-distutils-extra
Undecided
Unassigned
python-distutils-extra (Ubuntu)
Medium
Barry Warsaw

Bug Description

Binary package hint: python-distutils-extra

Please apply the attached patch to rebuild this package with Python 2.7 in natty.

Related branches

Alessio Treglia (quadrispro) wrote :
Changed in python-distutils-extra (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Changed in python-distutils-extra (Ubuntu):
milestone: none → natty-alpha-2
Barry Warsaw (barry) wrote :

It's not clear to me that a no-change rebuild will work. I'm seeing test failures against Python 3.2 in my sbuild. Investigating.

Barry Warsaw (barry) wrote :

The test was failing for me because I happen to have $PYTHONPATH in my environment. I think test/auto.py could do a better job of sanitizing $PYTHONPATH in that case. Branch pushed. I'll link it to this bug report, submit a merge proposal, and get pitti to review + commit.

Changed in python-distutils-extra (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Barry Warsaw (barry)
Martin Pitt (pitti) wrote :

See my comments in the merge proposal. I'll just do a rebuild for now to fix this bug.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package python-distutils-extra - 2.22-3

---------------
python-distutils-extra (2.22-3) unstable; urgency=low

  [ Martin Pitt ]
  * auto.py: Skip setup.py when calculating automatic requires, since
    modules from that script are just build dependencies. Thanks Michael
    Terry! (LP: #643655)
  * python-mkdebian: Update python-mkdebian's generated copyright fields with
    latest names/values from http://dep.debian.net/deps/dep5/. Thanks Michael
    Terry!
  * Rebuild against Python 2.7 in Ubuntu. (LP: #670188)

  [ Didier Roche ]
  * Return an error when can't update changelog (LP: #656950)
  * Add --force-copyright to force copyright file to be recreated
    (LP: #656943)
 -- Martin Pitt <email address hidden> Wed, 03 Nov 2010 22:37:27 -0400

Changed in python-distutils-extra (Ubuntu):
status: In Progress → Fix Released
Martin Pitt (pitti) on 2010-11-04
Changed in python-distutils-extra:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Patches