backport dh_python2 to lucid (and maverick if appropriate)

Bug #788524 reported by Matthias Klose on 2011-05-26
124
This bug affects 20 people
Affects Status Importance Assigned to Milestone
OpenStack Core Infrastructure
Fix Released
Critical
Monty Taylor
python-defaults (Ubuntu)
High
Unassigned

Bug Description

dh_python2 should be backported to lucid to ease backporting of python modules to lucid.

 - dh_python2 is a helper, only used at package build time
 - the two scripts pycompile and pyclean will see (upward compatible) updates
 - dh_python2 is currently only used by a handful of packages in lucid, so these
   existing pycompile/pyclean uses should be checked.

Matthias Klose (doko) wrote :

update of modules needed for pycompile/pyclean is tracked in bug #788525

Matthias Klose (doko) on 2011-05-26
Changed in python-defaults (Ubuntu):
status: New → In Progress
tags: added: pycentral-deprecation
Barry Warsaw (barry) on 2011-08-22
Changed in python-defaults (Ubuntu):
importance: Undecided → High
assignee: nobody → Barry Warsaw (barry)
Monty Taylor (mordred) on 2011-08-26
Changed in openstack-ci:
importance: Undecided → Critical
status: New → Triaged
assignee: nobody → Monty Taylor (mordred)
Barry Warsaw (barry) wrote :

<doko> hmm, I have a package here, but not yet finished [09:53]
<barry> it's a backport? from? to? if you want me to look at it and/or
        finish it up and test it, i'd be happy to. [09:55]
<doko> I'll finish it this week. yes, review would be nice
<barry> cool. so do you want me to hand bug 788524 over to you then? [09:56]
<doko> sure [09:57]

Changed in python-defaults (Ubuntu):
assignee: Barry Warsaw (barry) → Matthias Klose (doko)
Monty Taylor (mordred) wrote :

After a discussion on #ubuntu-server, openstack is taking the approach of adding this to the top of debian/rules:

WITH_PYTHON2 = $(shell test -f /usr/bin/dh_python2 && echo "--with python2")

And then using dh in the following way:

dh ${WITH_PYTHON2}

which has the effect of allowing us to use dh_python2 on systems that have it (natty and beyond) and falling back to python-support on pre-natty systems. So far all looks good, so our vested interest here is taken care of.

Changed in openstack-ci:
status: Triaged → Fix Released
Rolf Leggewie (r0lf) wrote :

any progress on the backport?

John S. Gruber (jsjgruber) wrote :

Is this still on the agenda?

pi-rho (pi-rho) wrote :

I use this for cdbs:

DEB_PYTHON_SYSTEM = $(if $(wildcard /usr/bin/dh_python2),,pysupport)

From what I can find, debian's python_2.6.5-1 contains dh_python2, but lucid has python_2.6.5-0ubuntu1, which doesn't have it. Any chance in sync'ing?

python:
  Installed: 2.6.5-0ubuntu1
  Candidate: 2.6.5-0ubuntu1
  Version table:
 *** 2.6.5-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ lucid/main Packages
        100 /var/lib/dpkg/status

Changed in python-defaults (Ubuntu):
status: In Progress → Confirmed
Barry Warsaw (barry) wrote :

Marking Won't Fix. After discussing with Matthias in IRC, the problem is that to backport it to Lucid would require also backporting it to all later releases, and realistically nobody has the spare resources to do all that work.

Changed in python-defaults (Ubuntu):
status: Confirmed → Won't Fix
assignee: Matthias Klose (doko) → nobody

This also affects dajax and dajaxice. It requieres > 2.6.6-3

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers