[Lucid] pycompile tries to use python 2.5

Bug #648620 reported by Dmitry Tantsur on 2010-09-27
This bug affects 1 person
Affects Status Importance Assigned to Milestone
python-defaults (Ubuntu)

Bug Description

$ pycompile agent/ibd3agent.py
/bin/sh: python2.5: not found

$ pycompile -p logging
/bin/sh: python2.5: not found
ERROR:pycompile:cannot get content of logging

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: python-minimal 2.6.5-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-24.43-generic
Uname: Linux 2.6.32-24-generic i686
Architecture: i386
Date: Mon Sep 27 12:55:07 2010
InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release i386 (20100816.1)
PackageArchitecture: all
SourcePackage: python-defaults

Dmitry Tantsur (divius) wrote :
Dmitry Tantsur (divius) wrote :

Problem is that pycompile has wrong default version (2.5). So this works:
$ pycompile -V 2.6 agent/ibd3agent.py

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers