Failed piuparts at purge because does not remove pyversions.pyc

Bug #1054442 reported by Mitsuya Shibata
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
python-defaults (Ubuntu)
Undecided
Unassigned

Bug Description

python package fail piuparts at "Installation and purging test".
There is no this failure at debian/sid.

How to reproduce:
$ sudo piuparts --apt --no-eatmydata -d quantal python -l python-install.log

---
2m14.2s ERROR: FAIL: After purging files have disappeared:
  /usr/share/python/pyversions.pyc not owned

2m14.2s ERROR: FAIL: Installation and purging test.
---

Related branches

Revision history for this message
Mitsuya Shibata (cosmos-door) wrote :
Revision history for this message
Mitsuya Shibata (cosmos-door) wrote :

/usr/share/python/pyversions.py is included in python-minimal.

Ubuntu package:
- make symbolic link /usr/bin/pyversions to pyversions.py in package of "python" (see debian/rules).
- remove /usr/share/python/*.py[co] at prerm of "python-minimal".
- remove /usr/share/python/pyversions.py[co] at prerm only with "remove" state of "python".
- debootstrap install "python-minimal" in base.tgz, therefore python-minimal.prerm is *not* executed in piuparts.

Ubuntu package:
- make symbolic link /usr/bin/pyversions to pyversions.py in package of "python-minimal" (see debian/rules).
- remove /usr/share/python/*.py[co] at prerm of "python-minimal".
- remove /usr/share/python/pyversions.py[co] at prerm only with "remove" state of "python".
- debootstrap *does not* install "python-minimal" in base.tgz, therefore python-minimal.prerm is executed in piuparts.

lp:~cosmos-door/ubuntu/quantal/python-defaults/fix-for-1054442
is remove /usr/share/python/pyversions.py[co] with purge option same as "apt-get remove".

tags: added: patch
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package python-defaults - 2.7.3-0ubuntu6

---------------
python-defaults (2.7.3-0ubuntu6) quantal; urgency=low

  * Remove pyversions.py[co] at purge command too (LP: #1054442)
 -- Mitsuya Shibata <email address hidden> Sat, 22 Sep 2012 13:12:14 +0900

Changed in python-defaults (Ubuntu):
status: New → Fix Released
Revision history for this message
Dmitry Shachnev (mitya57) wrote :

I've submitted this change to Debian, but it is going to be reverted because according to Section 6.5 of the Debian Policy (http://www.debian.org/doc/debian-policy/ch-maintainerscripts.html), prerm is called only as:

- prerm remove
- prerm upgrade […]
- prerm remove in-favour […]
- prerm deconfigure in-favour […]

It never gets called as `prerm purge`. I believe this is the case in Ubuntu as well, so I see no reason to keep this change in our delta.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers