Python upgrade errors

Bug #58915 reported by Eli Miller on 2006-09-04
54
Affects Status Importance Assigned to Milestone
python-central (Ubuntu)
High
Michael Vogt
python2.3 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: update-manager

I guess I have to wait until the bug report is created before attaching the log files.

Here are the errors the dialog provided me:

Could not install 'python2.3'

The upgrade aborts now. Please report this bug against the 'update-manager' package and include the files in /var/log/dist-upgrade/ in the bugreport.

subprocess post-installation script returned error exit status 1

--
Could not install 'python2.3-dev'

The upgrade aborts now. Please report this bug against the 'update-manager' package and include the files in /var/log/dist-upgrade/ in the bugreport.

dependency problems - leaving unconfigured

--
Could not install the upgrades

The upgrade aborts now. Your system could be in an unusable state. A recovery was run (dpkg --configure -a).

Please report this bug against the 'update-manager' package and include the files in /var/log/dist-upgrade/ in the bugreport.

installArchives() failed

Eli Miller (elijah-miller) wrote :
Eli Miller (elijah-miller) wrote :
Eli Miller (elijah-miller) wrote :
Michael Vogt (mvo) wrote :

Thanks for your bugreport.

This looks like a problem with python2.3 during the upgrade. Can you please attach the file '/var/log/dist-upgrade/main.log' and '/var/log/dist-upgrade/term.log' as well to make it easier for us to debug the problem?

Thanks,
 Michael

Changed in update-manager:
importance: Untriaged → High
Eli Miller (elijah-miller) wrote :

Odd, I attached all three log files from /var/log/dist-upgrade. Even received 3 email notifications about it!

Eli Miller (elijah-miller) wrote :
Eli Miller (elijah-miller) wrote :

I see what happened now. This comment listing is not showing all of the file attachments for some reason. If you look on the right side under "Bug Attachments" you can see that I've now duplicated term.log and main.log.

I can confirm this bug:

jb@tuxhome:~$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
Need to get 0B of archives.
After unpacking 0B of additional disk space will be used.
Setting up python2.3 (2.3.5-15ubuntu1) ...
byte-compiling files for package python2.3...
Linking and byte-compiling packages for runtime python2.3...
pycentral: pycentral rtinstall: installed runtime python2.3 not found
pycentral rtinstall: installed runtime python2.3 not found
dpkg: error processing python2.3 (--configure):
 subprocess post-installation script returned error exit status 1
Errors were encountered while processing:
 python2.3
E: Sub-process /usr/bin/dpkg returned an error code (1)

Toby Irvine (ubuntu-zakalwe) wrote :

I can also confirm, after dist-upgrading to edgy from a fully updated dapper today. python-wxglade also failing to configure, looks related:

---- Start console output ----
dev@dev-laptop:~$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree... Done
0 upgraded, 0 newly installed, 0 to remove and 35 not upgraded.
2 not fully installed or removed.
Need to get 0B of archives.
After unpacking 0B of additional disk space will be used.
Setting up python-wxglade (0.4.1-1) ...
Traceback (most recent call last):
  File "/usr/bin/pycentral", line 1325, in ?
    main()
  File "/usr/bin/pycentral", line 1319, in main
    rv = action.run(global_options)
  File "/usr/bin/pycentral", line 855, in run
    pkg.set_default_runtime_from_version_info()
  File "/usr/bin/pycentral", line 529, in set_default_runtime_from_version_info
    versions = list(pyversions.requested_versions(self.version_field, version_only=True))
  File "/usr/share/python/pyversions.py", line 113, in requested_versions
    raise ValueError, 'empty set of versions'
ValueError: empty set of versions
dpkg: error processing python-wxglade (--configure):
 subprocess post-installation script returned error exit status 1
Setting up python2.3 (2.3.5-15ubuntu1) ...
byte-compiling files for package python2.3...
Linking and byte-compiling packages for runtime python2.3...
pycentral: pycentral rtinstall: installed runtime python2.3 not found
pycentral rtinstall: installed runtime python2.3 not found
dpkg: error processing python2.3 (--configure):
 subprocess post-installation script returned error exit status 1
Errors were encountered while processing:
 python-wxglade
 python2.3
E: Sub-process /usr/bin/dpkg returned an error code (1)
---- End console output ----

The 35 not upgraded are:

beagle beagle-backend-evolution eric hpijs python-adns python-clientcookie python-crypto python-gadfly python-htmlgen python-htmltmpl python-imaging python-imaging-sane python-jabber python-kde3 python-kjbuckets python-ldap python-mysqldb python-pam python-pexpect python-pgsql python-profiler python-pygame python-pylibacl python-pyopenssl python-pyxattr python-qt3 python-qtext python-reportlab python-simpletal python-soappy python-sqlite python-syck python-xmpp sketch x-window-system-core

Michael Vogt (mvo) on 2006-09-11
Changed in python2.3:
assignee: nobody → doko
status: Unconfirmed → Confirmed

I can confirm this:

(Lese Datenbank ... 164948 Dateien und Verzeichnisse sind derzeit installiert.)
Entferne python2.3 ...
Unlinking and removing bytecode for runtime python2.3...
pycentral: pycentral rtremove: installed runtime python2.3 not found
pycentral rtremove: installed runtime python2.3 not found
dpkg: Fehler beim Bearbeiten von python2.3 (--remove):
 Unterprozess pre-removal script gab den Fehlerwert 1 zurück
Fehler traten auf beim Bearbeiten von:
 python2.3
E: Sub-process /usr/bin/dpkg returned an error code (1)

jkuhnert (jkuhnert) wrote :

Yep...Happened to me as well. If a confirmable ubuntu dev needs a login to be able to re-produce this let me know.

Confirmed here, too. Upgrade to Edgy from dapper went well. Except "sudo aptitude dist-upgrade" shows this for Python 2.3 and Python 2.3-imaging:

unclespellbinder@Wombat:~$ sudo aptitude dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Building tag database... Done
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B of archives. After unpacking 0B will be used.
Setting up python2.3 (2.3.5-15ubuntu1) ...
byte-compiling files for package python2.3...
Linking and byte-compiling packages for runtime python2.3...
pycentral: pycentral rtinstall: installed runtime python2.3 not found
pycentral rtinstall: installed runtime python2.3 not found
dpkg: error processing python2.3 (--configure):
 subprocess post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of python2.3-imaging:
 python2.3-imaging depends on python2.3; however:
  Package python2.3 is not configured yet.
dpkg: error processing python2.3-imaging (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 python2.3
 python2.3-imaging
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:
Setting up python2.3 (2.3.5-15ubuntu1) ...
byte-compiling files for package python2.3...
Linking and byte-compiling packages for runtime python2.3...
pycentral: pycentral rtinstall: installed runtime python2.3 not found
pycentral rtinstall: installed runtime python2.3 not found
dpkg: error processing python2.3 (--configure):
 subprocess post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of python2.3-imaging:
 python2.3-imaging depends on python2.3; however:
  Package python2.3 is not configured yet.
dpkg: error processing python2.3-imaging (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 python2.3
 python2.3-imaging
unclespellbinder@Wombat:~$

Dave Hall (skwashd) wrote :

Same here. I have been running edgy for since late July. I tried to install scribus-ng which depends on python2.3 and the python2.3 package is broken, as above.

It can't be removed/purged even using dpkg. Here is what i get when trying to remove it.

$ sudo dpkg -P --force-all python2.3
(Reading database ... 185658 files and directories currently installed.)
Removing python2.3 ...
Unlinking and removing bytecode for runtime python2.3...
pycentral: pycentral rtremove: installed runtime python2.3 not found
pycentral rtremove: installed runtime python2.3 not found
dpkg: error processing python2.3 (--purge):
 subprocess pre-removal script returned error exit status 1
Errors were encountered while processing:
 python2.3

Michael Vogt (mvo) wrote :

Hi Matthias,

attached is a debdiff for a fix that turns the error into a warning and that should fix the issue. Please review. If you like it I will upload it tomorrow.

Cheers,
 Michael

Changed in python2.3:
status: Confirmed → In Progress
tonfa (bboissin) wrote :

It doesn't work because pycentral puts /usr/share/python before /usr/share/pycentral-data and /usr/share/python already has a pyversion.py (from python-minimal), so it won't load the right module.

regards,

Benoit

Michael Vogt (mvo) wrote :

Oh, the joy of code duplication :(

I uploaded a updated python-minimal now as well with the same set of changes. Lets that should fixe the issue.

Michael Vogt (mvo) wrote :

I reject that task against python2.3 because it turned out that is only a python-central/python-minimal issue

Changed in python2.3:
status: Unconfirmed → Rejected
Michael Vogt (mvo) wrote :

The latest upload of python-defaults should have fixed it (fingers crossed). I set it to "commited" until it makes it to the archive and I get a confirmation for the fix.

Changed in python-central:
assignee: doko → mvo
status: In Progress → Fix Committed
Susan Cragin (susancragin) wrote :

Just re-installed using today's Flight 3. Install completed at 12:00 noon EST, USA. Bug not fixed.
Machine Acer Ferrari 4005 AMD64. Selected all default options.
After re-boot, synaptic package manager gives me the following:

E: /var/cache/apt/archives/python-apt_0.6.19ubuntu5_amd64.deb: subprocess new pre-removal script returned error exit status 1

Will try again at about 3:00 EST.

Kraemer (djkraemer) wrote :

As of 12:35 pm EDT, I can't confirm this bug has been fixed.

I attempted after an apt-get update.

Micah Cowan (micahcowan) wrote :

I can't confirm fix either. In fact, I can confirm it's broken.

The pre-rm script involves pycentral, which attempts to invoke a nonexistant method "old_versions" from pyversions.

Since the call only exists so pycentral can emit some warnings, and doesn't affect actual program logic, I commented out the call, replacing it with an empty array, to "fix" the upgrade.

I can confirm this bug as well. But I also seem to be getting it from the file
/var/cache/apt/archives/python-pisock_0.12.1-3_i386.deb

Going by what Micah said, I guess that if old_versions method is corrected, both files will be fixed.

Michael Vogt (mvo) wrote :

Yeah, the fix is in progress, it should be availalbe soon.

Robert (robertabraham82) wrote :

I'm glad that these has been reported. Hope it gets fixed. What else should I do to help. But I can't code.

Kraemer (djkraemer) wrote :

Robert:

The fix is already in progress. You did your part by making it here to report the bug.

Cheers

Around 3:50 PM, I did an apt-get update, and the changes were up.

The following packages will be upgraded:
  python python-apt python-central python-examples python-minimal python-pisock

The upgrade now continues for me and gets past these. (It errors on another part, unrelated to this bug)

I can confirm this particular bug is FIXED.

Kraemer (djkraemer) wrote :

At 4:18 pm EDT, i too did and apt-get update and installed the packages listed above.

I can also confirm that this bug is FIXED.

Cheers and thank you.

Daniel T Chen (crimsun) on 2006-09-20
Changed in python-central:
status: Fix Committed → Fix Released
Giuped (giuped) wrote :

I have this error:
excuse me for log in italian

Conf python-gtk-1.2 (0.6.12-5) ...
Traceback (most recent call last):
  File "/usr/sbin/update-python-modules", line 279, in ?
    process(basedir,install_modules(py_installed))
  File "/usr/sbin/update-python-modules", line 150, in process
    func(basedir, dir, file)
  File "/usr/sbin/update-python-modules", line 117, in install_modules_f
    raise "Trying to overwrite %s which is already provided by %s"%(os.p (dir,file),otherdir)
Trying to overwrite pygtk.py which is already provided by /usr/share/pyt ort/python-gobject
dpkg: errore processando python-gtk-1.2 (--configure):
 il sottoprocesso post-installation script ha restituito un codice di er
dpkg: problemi con le dipendenze impediscono la configurazione di python .2:
 python-glade-1.2 dipende da python-gtk-1.2 (= 0.6.12-5); comunque:
  Package python-gtk-1.2 is not configured yet.
dpkg: errore processando python-glade-1.2 (--configure):
 problemi con le dipendenze - lasciato non configurato
Sono occorsi degli errori processando:
 python-gtk-1.2
 python-glade-1.2

Bastanteroma (bastanteroma) wrote :

And I still get what seems to be the same error.

vanya@vanya:~$ sudo aptitude upgrade
Reading package lists... Done
Building dependency tree... Done
Initializing package states... Done
Building tag database... Done
No packages will be installed, upgraded, or removed.
0 packages upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B of archives. After unpacking 0B will be used.
Setting up python-gtk-1.2 (0.6.12-5) ...
Traceback (most recent call last):
  File "/usr/sbin/update-python-modules", line 281, in ?
    process(basedir,install_modules(py_installed))
  File "/usr/sbin/update-python-modules", line 154, in process
    func(basedir, dir, file)
  File "/usr/sbin/update-python-modules", line 121, in install_modules_func
    raise "Trying to overwrite %s which is already provided by %s"%(os.path.join(dir,file),otherdir)
Trying to overwrite pygtk.py which is already provided by /usr/share/python-support/python-gobject
dpkg: error processing python-gtk-1.2 (--configure):
 subprocess post-installation script returned error exit status 1
Errors were encountered while processing:
 python-gtk-1.2
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:
Setting up python-gtk-1.2 (0.6.12-5) ...
Traceback (most recent call last):
  File "/usr/sbin/update-python-modules", line 281, in ?
    process(basedir,install_modules(py_installed))
  File "/usr/sbin/update-python-modules", line 154, in process
    func(basedir, dir, file)
  File "/usr/sbin/update-python-modules", line 121, in install_modules_func
    raise "Trying to overwrite %s which is already provided by %s"%(os.path.join(dir,file),otherdir)
Trying to overwrite pygtk.py which is already provided by /usr/share/python-support/python-gobject
dpkg: error processing python-gtk-1.2 (--configure):
 subprocess post-installation script returned error exit status 1
Errors were encountered while processing:
 python-gtk-1.2

Michael Vogt (mvo) wrote :

@Bastanteroma: that one is yet another different bug in python-central (or python-gtk-1.2/python-goject depends on how you look at it). If it was not reported already it should be filed as a new bug.

Michael Vogt (mvo) wrote :

the python-gtk-1.2 issue seems to be reported in #61323 already.

Matthias Klose (doko) wrote :

this is python-support ...

Michael Vogt (mvo) wrote :

@Matthias Klose: urgs, I'm very sorry for confusing this :/

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers