Does not honor XS-Python-Version if debian/control contains a empty line before the Source: line

Bug #507842 reported by Michael Vogt on 2010-01-15
46
This bug affects 6 people
Affects Status Importance Assigned to Milestone
at-spi (Ubuntu)
Undecided
Unassigned
python-central (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: python-central

It looks like the binary Python-Version is no longer honored. To reproduce:
# apt-get install python2.4
# apt-get install python-pyatspi
Setting up python-pyatspi (1.29.5-0ubuntu2) ...
Compiling /usr/lib/python2.4/site-packages/pyatspi/__init__.py ...
  File "/usr/lib/python2.4/site-packages/pyatspi/__init__.py", line 42
    finally:
          ^
SyntaxError: invalid syntax

pycentral: pycentral pkginstall: error byte-compiling files (7)
pycentral pkginstall: error byte-compiling files (7)
dpkg: error processing python-pyatspi (--configure):
 subprocess installed post-installation script returned error exit status 1
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
Processing triggers for python-support ...
Errors were encountered while processing:
 python-pyatspi
E: Sub-process /usr/bin/dpkg returned an error code (1)

# apt-cache show python-pyatspi|grep Python-Ver
Python-Version: 2.5, 2.6

*but*

# grep python-version /usr/share/pyshared-data/python-pyatspi
python-version = all

And that is considered authorative when pycentral does the "read_version_info()" call.

Michael Vogt (mvo) wrote :
summary: - Does not honor XB-Python-Version
+ Does not honor XS-Python-Version if debian/control contains a empty line
+ before the Source: line
Changed in python-central (Ubuntu):
status: New → Confirmed
importance: Undecided → Medium
Michael Vogt (mvo) wrote :

I add a at-spi task because it needs a rebuild against the fixed python-central.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package python-central - 0.6.11ubuntu11

---------------
python-central (0.6.11ubuntu11) lucid; urgency=low

  * dh_pycentral:
    - fix incorrect generation of python-version information
      if the control file contains a empty line before the
      Source stanza (LP: #507842)
 -- Michael Vogt <email address hidden> Fri, 15 Jan 2010 11:03:11 +0100

Changed in python-central (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package at-spi - 1.29.5-0ubuntu3

---------------
at-spi (1.29.5-0ubuntu3) lucid; urgency=low

  * rebuild against fixed python-central (LP: #507842)
 -- Michael Vogt <email address hidden> Fri, 15 Jan 2010 14:07:52 +0100

Changed in at-spi (Ubuntu):
status: New → Fix Released
Bowmore (bowmore) wrote :

Confirmed, this fixed my problem!

As I installed python 2.4 earlier after reinstalling python-pyatspi I tested this now just by reinstalling python-pyatspi

Thus,
apt-get install --reinstall python-pyatspi
gave no errors.

ellisrubio (ellisrubio) on 2010-01-18
Changed in at-spi (Ubuntu):
status: Fix Released → In Progress
Michael Vogt (mvo) wrote :

@ellisrubio: hello - why did you reopen the at-spi task?

Loïc Minier (lool) wrote :

Please don't reopen bugs without a comment; thanks!

Changed in at-spi (Ubuntu):
status: In Progress → Fix Released
Anand Kumria (wildfire) wrote :

This has regressed. Both of these are later versions than mentioned above.

eve:[~]% apt-cache policy python-central
python-central:
  Installed: 0.6.11ubuntu12
  Candidate: 0.6.11ubuntu12
  Version table:
 *** 0.6.11ubuntu12 0
        500 http://uk.archive.ubuntu.com lucid/main Packages
        100 /var/lib/dpkg/status

eve:[~]% apt-cache policy at-spi
at-spi:
  Installed: 1.29.90-0ubuntu1
  Candidate: 1.29.90-0ubuntu1
  Version table:
 *** 1.29.90-0ubuntu1 0
        500 http://uk.archive.ubuntu.com lucid/main Packages
        100 /var/lib/dpkg/status

eve:[~]% sudo dpkg -a --configure
Setting up libvirt-bin (0.7.5-5ubuntu7) ...
useradd: cannot lock /etc/passwd; try again later.
adduser: `/usr/sbin/useradd -d /var/lib/libvirt -g kvm -s /bin/false -u 148 libvirt-qemu' returned error code 1. Exiting.
dpkg: error processing libvirt-bin (--configure):
 subprocess installed post-installation script returned error exit status 1
Setting up python-pyatspi (1.29.90-0ubuntu1) ...
Compiling /usr/lib/python2.4/site-packages/pyatspi/__init__.py ...
  File "/usr/lib/python2.4/site-packages/pyatspi/__init__.py", line 50
    finally:
          ^
SyntaxError: invalid syntax

pycentral: pycentral pkginstall: error byte-compiling files (6)
pycentral pkginstall: error byte-compiling files (6)
dpkg: error processing python-pyatspi (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of gnome-orca:
 gnome-orca depends on python-pyatspi (>= 1.22.0) | python-pyatspi2; however:
  Package python-pyatspi is not configured yet.
  Package python-pyatspi2 is not installed.
dpkg: error processing gnome-orca (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libvirt-bin
 python-pyatspi
 gnome-orca

Changed in python-central (Ubuntu):
status: Fix Released → In Progress
Changed in at-spi (Ubuntu):
status: Fix Released → In Progress
Michael Vogt (mvo) wrote :

It appears that this got broken again with the most recent 0.6.11ubuntu12 upload. This is unfortunate as the packages that got rebuild since will need a rebuild (the change affects builds only, not runtime).

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package python-central - 0.6.11ubuntu13

---------------
python-central (0.6.11ubuntu13) lucid; urgency=low

  * Skip comments when parsing debian/control; thanks Michael Vogt;
    LP: #507842.
 -- Loic Minier <email address hidden> Wed, 10 Feb 2010 13:45:32 +0100

Changed in python-central (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package at-spi - 1.29.90-0ubuntu2

---------------
at-spi (1.29.90-0ubuntu2) lucid; urgency=low

  * rebuild against latest python-central after regression (LP: #507842)
 -- Michael Vogt <email address hidden> Wed, 10 Feb 2010 13:56:24 +0100

Changed in at-spi (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers