py_compilefiles shows error during byte-compiling files on setting up installed package

Bug #366304 reported by Ivan Zorin on 2009-04-24
32
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Ubuntu One Client
Undecided
Unassigned
gnome-orca
Invalid
Undecided
Unassigned
python-central (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: python-central

Hello. I use Jaunty and i've updated my system from RC to release;
after that I've tried to update system with few new packages.
Most of them have been successfully installed, but on gwibber I've got error.
(gwibber it's twitter client; https://launchpad.net/gwibber)
Trying to fix it, I've run:
> sudo dpkg --configure -a
Setting up gwibber (0.9.2~bzr263-0ubuntu1~jaunty) ...
  File "/usr/bin/py_compilefiles", line 27
    print "file does not exist:", fullname
                               ^
SyntaxError: invalid syntax
pycentral: pycentral pkginstall: error byte-compiling files (36)
pycentral pkginstall: error byte-compiling files (36)
dpkg: error processing gwibber (--configure):
 subprocess post-installation script returned error exit status 1
Errors were encountered while processing:
 gwibber

Also, I think that this bug LP #354228 can be used as related, according to this comment:
https://bugs.launchpad.net/ubuntu/intrepid/+source/python2.6/+bug/354228/comments/30

Thanks in advance and I will be very appreciate for any workaround about this issue.

DaNmarner (danmarner) wrote :

I am having the same issue!

Darryl Pogue (dpogue) wrote :

This is also an issue on Karmic with both Python 2.6 and Python 3.1 installed.

Setting up python-lazr-restfulclient (0.9.3-0ubuntu3) ...
  File "/usr/bin/py_compilefiles", line 27
    print "file does not exist:", fullname
                               ^
SyntaxError: invalid syntax
pycentral: pycentral pkginstall: error byte-compiling files (27)
pycentral pkginstall: error byte-compiling files (27)
dpkg: error processing python-lazr-restfulclient (--configure):
 subprocess installed post-installation script returned error exit status 1
Setting up python-pyatspi (1.27.92-0ubuntu1) ...
  File "/usr/bin/py_compilefiles", line 27
    print "file does not exist:", fullname
                               ^
SyntaxError: invalid syntax
pycentral: pycentral pkginstall: error byte-compiling files (6)
pycentral pkginstall: error byte-compiling files (6)
dpkg: error processing python-pyatspi (--configure):
 subprocess installed post-installation script returned error exit status 1

DaNmarner (danmarner) wrote :
Download full text (19.1 KiB)

And it's not a small problem once you get this many failed packages, I'm using 9.10 BTW.

sudo dpkg --configure -a
Setting up python-tz (2009g-1) ...
  File "/usr/bin/py_compilefiles", line 27
    print "file does not exist:", fullname
                               ^
SyntaxError: invalid syntax
pycentral: pycentral pkginstall: error byte-compiling files (575)
pycentral pkginstall: error byte-compiling files (575)
dpkg: error processing python-tz (--configure):
 subprocess installed post-installation script returned error exit status 1
Setting up python-lazr-uri (1.0-0ubuntu1) ...
  File "/usr/bin/py_compilefiles", line 27
    print "file does not exist:", fullname
                               ^
SyntaxError: invalid syntax
pycentral: pycentral pkginstall: error byte-compiling files (17)
pycentral pkginstall: error byte-compiling files (17)
dpkg: error processing python-lazr-uri (--configure):
 subprocess installed post-installation script returned error exit status 1
Setting up python-pexpect (2.3-1) ...
  File "/usr/bin/py_compilefiles", line 27
    print "file does not exist:", fullname
                               ^
SyntaxError: invalid syntax
pycentral: pycentral pkginstall: error byte-compiling files (7)
pycentral pkginstall: error byte-compiling files (7)
dpkg: error processing python-pexpect (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of sagemath:
 sagemath depends on python-pexpect; however:
  Package python-pexpect is not configured yet.
dpkg: error processing sagemath (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python-smartpm:
 python-smartpm depends on python-pexpect; however:
  Package python-pexpect is not configured yet.
dpkg: error processing python-smartpm (--configure):
 dependency problems - leaving unconfigured
Setting up python-gnuplot (1.8-1) ...
  File "/usr/bin/py_compilefiles", line 27
    print "file does not exist:", fullname
                               ^
SyntaxError: invalid syntax
pycentral: pycentral pkginstall: error byte-compiling files (19)
pycentral pkginstall: error byte-compiling files (19)
dpkg: error processing python-gnuplot (--configure):
 subprocess installed post-installation script returned error exit status 1
Setting up python-speechd (0.6.7+git20090514-0ubuntu13) ...
  File "/usr/bin/py_compilefiles", line 27
    print "file does not exist:", fullname
                               ^
SyntaxError: invalid syntax
pycentral: pycentral pkginstall: error byte-compiling files (8)
pycentral pkginstall: error byte-compiling files (8)
dpkg: error processing python-speechd (--configure):
 subprocess installed post-installation script returned error exit status 1
dpkg: dependency problems prevent configuration of gnome-orca:
 gnome-orca depends on python-speechd (>= 0.6.2); however:
  Package python-speechd is not configured yet.
dpkg: error processing gnome-orca (--configure):
 dependency problems - leaving unconfigured
Setting up python-zconfig (2.7.1-1) ...
  File "/usr/bin/py_compilefiles", line 27
    print "file does not exist:", fullname
...

DaNmarner (danmarner) on 2009-09-14
Changed in python-central (Ubuntu):
status: New → Confirmed
Rick McBride (rmcbride) on 2009-09-22
Changed in ubuntuone-client:
status: New → Invalid
Matthias Klose (doko) on 2009-10-11
Changed in gnome-orca:
status: New → Invalid
Matthias Klose (doko) wrote :

python-central (0.6.11ubuntu9) karmic; urgency=low

  * Call py3_compilefiles when byte-compiling for python3.x.
    LP: #366304, #435003.

Changed in python-central (Ubuntu):
status: Confirmed → Fix Released
Colin Dean (colindean) wrote :

I'm still seeing this in Jaunty with 0.6.11ubuntu7.

Should I try to install 0.6.11ubuntu9 from Karmic, or could this fix make its way into backports/updates for Jaunty? It's blocking updates of python-pexpect, python-smartpm, landscape-common, gwibber, virtualbox-ose, virtualbox-ose-qt for me.

Colin Dean (colindean) wrote :

I tried the patch at https://bugs.edge.launchpad.net/ubuntu/intrepid/+source/python2.6/+bug/354228/comments/30 but I'm still getting errors.

These errors seem to be syntax errors while compiling gwibber and virtualbox-ose-qt. Perhaps Python3 is being used to compile these when they should be compiled with Python2?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers