broken update from feisty on ppc

Bug #148930 reported by jo on 2007-10-04
4
Affects Status Importance Assigned to Milestone
python-central (Ubuntu)
High
Michael Vogt
update-manager (Ubuntu)
Undecided
Unassigned

Bug Description

as i did an upgrade from feisty to gutsy the upgrade stopped and told me to report a bug.
the output i got looked different from the those in the other bug reports so i file this report
and hope it is useful. the requested logfiles should be attached.

jo (josef-kirmair) wrote :
Michael Vogt (mvo) wrote :

The problem is that pycentral does call dpkg-querry with a absolute path and the installed version of dpkg does not support the dpkg triggers status flags. This makes the pycentral scripts fail:

/usr/bin/pycentral:
            cmd = ['/usr/bin/dpkg-query', '-L', self.name]

Changed in update-manager:
importance: Undecided → High
status: New → Confirmed
Michael Vogt (mvo) wrote :

The correct dpkg that supports triggers is in $PATH, I think the correct solution here is to pre-depend in pycentral on a dpkg version that supports triggers.

Michael Vogt (mvo) on 2007-10-05
Changed in python-central:
assignee: nobody → mvo
Michael Vogt (mvo) wrote :

python-central (0.5.15ubuntu2) gutsy; urgency=low

  * debian/control:
    - add pre-depends on dpkg with trigger support (LP: #148930)

 -- Michael Vogt <email address hidden> Fri, 05 Oct 2007 17:58:13 +0200

Changed in python-central:
status: Confirmed → Fix Released

Closing as for last comment.

Changed in update-manager:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments