Deprecation warnings during server upgrade

Bug #744990 reported by Scott Kitterman on 2011-03-29
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
python-apt (Ubuntu)
Medium
Unassigned
Maverick
Medium
pehaclm@centrum.sk
Natty
Medium
Unassigned

Bug Description

Binary package hint: python-apt

TEST CASE:
1. use a maverick server install
2. run do-release-upgrade -d
3. verify that there are (fast scrolling) deprecation warnings
4. cancel the upgrade
5. install the updated update-manager from maverick-proposed
6. repeat step 2
7. verify that the warnings are gone now

Lots of warnings like:

/usr/lib/python2.6/dist-packages/apt/progress/old.py:134: DeprecationWarning: apt.progress.FetchProgress is deprecated.

I didn't catch all of them before the screen changed, so some may have referred to other files.

tags: added: iso-testing
Michael Vogt (mvo) on 2011-03-30
Changed in python-apt (Ubuntu Maverick):
status: New → In Progress
Changed in python-apt (Ubuntu Natty):
status: New → Fix Committed
Changed in python-apt (Ubuntu Maverick):
importance: Undecided → Medium
Changed in python-apt (Ubuntu Natty):
importance: Undecided → Medium
description: updated
christine (christinewhenman) wrote :

how do i remove it

Accepted update-manager into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Jay R. Wren (evarlast) wrote :

$ do-release-upgrade -d
Checking for a new ubuntu release
/usr/lib/python2.6/dist-packages/apt/progress/old.py:134: DeprecationWarning: apt.progress.FetchProgress is deprecated.
  FetchProgress.__init__(self)
/usr/lib/python2.6/dist-packages/UpdateManager/Core/DistUpgradeFetcherCore.py:202: DeprecationWarning: apt_pkg.GetAcquire() is deprecated. Please see apt_pkg.Acquire() for the replacement.
  fetcher = apt_pkg.GetAcquire(self._progress)
/usr/lib/python2.6/dist-packages/UpdateManager/Core/DistUpgradeFetcherCore.py:205: DeprecationWarning: apt_pkg.GetPkgAcqFile() is deprecated. Please see apt_pkg.AcquireFile() for the replacement
  af = apt_pkg.GetPkgAcqFile(fetcher,uri, descr=_("Upgrade tool signature"))
/usr/lib/python2.6/dist-packages/UpdateManager/Core/DistUpgradeFetcherCore.py:208: DeprecationWarning: apt_pkg.GetPkgAcqFile() is deprecated. Please see apt_pkg.AcquireFile() for the replacement
  af = apt_pkg.GetPkgAcqFile(fetcher,self.uri, descr=_("Upgrade tool"))
/usr/lib/python2.6/dist-packages/UpdateManager/Core/DistUpgradeFetcherCore.py:209: DeprecationWarning: Attribute 'Run' of the 'apt_pkg.Acquire' object is deprecated, use 'run' instead.
  if fetcher.Run() != fetcher.ResultContinue:
Done Upgrade tool signature
Done Upgrade tool
Done downloading
extracting 'natty.tar.gz'
authenticate 'natty.tar.gz' against 'natty.tar.gz.gpg'
[screen is terminating]

I just wanted to document the full errors.

I enabled proposed and this is fixed.

tags: added: verification-done
removed: verification-needed
Michael Vogt (mvo) on 2011-04-12
Changed in python-apt (Ubuntu Natty):
status: Fix Committed → Fix Released
Changed in python-apt (Ubuntu Maverick):
status: In Progress → New
Changed in python-apt (Ubuntu Maverick):
status: New → Fix Released
assignee: nobody → pehaclm@centrum.sk (pehaclm)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers