unattended-upgrade crashed with SIGSEGV in PyString_FromFormatV()

Bug #655154 reported by pliut on 2010-10-05
280
This bug affects 62 people
Affects Status Importance Assigned to Milestone
unattended-upgrades
Invalid
Medium
Unassigned
python-apt (Ubuntu)
Medium
Unassigned
Maverick
High
Unassigned

Bug Description

regression test with unattended-upgrades should be fine I don't know a way to reliable
trigger the bug

TEST CASE:
1. install maverick on i386
2. install python-apt from maverick-proposed
2. run unattended-upgrades -d
3. verify that it works and upgrades a bunch of packages

Binary package hint: unattended-upgrades

Everytime I start Ubuntu I have this bug
Ubuntu10.10 MMaverick
0.62.1 Ubuntu1 package
i have no idea what kind of problem is it, I report just because there is an alarm on desktop everytime I log on.
Paolo

ProblemType: Crash
DistroRelease: Ubuntu 10.10
Package: unattended-upgrades 0.62ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-22.33-generic-pae 2.6.35.4
Uname: Linux 2.6.35-22-generic-pae i686
Architecture: i386
Date: Sat Oct 2 09:28:52 2010
ExecutablePath: /usr/bin/unattended-upgrade
InstallationMedia: Xubuntu 10.04 "Lucid Lynx" - Release i386 (20100429)
InterpreterPath: /usr/bin/python2.6
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/unattended-upgrade
ProcEnviron:
 PATH=(custom, no user)
 SHELL=/bin/sh
SegvAnalysis:
 Segfault happened at: 0xb7477770: pcmpeqb (%esi),%xmm0
 PC (0xb7477770) ok
 source "(%esi)" (0x00000000) not located in a known VMA region (needed readable region)!
 destination "%xmm0" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: unattended-upgrades
StacktraceTop:
 ?? () from /lib/libc.so.6
 PyString_FromFormatV ()
 PyString_FromFormat ()
 ?? () from /usr/lib/python2.6/dist-packages/apt_pkg.so
 _PyObject_Str ()
Title: unattended-upgrade crashed with SIGSEGV in PyString_FromFormatV()
UserGroups:

StacktraceTop:
 __strlen_sse2 () from /lib/libc.so.6
 PyString_FromFormatV (
 PyString_FromFormat (
 acquireitem_repr (Self=0xb69c744c)
 _PyObject_Str (v=0xb69c744c) at ../Objects/object.c:425

Changed in unattended-upgrades (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Steve Langasek (vorlon) on 2010-10-21
visibility: private → public
Daniel Richard G. (skunk) wrote :

I'm seeing this crash every two or three days on a Maverick i386 system. Because unattended-upgrade is just a Python script, I believe this bug is either in Python itself, or python-apt.

Patrick G. (elgato) wrote :

Same on 2.6.35-22-virtual

unattended-upgr[9354]: segfault at 0 ip 00cc87f1 sp bfa94f0c error 4 in libc-2.12.1.so[c54000+157000]

Patrick G. (elgato) wrote :

can confirm, apport reports this error after every boot.

Changed in unattended-upgrades (Ubuntu):
status: New → Confirmed
urusha (urusha) wrote :

I'm getting this bug on many maverick machines. unattended-upgrade segfaults.
To represent just run "unattended-upgrades -d".

Michael Vogt (mvo) on 2011-01-10
Changed in unattended-upgrades:
status: New → Confirmed
importance: Undecided → Medium
Michael Vogt (mvo) wrote :

This is fixed in natty already but needs backporting to maverick.

Changed in unattended-upgrades (Ubuntu):
status: Confirmed → Fix Released
Changed in unattended-upgrades:
status: Confirmed → Invalid
affects: unattended-upgrades (Ubuntu) → python-apt (Ubuntu)
Michael Vogt (mvo) on 2011-01-10
description: updated
Changed in python-apt (Ubuntu Maverick):
status: New → In Progress
importance: Undecided → High
milestone: none → maverick-updates
Jonathan Riddell (jr) wrote :

Needs approval from ubuntu-sru, now subcribed
Needs debdiff attached

Jamie Strandboge (jdstrand) wrote :

FYI, people in bug #664514 are seeing similar issues. I've Invalidated that maverick task and pointed them here.

Nick Andrik (andrikos) wrote :

Jonathan,

Do we need a debdiff against natty version, or just the maverick one with the patch applied?
I could prepare and provide any of them.

Let me know,
Nick

Accepted python-apt into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in python-apt (Ubuntu Maverick):
status: In Progress → Fix Committed
tags: added: verification-needed
Nobuto Murata (nobuto) wrote :

python-apt 0.7.96.1ubuntu11.1/maverick-proposed works fine.

Martin Pitt (pitti) on 2011-01-15
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package python-apt - 0.7.96.1ubuntu11.1

---------------
python-apt (0.7.96.1ubuntu11.1) maverick-proposed; urgency=low

  * python/acquire-item.cc:
    - fix format string for FileSize and PartialSize to be
      long long instead of float
    - use strsprint() instead of PyString_FromFormat() because the
      later does not support %llu until python 2.7. This fixes the
      segfault LP: #655154
 -- Michael Vogt <email address hidden> Mon, 10 Jan 2011 18:54:32 +0100

Changed in python-apt (Ubuntu Maverick):
status: Fix Committed → Fix Released
tags: added: testcase
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers