gdebi crashes if the control file contains UTF-8 characters

Bug #624290 reported by Samuel Lidén Borell on 2010-08-25
76
This bug affects 12 people
Affects Status Importance Assigned to Milestone
python-apt (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: gdebi

gdebi crashes If the control file of a package contains UTF-8 characters that aren't ASCII characters. This should work according to the "Debian Policy Manual":

http://www.debian.org/doc/debian-policy/ch-controlfields.html

This is a regression from Ubuntu 10.04

ProblemType: Crash
DistroRelease: Ubuntu 10.10
Package: gdebi-core 0.6.2
ProcVersionSignature: Ubuntu 2.6.35-18.24-generic 2.6.35.3
Uname: Linux 2.6.35-18-generic i686
Architecture: i386
CheckboxSubmission: 0691bb82e1ceb52deb6ac02862ed2f80
CheckboxSystem: b845c366ea09c60efa3a45c1b5b21525
Date: Wed Aug 25 23:11:59 2010
ExecutablePath: /usr/bin/gdebi
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
InterpreterPath: /usr/bin/python2.6
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/gdebi utf8-package_1.0-1_all.deb
ProcEnviron:
 SHELL=/bin/bash
 LANG=sv_SE.utf8
PythonArgs: ['/usr/bin/gdebi', 'utf8-package_1.0-1_all.deb']
SourcePackage: gdebi
Title: gdebi crashed with UnicodeEncodeError in open()
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

Samuel Lidén Borell (samuellb) wrote :
visibility: private → public
Samuel Lidén Borell (samuellb) wrote :

This patch to python-apt appears to fix the problem.

Samuel Lidén Borell (samuellb) wrote :

Attached a test package with a UTF-8 character in it's Maintainer field.

tags: added: patch
Michael Vogt (mvo) on 2010-09-02
Changed in gdebi (Ubuntu):
status: New → In Progress
importance: Undecided → Medium
milestone: none → ubuntu-10.10-beta
affects: gdebi (Ubuntu) → python-apt (Ubuntu)
Changed in python-apt (Ubuntu):
milestone: ubuntu-10.10-beta → none

Thank you for taking the time to report this crash and helping to make Ubuntu better. This particular crash has already been reported and is a duplicate of bug #620578, so is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package python-apt - 0.7.96.1ubuntu9

---------------
python-apt (0.7.96.1ubuntu9) maverick; urgency=low

  [ Kiwinote ]
  * apt/debfile:
    - don't fail if we conflict with the pkgs we are reinstalling

  [ Michael Vogt ]
  * add "provides" property to the apt.Version objects
  * apt/debfile.py:
    - fix error when reading binary content and add regresion test
  * merged patch from Samuel Lidén Borell to fix crash if there utf8
    in the control file (LP: #624290) and add test
  * apt/cache.py:
    - add "sources_list" parameter to cache.update() to force updating
      a single sources.list entry only
  * debian/control:
    - add missing build-depends on python-debian (needed to run the
      tests for apt.debfile.DebPackage()
 -- Michael Vogt <email address hidden> Tue, 07 Sep 2010 13:47:03 +0200

Changed in python-apt (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers