LTS release has outdated Ubuntu.mirrors file

Bug #1397578 reported by PeterDaveHello on 2014-11-29
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
python-apt (Ubuntu)
Low
Unassigned
Precise
Low
Brian Murray
Trusty
Low
Brian Murray

Bug Description

Seems it was not updated from the mirror list on https://launchpad.net/ubuntu/+archivemirrors for a long time

for example, Yuan Ze University(https://launchpad.net/ubuntu/+mirror/ftp.yzu.edu.tw-archive) is not in it

PeterDaveHello (hsu-8) on 2014-11-29
description: updated
Julian Andres Klode (juliank) wrote :

Which version are you talking about? The mirror list is updated on the upload. Utopic on 2014-10-24, and vivid on 2014-09-24.

Julian Andres Klode (juliank) wrote :

Sorry, other way around.

Also what does a long time mean to you?

PeterDaveHello (hsu-8) wrote :

at least 6 months, I'm using 14.04.1 LTS

chaun (ubuntumirror) wrote :

My mirror doens't show up in Trusty either

Mirror was registered on on 2014-05-24.

My mirror is http://mirror.os6.org/ubuntu
https://launchpad.net/ubuntu/+mirror/mirror.os6.org-archive

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in python-apt (Ubuntu):
status: New → Confirmed
tags: added: trusty
summary: - outdated Ubuntu.mirrors file
+ LTS releases can have outdated Ubuntu.mirrors file
Changed in python-apt (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Low
chaun (ubuntumirror) wrote :

sad face

Brian Murray (brian-murray) wrote :

I've uploaded a new version of python-apt, which includes updated mirrors file lists, to the Trusty -proposed queue for review by the SRU team.

summary: - LTS releases can have outdated Ubuntu.mirrors file
+ LTS release has outdated Ubuntu.mirrors file
Changed in python-apt (Ubuntu Trusty):
status: New → Triaged
importance: Undecided → Low
assignee: nobody → Brian Murray (brian-murray)
Changed in python-apt (Ubuntu):
status: Triaged → Won't Fix
Changed in python-apt (Ubuntu Precise):
status: New → Triaged
importance: Undecided → Low
assignee: nobody → Brian Murray (brian-murray)
Brian Murray (brian-murray) wrote :

While I was here, I decided I might as well do Precise too.

Changed in python-apt (Ubuntu Precise):
status: Triaged → In Progress
Changed in python-apt (Ubuntu Trusty):
status: Triaged → In Progress

Hello PeterDaveHello, or anyone else affected,

Accepted python-apt into precise-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/python-apt/0.8.3ubuntu7.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in python-apt (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Brian Murray (brian-murray) wrote :

Hello PeterDaveHello, or anyone else affected,

Accepted python-apt into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/python-apt/0.9.3.5ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in python-apt (Ubuntu Trusty):
status: In Progress → Fix Committed
PeterDaveHello (hsu-8) wrote :

I still can't find this site - https://launchpad.net/ubuntu/+mirror/ftp.yzu.edu.tw-archive in /usr/share/python-apt/templates/Ubuntu.mirrors after upgrade python-apt to 0.9.3.5ubuntu1 :(

PeterDaveHello (hsu-8) wrote :

Oops, looks okay after install python-apt-common_0.9.3.5ubuntu1_all.deb, thanks!

tags: added: verification-done-trusty
Bartosz Kosiorek (gang65) wrote :

I'm unable to find package for Precise.
I enabled Proposed and it unable to install.

I tried:
   sudo apt-get install python-apt

Evenm with command:
  apt-cache policy python-apt

I'm unable to find out package from proposed.
 Can somesobe fix that?

Brian Murray (brian-murray) wrote :

The package seems to be available when I looked:

(precise-amd64)root@impulse:~# apt-cache policy python-apt
python-apt:
  Installed: (none)
  Candidate: 0.8.3ubuntu7.3
  Version table:
     0.8.3ubuntu7.3 0
        500 http://192.168.10.1/ubuntu/ precise-proposed/main amd64 Packages
     0.8.3ubuntu7.2 0
        500 http://192.168.10.1/ubuntu/ precise-updates/main amd64 Packages
     0.8.3ubuntu7 0
        500 http://192.168.10.1/ubuntu/ precise/main amd64 Packages

tags: added: verification-needed-precise
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package python-apt - 0.9.3.5ubuntu1

---------------
python-apt (0.9.3.5ubuntu1) trusty-proposed; urgency=medium

  * Rebuild to get updated mirror files. (LP: #1397578)
 -- Brian Murray <email address hidden> Tue, 06 Jan 2015 16:47:11 -0800

Changed in python-apt (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for python-apt has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Bartosz Kosiorek (gang65) wrote :

After install package from proposed, the list of packages was updated for Precise, and it is working perfectly.

tags: added: verification-done
removed: verification-needed-precise
tags: removed: verification-done-trusty
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package python-apt - 0.8.3ubuntu7.3

---------------
python-apt (0.8.3ubuntu7.3) precise-proposed; urgency=medium

  * Update list of mirrors from launchpad, using pre-build.sh hook.
    (LP: #1397578)
 -- Brian Murray <email address hidden> Tue, 06 Jan 2015 16:55:37 -0800

Changed in python-apt (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers