package python3-pytango 8.1.8-1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

Bug #1641790 reported by Nguyen Nhu Tuan on 2016-11-15
126
This bug affects 19 people
Affects Status Importance Assigned to Milestone
pytango (Debian)
Fix Released
Unknown
pytango (Ubuntu)
Medium
Unassigned
Xenial
Medium
Logan Rosen

Bug Description

python3-pytango fails to install in Xenial with the following error message:
Setting up python3-pytango (8.1.8-1) ...
  File "/usr/lib/python3/dist-packages/PyTango/tango_gevent.py", line 56
    raise result.error_string, None, result.tb
                             ^
SyntaxError: invalid syntax

dpkg: error processing package python3-pytango (--configure):
 subprocess installed post-installation script returned error exit status 1

[Test Case]
In a system running Ubuntu 16.04 (Xenial), try installing the python3-pytango package. It will fail with the above error.

[Regression Potential]
None that I can think of. This is fixing a package that can't be installed in the first place.

ProblemType: Package
DistroRelease: Ubuntu 16.04
Package: python3-pytango 8.1.8-1
ProcVersionSignature: Ubuntu 4.4.0-47.68-generic 4.4.24
Uname: Linux 4.4.0-47-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.1
Architecture: amd64
Date: Mon Nov 7 17:07:07 2016
ErrorMessage: subprocess installed post-installation script returned error exit status 1
InstallationDate: Installed on 2016-11-07 (7 days ago)
InstallationMedia: Ubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 (20160719)
RelatedPackageVersions:
 dpkg 1.18.4ubuntu1.1
 apt 1.2.12~ubuntu16.04.1
SourcePackage: pytango
Title: package python3-pytango 8.1.8-1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
UpgradeStatus: No upgrade log present (probably fresh install)

Nguyen Nhu Tuan (tuanquynh0508) wrote :
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in pytango (Ubuntu):
status: New → Confirmed

I have xubuntu 16 LTS fresh install, and python 2.7( default )
I manually installed python3.5 with everything that matches python3.* pattern(apt-get install python3.*).

Changed in pytango (Ubuntu):
importance: Undecided → Medium
Logan Rosen (logan) on 2018-12-09
Changed in pytango (Ubuntu):
status: Confirmed → Fix Released
Changed in pytango (Ubuntu Xenial):
status: New → Triaged
importance: Undecided → Medium
Changed in pytango (Debian):
status: Unknown → Fix Released
Logan Rosen (logan) on 2018-12-09
description: updated
Changed in pytango (Ubuntu Xenial):
status: Triaged → In Progress
assignee: nobody → Logan Rosen (logan)

Hello Nguyen, or anyone else affected,

Accepted pytango into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/pytango/8.1.8-1ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in pytango (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-xenial
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.