[jaunty] PyTables does not work for Python 2.6

Bug #348983 reported by Francesc Alted on 2009-03-26
104
This bug affects 15 people
Affects Status Importance Assigned to Milestone
PyTables
Fix Released
Unknown
pytables (Ubuntu)
Undecided
Unassigned
Nominated for Jaunty by Robert Jordens
Nominated for Karmic by Robert Jordens

Bug Description

Binary package hint: python-tables

The PyTables package (python-tables) is not working for Python 2.6 (the default) in my recently installed kubuntu jaunty:

$ python2.6 -c "import tables; print tables.__version__"
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "/usr/lib/python2.6/dist-packages/tables/__init__.py", line 76, in <module>
    from tables.file import File, openFile, copyFile
  File "/usr/lib/python2.6/dist-packages/tables/file.py", line 44, in <module>
    from tables import hdf5Extension
  File "hdf5Extension.pyx", line 11, in hdf5Extension
ImportError: No module named utilsExtension

However, it seems to work fine with Python 2.5:

$ python2.5 -c "import tables; print tables.__version__"
2.0.3

Here it is some version info about my setup:

faltet@kubuntu-vb:/usr/lib/xorg/modules/input$ date ; lsb_release -rd ; uname -a ; apt-cache policy python python
dj mar 26 14:34:58 CET 2009
Description: Ubuntu jaunty (development branch)
Release: 9.04
Linux kubuntu-vb 2.6.28-11-generic #37-Ubuntu SMP Mon Mar 23 16:40:00 UTC 2009 x86_64 GNU/Linux
python:
  Instal·lat: 2.6.1-0ubuntu4
  Candidat: 2.6.1-0ubuntu4
  Taula de versió:
 *** 2.6.1-0ubuntu4 0
        500 http://es.archive.ubuntu.com jaunty/main Packages
        100 /var/lib/dpkg/status
python:
  Instal·lat: 2.6.1-0ubuntu4
  Candidat: 2.6.1-0ubuntu4
  Taula de versió:
 *** 2.6.1-0ubuntu4 0
        500 http://es.archive.ubuntu.com jaunty/main Packages
        100 /var/lib/dpkg/status

Thanks!

jhn (jenshnielsen) wrote :

I have the same problem and I think that this is the relevant upstream bug.
http://www.pytables.org/trac/ticket/183
This version of this package in ubuntu is a bit old. The newest
version is 2.1.1 and I think the bug was fixed in 2.1 (from December last year)

Francesc Alted (faltet) wrote :

That's correct. In addition, PyTables 2.1.1 is strongly advised for general use.

David Fokkema (dfokkema) wrote :

May I also ask to include pytables 2.1.1 ASAP? Thanks!

(as a workaround, 2.1.1 is available using easy_install, but you need to install python-dev and libhdf5-serial-dev first)

Shashmik (philbinj) wrote :

I can confirm this problem as well. Simply running 'apt-get install python-tables' and then 'python -c "import tables"' gives:
"ImportError: No module named utilsExtension"

The package is therefore currently completely broken in jaunty. (as 2.6 is the default)

Changed in pytables:
status: Unknown → Fix Released
Kyle Beauchamp (kyleabeauchamp) wrote :

I second that--we need to get pytables 2.1.1 included as the standard package in Jaunty. As of now, the Jaunty pytables package is broken!

Jasper (nak-ed) wrote :

I am also experiencing the same bug with pytables version 2.0.3. The standard package in the Jaunty distro. Be great to get this bug fixed soon. Thanks.

Dimitri John Ledkov (xnox) wrote :

Francesc Alted the issue has been fixed in the new upstream release. You are listed as debian maintainter for the package. Would you please create / upload new version 2.1.1 to debian?

Jasper (nak-ed) wrote :

Will 2.1.1 make it as a package in Jaunty?

Depends..... It is a regregression so it should qualify for an Stable
Release Update. But it might not get accepted because it is new
release.

As a workaround it still works if you call "python2.5" instead of
"python" interpreter.

Ken Arnold (kenneth-arnold) wrote :

I just built http://web.mit.edu/kcarnold/Public/python-tables_2.1.1-1_i386.deb by running:

wget http://www.pytables.org/download/stable/tables-2.1.1.tar.gz
tar -zxvf tables-2.1.1.tar.gz
mv tables-2.1.1 pytables-2.1.1
cd pytables-2.1.1/
dch -d
dpkg-buildpackage -rfakeroot

It seems to be working, but this is completely unsupported. This still needs a proper upload (into Debian first, probably) to fix the bug.

Jasper (nak-ed) wrote :

Ken,
great info. I am not sure where on my system to put the unzipped pytables files to get this to work. Any advise welcome.

Ondrej Certik (ondrej-certik) wrote :

I followed Ken's build instructions and uploaded the packages to my PPA:

https://edge.launchpad.net/~ondrej-certik/+archive/ppa

it just works.

nicky (vanforeest) wrote :

Hi,

I also suffer from this problem. If possible I would like to see this issue solved.

As a temporary work-around, the following procedure worked for me.
- install python-dev and libhdf5-serial-dev (See one of the above mails)
- download pytables 2.1.1, untar (for instance in ~/tmp) and compile as explained in the pytables manual (but do not install as root, which is the last step in the manual)
- check the tests
- copy the directory ~/tmp/tables-2.1.1/tables to a library directory included
in PYTHONPATH. (To achieve this, I included in ~/.bash_profile the line: export PYTHONPATH=$PYTHONPATH:~/myprogs/python/:~/lib/python/:. ) Thus, I used cp -r ~/tmp/tables-2.1.1/tables ~/lib/python .

Hope this works for you too. I also installed pytables as root by running python --setup.py instal, but this did not have the desired result for some reason.

dieterv (dieterv77) wrote :

I followed the instructions on https://wiki.ubuntu.com/PackagingGuide/Complete#Ingredients
and was able to create a pytables-2.1.2 package. Unittests ran fine and i was also able to build the package using pbuilder.

Any chance that we can get a 2.1.2 package into karmic?

Jonathan Blakes (infobiotics) wrote :

dieterv, did you build it for the HDF5 1.6 or 1.8 API? Is your package available somewhere? Thanks

dieterv (dieterv77) wrote :

Jonathan, unfortunately i don't have the package posted anywhere, i just built it locally to see if it works.

I installed the libhdf5-serial-dev package (version 1.6.6) to satisfy that dependency.

hope that helps
dieter

Ryan Ren (pemryan) wrote :

ubuntu karmic 9.10 python-tables_2.0.3 is not updated to 2.1.1
this problem still exists.

Jochen Schroeder (cyco) wrote :

I also would like this bug resolved as I use pytables quite a bit and have to keep using python2.5 due to this bug.
Ubuntu Karmic 9.1 here.

Ken Arnold (kenneth-arnold) wrote :

Remember that in the interim, you can install libhdf5-serial-dev,
liblzo2-dev, and libbz2-dev, then easy_install tables. That just
worked on a fresh Karmic install.

On Sun, Nov 8, 2009 at 5:32 PM, cyco <email address hidden> wrote:
> I also would like this bug resolved as I use pytables quite a bit and have to keep using python2.5 due to this bug.
> Ubuntu Karmic 9.1 here.
>
> --
> [jaunty] PyTables does not work for Python 2.6
> https://bugs.launchpad.net/bugs/348983
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Changed in pytables (Ubuntu):
status: New → Fix Released
David Fokkema (dfokkema) wrote :

Fix released as in ... ?
  - Bug fix release uploaded?
  - New upstream version included?
  - Closed because upstream is closed? (because of a new release, but do we have it?)

Thanks!

Dimitri John Ledkov (xnox) wrote :

The new version of PyTables has entered the next development distrubtion - Lucid Lynx.

The version of the package is 2.1.2-3.

Detailed changelog is available here https://edge.launchpad.net/ubuntu/+source/pytables/2.1.2-3

Sorry for not mentioning this when updating the bug report.

Not to be nitpicking , but how does having a package in the dev version solves the bug in the 'stable' , since the default python version is 2.6 and the package for lucid depends on the hdf5 1.8 (at least, didn't check for other dependencies).
Would it be possible to have an official package for the stable version? Thanks and keep the good work!

Dimitri John Ledkov (xnox) wrote :

On 2 February 2010 23:35, Nuno Sucena Almeida <email address hidden> wrote:
> Not to be nitpicking , but how does having a package in the dev version solves the bug in the 'stable' , since the default python version is 2.6 and the package for lucid depends on the hdf5 1.8 (at least, didn't check for other dependencies).
> Would it be possible to have an official package for the stable version? Thanks and keep the good work!
>

I will look in to it deeper and I'll try to apply for Stable Release
Update to get this fix into Jaunty & Karmic. Can't promise anything =)
I'm not core-dev / motu.

--
With best regards

Dmitrijs Ledkovs (for short Dima),
Ледков Дмитрий Юрьевич

() ascii ribbon campaign - against html e-mail
/\ www.asciiribbon.org - against proprietary attachments

LinkedIn
------------

Bug,

I'd like to add you to my professional network on LinkedIn.

- Dmitrijs Ledkovs

Confirm that you know Dmitrijs Ledkovs
https://www.linkedin.com/e/isd/1067430361/80AdyfJc/

------
(c) 2010, LinkedIn Corporation

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.