Ubuntu

ImportError PySide phonon.so. undefined symbol: _ZTIN6Phonon19AbstractAudioOutputE

Reported by Boobek on 2011-10-04
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
pyside (Ubuntu)
Medium
Stefano Rivera

Bug Description

When I try to import PySide.phonon.Phonon I get the following error:
 File "/.../videowidget.py", line 6, in <module>
    from PySide.phonon import Phonon
ImportError: /usr/lib/python2.7/dist-packages/PySide/phonon.so: undefined symbol: _ZTIN6Phonon19AbstractAudioOutputE

My code is nearly perfect ('cause it's works well on Arch linux with PySide 1.0.0, Python 2.7.2) but not on Ubuntu 11.10 (python ver: 2.7.2+, PySide ver.: 1.0.6).

If someone can provide me an instant solution I would mention his/her name in my 'Who saved my live' book ;)

Related branches

Boobek (bkanyo) wrote :
Stefano Rivera (stefanor) wrote :

Confirmed. It appears that PySide's phonon extension doesn't link to libphonon

Changed in pyside (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Stefano Rivera (stefanor) wrote :

Looks like our solution to bug 832864 was bad. I think I know what to do, just doing a test build (and going to sleep while it runs)

Changed in pyside (Ubuntu):
assignee: nobody → Stefano Rivera (stefanor)
Stefano Rivera (stefanor) wrote :
Stefano Rivera (stefanor) wrote :

Uploaded, waiting for archive-admin review. I tested it by running the phonon examples from the pyside-examples git tree.

Changed in pyside (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pyside - 1.0.6.1-2ubuntu2

---------------
pyside (1.0.6.1-2ubuntu2) oneiric; urgency=low

  * Link the phonon extension to phonon (LP: #867927)
 -- Stefano Rivera <email address hidden> Wed, 05 Oct 2011 14:41:51 +0200

Changed in pyside (Ubuntu):
status: Fix Committed → Fix Released
Boobek (bkanyo) wrote :

Thank you for your fast reaction, now PySide working properly on my pc.

Balazs

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments