Error while loading shared libraries on 64-bit Ubuntu11.10

Bug #939810 reported by Leon Matthews on 2012-02-23
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
pypy (Ubuntu)
Undecided
Unassigned

Bug Description

Firstly, thank you for putting together the PPA. Being able to skip the LONG translation of pypy is a boon, thank you!

Unfortunately, running 'pypy' from the command line gives me an error:

$ pypy
pypy: error while loading shared libraries: libssl.so.1.0.0: cannot open shared object file: No such file or directory

A quick run under strace, and the problem seems to be that pypy is looking for libssl.so.1.0.0 everywhere but its actual location, which on my (vanilla) 64-bit Ubuntu 11.10 install is:

/usr/lib/x86_64-linux-gnu/libssl.so.1.0.0

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in pypy (Ubuntu):
status: New → Confirmed
Stepan Bakshaev (step2back) wrote :

problem is pypy 32bit

$ file /usr/share/pypy-1.8/bin/pypy
/usr/share/pypy-1.8/bin/pypy: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.15, stripped

but system is 64bit

$ uname -a
Linux -- 2.6.32.26 #1 SMP Thu Dec 9 15:33:24 UTC 2010 x86_64 x86_64 x86_64 GNU/Linux

I tried to install some :i386 packages, but stoped at libbz2-1.0

$ /usr/share/pypy-1.8/bin/pypy
/usr/share/pypy-1.8/bin/pypy: error while loading shared libraries: libbz2.so.1.0: wrong ELF class: ELFCLASS64

$ LANG=C sudo apt-get install libbz2-1.0:i386
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 base-files : PreDepends: awk
 base-passwd : Depends: libc6 (>= 2.8) but it is not going to be installed
 bsdutils : Depends: libc6 (>= 2.7) but it is not going to be installed
            Recommends: bsdmainutils but it is not going to be installed
 debianutils : PreDepends: libc6 (>= 2.7) but it is not going to be installed
 diffutils : PreDepends: libc6 (>= 2.4) but it is not going to be installed
 findutils : PreDepends: libc6 (>= 2.7) but it is not going to be installed
 gzip : PreDepends: libc6 (>= 2.4) but it is not going to be installed
 libbz2-1.0:i386 : Depends: libc6:i386 (>= 2.4) but it is not going to be installed
 tar : PreDepends: libc6 (>= 2.8) but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages

Stepan Bakshaev (step2back) wrote :

mmm... am i at right place? I want to report problem with pypy from https://launchpad.net/~pypy/+archive/ppa

Pi Delport (pi-delport) wrote :

Right, this is a dependency and/or multi-arch problem.

The libssl dependency can be resolved by installing the 32-bit version: apt-get install libssl1.0.0:i386

However, the remaining unmet dependencies are not so straightforward to resolve. I don't encounter a problem with libbz2 (yet), but with libtinfo instead:

$ pypy
pypy: error while loading shared libraries: libtinfo.so.5: wrong ELF class: ELFCLASS6

However, installing libtinfo5:i386 fails, because the amd64 and i386 packages conflict with each other:

$ sudo apt-get install libtinfo5:i386
...
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

$ apt-cache depends libtinfo5 libtinfo5:i386
libtinfo5
  Depends: libc6
  Conflicts: libtinfo5:i386
libtinfo5:i386
  Depends: libc6:i386
  Conflicts: libtinfo5

Pi Delport (pi-delport) wrote :

Update: Just after posting the above, i spotted that oneiric actually provides a separate lib32tinfo5 package, for 32-bit libtinfo.

Installing this seems to get PyPy running:

$ sudo apt-get install lib32tinfo5
...
$ pypy
Python 2.7.2 (2346207d99463f299f09f3e151c9d5fa9158f71b, Feb 15 2012, 17:02:59)
[PyPy 1.8.0 with GCC 4.6.1] on linux2
Type "help", "copyright", "credits" or "license" for more information.
And now for something completely different: ``things worked nicely till today
just by chance''
>>>>

Stefano Rivera (stefanor) wrote :

Closing this bug, as the issue seems to be solved, and it refers to a PPA package.

Changed in pypy (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers