[needs-packaging] pypy

Bug #867507 reported by Sidnei da Silva on 2011-10-04
86
This bug affects 15 people
Affects Status Importance Assigned to Milestone
PyPy
New
Undecided
Unassigned
pypy (Debian)
Fix Released
Unknown
pypy (Ubuntu)
Wishlist
Stefano Rivera

Bug Description

* Package name : pypy
  Version : 1.6
  Upstream Author : Armin Rigo <email address hidden>
* URL : http://www.pypy.org/
* License : MIT/X
  Programming Lang: Python
  Description : PyPy is a fast, compliant alternative implementation of the Python language.

PyPy is a fast, compliant alternative implementation of the Python language.
It has several advantages and distinct features:
 * Speed: thanks to its Just-in-Time compiler, Python programs often run faster
   on PyPy.
 * Memory usage: large, memory-hungry Python programs might end up taking less
   space than they do in CPython.
 * Compatibility: PyPy is highly compatible with existing python code. It
   supports ctypes and can run popular python libraries like twisted and
   django.
 * Sandboxing: PyPy provides the ability to run untrusted code in a fully secure
   way.
 * Stackless: PyPy can be configured to run in stackless mode, providing
   micro-threads for massive concurrency.
As well as other features.

A WNPP already exists: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=639315

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed
Changed in debian:
status: Unknown → New
Changed in debian:
status: New → Fix Committed
Changed in debian:
status: Fix Committed → Fix Released
Stefano Rivera (stefanor) wrote :
affects: ubuntu → pypy (Ubuntu)
Changed in pypy (Ubuntu):
assignee: nobody → Stefano Rivera (stefanor)
status: Confirmed → Fix Released
affects: debian → pypy (Debian)
Fake Name (lemuix-2) wrote :

Is there any chance you can add a PyPy3 version to this PPA?

Right now, there's no nice way to get system-wide installs of PyPy3 on Ubuntu that I can find.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.