Sync pype 2.9.1-1 (universe) from Debian unstable (main)

Bug #655566 reported by Andreas Noteng on 2010-10-06
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
pype (Ubuntu)
Wishlist
Unassigned
Maverick
High
Unassigned
Natty
Wishlist
Unassigned

Bug Description

Binary package hint: pype

Pype is broken in Maverick, and most likely also in lucid and maybe karmic. The package has been abandoned in Debian since 2006, but I took over maintainership of the package, and it has now been updated in unstable.
If syncing after freeze is out of the question, the package should be deleted, and reintroduced in Natty.
See bug #618246.

The Debian changelog since the current version in ubuntu:
 pype (2.9.1-1) unstable; urgency=low

   * New upstream version (closes: #598661)
   * New maintainer. (Orphaned package) (closes: #579372)
   * Changed to machine readable debian/copyright
   * Bumped standards version to 3.9.1
     - Updated menu categories
     - All control files and changelog encoded in UTF-8
   * Switched from python-central to python-support

 -- Andreas Noteng <email address hidden> Sat, 02 Oct 2010 21:35:03 +0200

description: updated
Stefano Rivera (stefanor) wrote :

I agree, completely broken, FFe not necessary.

summary: - [sync request] pype from debian unstable main
+ Sync pype 2.9.1-1 (universe) from Debian unstable (main)
Changed in pype (Ubuntu):
assignee: nobody → Stefano Rivera (stefanor)
importance: Undecided → Wishlist
status: New → In Progress

Sync request ACK'd

Changed in pype (Ubuntu):
assignee: Stefano Rivera (stefanor) → nobody
status: In Progress → Confirmed
Colin Watson (cjwatson) wrote :

Autosynced in Natty. This bug didn't receive attention in time before Maverick released, so we can't remove it from there now; perhaps somebody could figure out the nature of the breakage and propose a minimal diff per http://wiki.ubuntu.com/StableReleaseUpdates.

Unsubscribing ubuntu-archive, as the rest of this isn't an archive admin matter.

Changed in pype (Ubuntu Natty):
status: Confirmed → Fix Released
Changed in pype (Ubuntu Maverick):
status: New → Confirmed
importance: Undecided → High
Andreas Noteng (andreas-noteng) wrote :

I belive the version in Natty should be released as an SRU to Maverick. The risk of breaking something is extremely low, and the package currently in Maverick is completely broken. It is currently not possible to start PyPE in Maverick. I see no point in locating the oldest upstream version that will run in Maverick, as the current also fixes a few bugs present since hardy.

Changed in pype (Ubuntu Maverick):
milestone: none → maverick-updates
status: Confirmed → Triaged
Martin Pitt (pitti) wrote :

Agreed, SRU ack. Please feel free to upload a backport to maverick. We can't autosync it to stable releases.

Martin Pitt (pitti) wrote :

Uploaded backport.

Accepted pype into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in pype (Ubuntu Maverick):
status: Triaged → Fix Committed
tags: added: verification-needed
Andreas Noteng (andreas-noteng) wrote :

Downloaded the package from https://launchpad.net/ubuntu/maverick/+queue?queue_state=2&queue_text=
and installed. The fix seem to work (as I already knew..) and I can find no negative side-effects.
Thanks for uploading.

Martin Pitt (pitti) on 2010-11-25
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pype - 2.9.1-2~maverick1

---------------
pype (2.9.1-2~maverick1) maverick-proposed; urgency=low

  * Backport Natty version, as the maverick one is completely broken.
    As per request from Andreas Noteng (the new Debian maintainer of this
    package). (LP: #655566)

pype (2.9.1-2) unstable; urgency=low

  * command-shell.patch
     - Fix broken command shell, from upstream svn repository. (closes: #600227)
  * iterpreter.py_warning.patch
     - Fix warning when opening a command shell.

pype (2.9.1-1) unstable; urgency=low

  * New upstream version (closes: #598661)
  * New maintainer. (Orphaned package) (closes: #579372)
  * Changed to machine readable debian/copyright
  * Bumped standards version to 3.9.1
    - Updated menu categories
    - All control files and changelog encoded in UTF-8
  * Switched from python-central to python-support
 -- Martin Pitt <email address hidden> Tue, 23 Nov 2010 09:47:19 +0100

Changed in pype (Ubuntu Maverick):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers