Tk backend is broken

Bug #439433 reported by Oliver Borm
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
pyopengl (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: python-opengl

Description: Ubuntu 9.04
Release: 9.04

python-opengl:
  Installed: 3.0.0~b6-3
  Candidate: 3.0.0~b6-3
  Version table:
 *** 3.0.0~b6-3 0
        500 http://de.archive.ubuntu.com jaunty/universe Packages
        100 /var/lib/dpkg/status

If loading the Tk backend of python-opengl the following error occured:

~$ python
Python 2.6.2 (release26-maint, Apr 19 2009, 01:58:18)
[GCC 4.3.3] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import OpenGL.Tk
>>> can't invoke "event" command: application has been destroyed
    while executing
"event generate $w <<ThemeChanged>>"
    (procedure "ttk::ThemeChanged" line 6)
    invoked from within
"ttk::ThemeChanged"

>>>

And scripts which are using this backend won't work, for example: http://scipy.org/WilnaDuToit

This can be fixed, if the Togl library is installed, maybe from (https://launchpad.net/~cae-team/+archive/ppa/+packages)
So togl should be a dependency of the python-opengl package.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in pyopengl (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers