telepathy-butterfly crashed with AssertionError in send()

Bug #384181 reported by Cody A.W. Somerville on 2009-06-06
104
This bug affects 22 people
Affects Status Importance Assigned to Milestone
pymsn
Fix Released
Critical
pymsn (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: telepathy-butterfly

telepathy-butterfly likes to crash rather frequently.

ProblemType: Crash
Architecture: amd64
Date: Sat Jun 6 00:19:47 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/lib/telepathy/telepathy-butterfly
InterpreterPath: /usr/bin/python2.6
NonfreeKernelModules: nvidia
Package: telepathy-butterfly 0.3.3-2
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/lib/telepathy/telepathy-butterfly
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_CA.UTF-8
ProcVersionSignature: Ubuntu 2.6.30-8.9-generic
PythonArgs: ['/usr/lib/telepathy/telepathy-butterfly']
SourcePackage: telepathy-butterfly
Title: telepathy-butterfly crashed with AssertionError in send()
Uname: Linux 2.6.30-8-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Here again, connecting to my MSN account using Pidgin solved the problem. Pidgin warned me about some roster synchronisation issues. I guess that's why butterfly wasn't able to connect.

Oups, I spoke too fast. Actually that didn't solve anything. I still have the same error.

Binary package hint: telepathy-butterfly

telepathy-butterfly likes to crash rather frequently.

ProblemType: Crash
Architecture: amd64
Date: Sat Jun 6 00:19:47 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/lib/telepathy/telepathy-butterfly
InterpreterPath: /usr/bin/python2.6
NonfreeKernelModules: nvidia
Package: telepathy-butterfly 0.3.3-2
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/lib/telepathy/telepathy-butterfly
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_CA.UTF-8
ProcVersionSignature: Ubuntu 2.6.30-8.9-generic
PythonArgs: ['/usr/lib/telepathy/telepathy-butterfly']
SourcePackage: telepathy-butterfly
Title: telepathy-butterfly crashed with AssertionError in send()
Uname: Linux 2.6.30-8-generic x86_64
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

visibility: private → public
tags: removed: need-duplicate-check
Pedro Villavicencio (pedro) wrote :

Thanks for the report, traceback matches: https://bugs.freedesktop.org/show_bug.cgi?id=20432

affects: telepathy-butterfly (Ubuntu) → pymsn (Ubuntu)
Changed in pymsn (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Changed in pymsn:
status: Unknown → Confirmed

I think this crash is due to the command "CHG 9 2 1879048192" where "2" is an invalid status. When the server receives a wrong command, it just disconnects us. This bug was caused by tp-butterfly sending a telepahy presence instead of a papyon one (2 == Telepathy.PRESENCE_AVAILABLE). It should be fixed with papyon and tp-butterfly git master.

Changed in pymsn:
status: Confirmed → Fix Released
Changed in pymsn:
importance: Unknown → Critical
Changed in pymsn:
importance: Critical → Unknown
Changed in pymsn:
importance: Unknown → Critical
Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 430768, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.