telepathy-butterfly crashed when allowing a new contact to be added to my buddy list

Bug #283481 reported by Gert van Dijk on 2008-10-14
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
pymsn
Fix Released
Critical
pymsn (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: telepathy-butterfly

I was using Empathy for the first time after installing it in Intrepid (normally using Hardy + Pidgin) and someone seemed to have added me as a contact on my MSN account. My MSN status was 'hidden' at that moment. Empathy asked me to permit this contact to be added to my contact list. I saw the dialogue screen with his details and permitted him. At that very moment telepathy-butterfly crashed and Empathy tried to relogin to my account.
After the relogin I could see he does seem to be added to my contact list, actually.

telepathy-butterfly version: 0.3.2-1
empathy version: Version: 2.24.0-1ubuntu1

ProblemType: Crash
Architecture: amd64
DistroRelease: Ubuntu 8.10
ExecutablePath: /usr/lib/telepathy/telepathy-butterfly
InterpreterPath: /usr/bin/python2.5
Package: telepathy-butterfly 0.3.2-1
PackageArchitecture: all
ProcAttrCurrent: unconfined
ProcCmdline: /usr/bin/python /usr/lib/telepathy/telepathy-butterfly
ProcEnviron:
 SHELL=/bin/bash
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_GB.UTF-8
PythonArgs: ['/usr/lib/telepathy/telepathy-butterfly']
SourcePackage: telepathy-butterfly
Title: telepathy-butterfly crashed with AssertionError in send()
Uname: Linux 2.6.27-7-generic x86_64
UserGroups: adm admin cdrom dialout fuse lpadmin plugdev sambashare

Gert van Dijk (gertvdijk) wrote :

I got this error each time I try to connect using telepathy-butterfly

DEBUG:Transport:<<< ADL 8 OK
DEBUG:Transport:>>> CHG 9 2 1879048192
DEBUG:Transport:>>> PNG
INFO:Butterfly.Presence:Setting Presence to 'NLN'
INFO:Butterfly.Presence:Setting Personal message to ''
DEBUG:Butterfly.Aliasing:Called RequestAliases
DEBUG:Butterfly.Aliasing:Called RequestAliases
DEBUG:Butterfly.Aliasing:Called RequestAliases
DEBUG:Transport:>>> CHG 10 NLN 1879048192
Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/pymsn/util/decorator.py", line 103, in process_queue
    func(*args, **kwargs)
  File "/usr/lib/python2.5/site-packages/pymsn/msnp/notification.py", line 138, in set_presence
    (presence, str(client_id), urllib.quote(str(msn_object))))
  File "/usr/lib/python2.5/site-packages/pymsn/msnp/base.py", line 80, in _send_command
    callback, *cb_args)
  File "/usr/lib/python2.5/site-packages/pymsn/transport.py", line 208, in send_command_ex
    self.send_command(cmd, increment, callback, *cb_args)
  File "/usr/lib/python2.5/site-packages/pymsn/transport.py", line 273, in send_command
    self._transport.send(str(command), self.__on_command_sent, *our_cb_args)
  File "/usr/lib/python2.5/site-packages/pymsn/gnet/io/iochannel.py", line 157, in send
    assert(self._status == IoStatus.OPEN), self._status
AssertionError: 1

Here again, connecting to my MSN account using Pidgin solved the problem. Pidgin warned me about some roster synchronisation issues. I guess that's why butterfly wasn't able to connect.

Oups, I spoke too fast. Actually that didn't solve anything. I still have the same error.

Confirmed in Jaunty

Changed in telepathy-butterfly:
status: New → Confirmed
affects: telepathy-butterfly (Ubuntu) → pymsn (Ubuntu)
Changed in pymsn (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Changed in pymsn:
status: Unknown → Confirmed

I think this crash is due to the command "CHG 9 2 1879048192" where "2" is an invalid status. When the server receives a wrong command, it just disconnects us. This bug was caused by tp-butterfly sending a telepahy presence instead of a papyon one (2 == Telepathy.PRESENCE_AVAILABLE). It should be fixed with papyon and tp-butterfly git master.

Changed in pymsn:
status: Confirmed → Fix Released
Changed in pymsn:
importance: Unknown → Critical
Changed in pymsn:
importance: Critical → Unknown
Changed in pymsn:
importance: Unknown → Critical
Brian Murray (brian-murray) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. This particular bug has already been reported and is a duplicate of bug 430768, so it is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.