Paster or Pylons don't depend on the right python-nose

Bug #182384 reported by J. Pablo Fernández on 2008-01-12
4
Affects Status Importance Assigned to Milestone
pylons (Ubuntu)
Low
Unassigned

Bug Description

After installing pylons from hardy into gutsy I've got this error:

$ paster create -t pylons helloworld
Traceback (most recent call last):
  File "/usr/bin/paster", line 8, in <module>
    load_entry_point('PasteScript==1.3.6', 'console_scripts', 'paster')()
  File "/usr/lib/python2.5/site-packages/paste/script/command.py", line 78, in run
    invoke(command, command_name, options, args[1:])
  File "/usr/lib/python2.5/site-packages/paste/script/command.py", line 117, in invoke
    exit_code = runner.run(args)
  File "/usr/lib/python2.5/site-packages/paste/script/command.py", line 212, in run
    result = self.command()
  File "/usr/lib/python2.5/site-packages/paste/script/create_distro.py", line 69, in command
    self.extend_templates(templates, tmpl_name)
  File "/usr/lib/python2.5/site-packages/paste/script/create_distro.py", line 233, in extend_templates
    tmpl = entry.load()(entry.name)
  File "/usr/lib/python2.5/site-packages/pkg_resources.py", line 1911, in load
    if require: self.require(env, installer)
  File "/usr/lib/python2.5/site-packages/pkg_resources.py", line 1924, in require
    working_set.resolve(self.dist.requires(self.extras),env,installer))
  File "/usr/lib/python2.5/site-packages/pkg_resources.py", line 528, in resolve
    raise VersionConflict(dist,req) # XXX put more info here
pkg_resources.VersionConflict: (nose 0.9.2 (/var/lib/python-support/python2.5), Requirement.parse('nose>=0.9.3'))

Pylons or Paster or something should be depending on python-nose >= 0.9.3.

Related branches

Just to be clear, you've locally installed a deb for pylons from the Hardy repo on to your Gutsy system?

python-nose (0.9.2-3) is in the Gutsy repos while python-nose (0.10.0-1) is in the Hardy repo. If you install the package for your distro the required deps should be pulled. Does this happen with the correct package provided on your systems repo?

I'm going to close this bug as installing packages from a different version is not supported. If I've miss understood your problem, please feel free to re open the bug.

J. Pablo Fernández (pupeno) wrote :

Yes, I've built the package from Hardy in Gutsy, but even then, what I'm reporting is as true in Hardy as it is in any other situation: Pylons depends on Nose 0.10.0 yet the Pylons package doesn't depend on the Nose package >= 0.10.0.

Yes, python-pylons (0.9.6.1-1) depends on python-nose (>= 0.9.1) while it actually needs python-nose (>= 0.9.3). While this isn't really an issue for Hardy as the current versions of nose works, the dependency field should get updated.

That won't fix your problem though. In fact it will keep you from installing python-pylons from Hardy on Gutsy.

I'll reopen and tag packaging.

Changed in pylons:
status: Invalid → Confirmed

Attached is a debdiff updating the dependencies.

J. Pablo Fernández (pupeno) wrote :

Yes, that's the good thing. Actually, I build always packages from sources, if the right dependencies were there, I would have just downloaded a newer nose. In the current situation I had to try the system and see it fail and infeer than a newer version of nose was required.
Thank you for understanding.

Changed in pylons:
importance: Undecided → Low
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pylons - 0.9.6.2-2

---------------
pylons (0.9.6.2-2) unstable; urgency=low

  * Typos fixed in:
    + debian/NEWS
    + debian/control (python-elementree in Suggests, closes: #485407)
  * python-nose required version bumped to 0.9.3 (LP: #182384)
  * Bump Standards-Version to 3.7.3 (no changes needed)

 -- Ubuntu Archive Auto-Sync <email address hidden> Wed, 05 Nov 2008 10:46:45 +0000

Changed in pylons:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers