Raises empty OSError when inotify_init fails

Bug #633405 reported by dobey on 2010-09-08
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
pyinotify (Ubuntu)
Undecided
Unassigned

Bug Description

pyinotify.py is using ctypes to bind the inotify API to python, but is not following errno when calling inotify_init in the C API. This results in a blind OSError getting raised. The attached debdiff fixes this for the current version in Ubuntu. It appears the issue is already fixed in upstream git, with much more intrusive changes, and after a newer release.

Related branches

dobey (dobey) wrote :
Michael Vogt (mvo) on 2010-09-15
Changed in pyinotify (Ubuntu):
status: New → Fix Committed
Colin Watson (cjwatson) wrote :

pyinotify (0.8.9-1ubuntu3) maverick; urgency=low

  * debian/patches/init_errno.patch:
    - Get the errno and raise OSError with the correct message (LP: #633405)
  * Update Standards-Version
  * Add README.source to fix lintian warning
  * Add ${misc:Depends} to binary packages to fix lintian warning

 -- Rodney Dawes <email address hidden> Wed, 08 Sep 2010 14:13:30 -0400

Changed in pyinotify (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers