Ubuntu

python 2.6 support - jaunty

Reported by Xyos on 2009-04-04
34
This bug affects 2 people
Affects Status Importance Assigned to Milestone
pygtk (Ubuntu)
Undecided
Unassigned
specto (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: specto

xyos@UNlock:~$ specto
/usr/lib/python2.6/dist-packages/spectlib/tools/iniparser.py:309: DeprecationWarning: the sets module is deprecated
  from sets import Set
/usr/lib/python2.6/dist-packages/spectlib/plugins/watch_web_static.py:32: DeprecationWarning: the md5 module is deprecated; use hashlib instead
  import md5
ImportError: No module named numpy.core.multiarray
Segmentation fault (core dumped)

Related branches

Chris Halse Rogers (raof) wrote :

This is odd. While I can't find where spectlib tries to import numpy, something in its dependency graph does. I'm not certain this is a specto bug, but there's certainly a bug somewhere!

Changed in specto (Ubuntu):
importance: Undecided → Medium
status: New → Incomplete

Did you try that using the main specto bazaar branch? It seems to me
that fixing the other python 2.6 issues may have made this vanish, at
least I haven't experienced this particular problem.

Xyos (slayerjairo-gmail) wrote :

solved by:

sudo apt-get install numpy

please add python-numpy to dependencies

Luke Whitmore (lwhitmore) wrote :

received error while trying to use specto -> message about numpy module... will try the fix above.

Luke Whitmore (lwhitmore) wrote :

sudo apt-get install python-numpy

solved the problem for me..

Might I ask wtf is this numpy module I've never heard about before as a
dev, though? :) it used to work without it.

numerical python?

http://sourceforge.net/projects/numpy

On Fri, Apr 10, 2009 at 2:49 PM, Jean-François Fortin Tam <
<email address hidden>> wrote:

> Might I ask wtf is this numpy module I've never heard about before as a
> dev, though? :) it used to work without it.
>
> --
> python 2.6 support - jaunty
> https://bugs.launchpad.net/bugs/354909
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Luke Whitmore

UK Landline: +442030511409

Alessio Treglia (quadrispro) wrote :
Alessio Treglia (quadrispro) wrote :

Setting 'New' because I can reproduce this bug.

Please test the package available in my PPA:

http://ppa.launchpad.net/quadrispro/testing/ubuntu

Changed in specto (Ubuntu):
status: Incomplete → New
Igor Gomes (igorgomes) wrote :

I can confirm this issue and the suggested workaround.

Igor Gomes

Changed in specto (Ubuntu):
status: New → Confirmed

Alessio, what changes did you make to your PPA version? perhaps you could provide your patch on http://code.google.com/p/specto/issues/detail?id=216 ?

For what it's worth, the last time I tried swapping hashlib and md5, this caused serious problems (web watches not working at all).

Alessio Treglia (quadrispro) wrote :

As you can see in the debdiff, I only added a dependency on python-numpy.

-Depends: ${python:Depends}, python-gtk2, python-glade2, python-gnome2, python-gnome2-extras, zenity, gconf2, python-notify, python-dbus, librsvg2-common, gnome-icon-theme
+Depends: ${python:Depends}, python-gtk2, python-glade2, python-gnome2, python-gnome2-extras, zenity, gconf2, python-notify, python-dbus, librsvg2-common, gnome-icon-theme, python-numpy

Changed in specto (Ubuntu):
status: Confirmed → New
Scott Kitterman (kitterman) wrote :

We should also fix the deprecated modules. They are easy enough.

Alessio Treglia (quadrispro) wrote :

Uploaded to my testing PPA

Alessio Treglia (quadrispro) wrote :

Everything works fine.

Uploaded, sitting in the queue.

Changed in specto (Ubuntu):
status: New → Fix Committed
Martin Pitt (pitti) wrote :

Reviewed the diff, looks appropriate to me. ACK.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package specto - 0.2.2-3ubuntu1

---------------
specto (0.2.2-3ubuntu1) jaunty; urgency=low

  * Add missing Depends on python-numpy (LP: #354909).
  * Add 10_fix_python26_warnings.patch patch to fix deprecation warnings.

 -- Alessio Treglia <email address hidden> Mon, 20 Apr 2009 07:56:11 +0200

Changed in specto (Ubuntu):
status: Fix Committed → Fix Released

Hold on a sec, Specto does not call the numpy module directly in its code, afaik, PyGTK is the one calling it. Shouldn't PyGTK be the package that gets its dependencies fixed? Surely we can't be the only application with which this happens?

Scott Kitterman (kitterman) wrote :

IIRC, there was a decision made for PyGTK not to carry the numpy depends
because numpy wouldn't fit on CD and it was thought the relevant functions
were only rarely used. This isn't the "right" fix, but as a workaround for
this release, it will do.

Matthias Klose (doko) wrote :

pygtk uses numpy for exactly one method. the reason not to have it as a dependency are space constraints on the CD (numpy and dependencies would add 10MB). So probably the current python-gtk package should be renamed into python-gtk-lite and an empty python-gtk package depending on python-gtk-lite and python-numpy. Then all packages going on the CD need to depend on python-gtk-lite.

Colin Watson (cjwatson) wrote :

I suspect that changing the users of this one method to add that dependency is a lot more practical than renaming python-gtk.

Jaunty has reached his EOL on 23 October 2010.

I'm marking this bug as incomplete, please test on a new ubuntu version and set the status again to "new" if you think the bug is not fixed.

Changed in pygtk (Ubuntu):
status: New → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers