apport-gtk crashed with SIGSEGV in PyEval_EvalFrameEx()

Bug #192504 reported by kyleabaker on 2008-02-16
16
Affects Status Importance Assigned to Milestone
pygtk (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: apport

Ubuntu 8.04 x64
apport: 0.102

MetaCity crashed and I apport was gathering information to send, but apport suddenly crashed. I'm unsure what triggered MetaCity or apport to crash. Hopefully the uploaded information will point this problem out. This is the first time apport has crashed on my machine, but MetaCity seems to crash on a regular basis.

ProblemType: Crash
Architecture: amd64
Date: Sat Feb 16 17:55:44 2008
Disassembly: 0x7fd09d883ea0:
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/share/apport/apport-gtk
InterpreterPath: /usr/bin/python2.5
NonfreeKernelModules: nvidia
Package: apport-gtk 0.102
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/share/apport/apport-gtk
ProcCwd: /home/kyleabaker
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=en_US.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: apport
StacktraceTop:
 ?? ()
 PyEval_EvalFrameEx ()
 PyEval_EvalFrameEx ()
 PyEval_EvalCodeEx ()
 ?? ()
Title: apport-gtk crashed with SIGSEGV in PyEval_EvalFrameEx()
Uname: Linux kyleabaker-desktop 2.6.24-8-generic #1 SMP Thu Feb 14 20:13:27 UTC 2008 x86_64 GNU/Linux
UserGroups: adm admin audio cdrom dialout dip floppy lpadmin netdev plugdev powerdev scanner vboxusers video
SegvAnalysis:
 Segfault happened at: 0x7fd09d883ea0:
 PC (0x7fd09d883ea0) not located in a known VMA region (needed executable region)!
SegvReason: executing unknown VMA

kyleabaker (kyleabaker) wrote :

StacktraceTop:?? ()
PyEval_EvalFrameEx (f=0x16e3360, throwflag=<value optimized out>)
PyEval_EvalFrameEx (f=0x16e4790, throwflag=<value optimized out>)
PyEval_EvalCodeEx (co=0xd5c120, globals=<value optimized out>,
function_call (func=0xd60e60, arg=0x10e6950, kw=0x0) at ../Objects/funcobject.c:517

Matthias Klose (doko) wrote :

is this reproducible?

Changed in python2.5:
status: New → Incomplete
Javier Jardón (jjardon) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in python2.5:
status: Incomplete → Invalid
jerryb (gerald-britton) wrote :

Similar situation with me. Actual crash message:

segfault at c ip b7bcce22 sp bfc94cf0 error 6 in libglib-2.0.so.0.1800.2[b7b76000+b5000]

Backtrace:

Thread 1 (Thread 0xb7e9f8c0 (LWP 5709)):
#0 0xb8073430 in __kernel_vsyscall ()
#1 0xb7f76f3b in poll () from /lib/tls/i686/cmov/libc.so.6
#2 0xb7957c32 in ?? () from /usr/lib/libglib-2.0.so.0
#3 0xb79582c2 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#4 0xb788ffd4 in ?? () from /var/lib/python-support/python2.5/gtk-2.0/glib/_glib.so
#5 0x080cede3 in PyEval_EvalFrameEx ()
#6 0x080d0345 in PyEval_EvalCodeEx ()
#7 0x080d0557 in PyEval_EvalCode ()
#8 0x080edf8f in PyRun_FileExFlags ()
#9 0x080ee25a in PyRun_SimpleFileExFlags ()
#10 0x080595e7 in Py_Main ()
#11 0x08058962 in main ()
#0 0xb8073430 in __kernel_vsyscall ()

This is reproducible

Changed in python2.5:
status: Invalid → New

jerryb, can you please install the debug packages "libglib2.0-0-dbgsym" and obtain a new trace? Thanks in advance.

Changed in python2.5:
status: New → Incomplete

OK -- I installed the library. Now do I have to do anything special to
get the trace or just make it crash? Where does the trace output go?

On Fri, Feb 20, 2009 at 3:52 PM, Martin Mai <email address hidden> wrote:
> jerryb, can you please install the debug packages "libglib2.0-0-dbgsym"
> and obtain a new trace? Thanks in advance.
>
> ** Changed in: python2.5 (Ubuntu)
>       Status: New => Incomplete
>
> --
> apport-gtk crashed with SIGSEGV in PyEval_EvalFrameEx()
> https://bugs.launchpad.net/bugs/192504
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Gerald Britton
Sent from: Don mills On Canada.

You can follow the instructions at http://wiki.ubuntu.com/DebuggingProgramCrash and upload the backtrace (as an attachment) to the bug report. Thanks.

jerryb (gerald-britton) wrote :

gdb backtrace attached

jerryb (gerald-britton) on 2009-03-13
Changed in python2.5:
status: Incomplete → New
Matthias Klose (doko) wrote :

reassigning to pygtk; it is more likely, that the error is in some of the bindings than in python itself. please could you check if you can reproduce this in current jaunty?

affects: python2.5 (Ubuntu) → pygtk (Ubuntu)

Sorry, jerryb, for the long delay. It would be good if you can obtain another backtrace after installing "libgtk2.0-0-dbg". Then the backtrace should be quite complete. Thanks in advance.

jerryb (gerald-britton) wrote :

New Backtrace attached as requested

jerryb (gerald-britton) wrote :

Did it

On Sat, Apr 4, 2009 at 9:23 AM, Martin Mai <email address hidden> wrote:
> Sorry, jerryb, for the long delay. It would be good if you can obtain
> another backtrace after installing "libgtk2.0-0-dbg". Then the backtrace
> should be quite complete. Thanks in advance.
>
> --
> apport-gtk crashed with SIGSEGV in PyEval_EvalFrameEx()
> https://bugs.launchpad.net/bugs/192504
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Gerald Britton

Thank you. By the way, what are you doing to reproduce the crash and to get the backtrace that confident? Or where you starting gdb and waiting for it to crash randomly?

Changed in pygtk (Ubuntu):
importance: Undecided → Medium
jerryb (gerald-britton) wrote :

I have to start up my application then work with it for a while.
Eventually it crashes, though there seems to be no relationship
between what I did and the crash, since the sequence is different
every time. Sometimes it crashes in a minute or two; sometimes it
takes longer.

On Tue, Apr 7, 2009 at 5:08 AM, Martin Mai <email address hidden> wrote:
> Thank you. By the way, what are you doing to reproduce the crash and to
> get the backtrace that confident? Or where you starting gdb and waiting
> for it to crash randomly?
>
> ** Changed in: pygtk (Ubuntu)
>   Importance: Undecided => Medium
>
> --
> apport-gtk crashed with SIGSEGV in PyEval_EvalFrameEx()
> https://bugs.launchpad.net/bugs/192504
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Gerald Britton

Kees Cook (kees) on 2009-09-16
description: updated
Pedro Villavicencio (pedro) wrote :

Thanks for the report, it has been some time without any response or feedback in this bug report and we are wondering if this is still an issue for you with the latest release of Ubuntu the Natty Narwhal, May you please test with that version and comment back if you're still having or not the issue? Please have a look at http://www.ubuntu.com/download to know how to install that version.Thanks in advance.

Changed in pygtk (Ubuntu):
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

We're closing this bug since it is has been some time with no response from the original reporter. However, if the issue still exists please feel free to reopen with the requested information. Also, if you could, please test against the latest development version of Ubuntu, since this confirms the bug is one we may be able to pass upstream for help.

Changed in pygtk (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers