pitivi crashed with SIGSEGV in PyEval_EvalCodeEx()

Bug #640630 reported by Ric Flomag on 2010-09-16
130
This bug affects 23 people
Affects Status Importance Assigned to Milestone
PiTiVi
Fix Released
Critical
pitivi (Ubuntu)
Critical
Unassigned
Maverick
Undecided
Unassigned
pygoocanvas (Ubuntu)
Critical
Unassigned
Maverick
Undecided
Unassigned

Bug Description

Binary package hint: pitivi

Opening new bug to follow with #635622 and provide with debug information.

Steps to reproduce:

* import (MPEG) clips
* drag a clip to the time line
* change the timeline zoom with the slider while the video thumbnails are being generated -> crash

ProblemType: Crash
DistroRelease: Ubuntu 10.10
Package: pitivi 0.13.4.3-1ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-21.31-generic 2.6.35.4
Uname: Linux 2.6.35-21-generic i686
Architecture: i386
CrashCounter: 1
Date: Thu Sep 16 18:16:16 2010
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/pitivi
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha i386 (20100913)
InterpreterPath: /usr/bin/python2.6
PackageArchitecture: all
ProcCmdline: python /usr/bin/pitivi
ProcEnviron:
 LANG=fr_FR.utf8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x80df43a <PyEval_EvalCodeEx+218>: addl $0x1,(%edx)
 PC (0x080df43a) ok
 source "$0x1" ok
 destination "(%edx)" (0x00000000) not located in a known VMA region (needed writable region)!
SegvReason: writing NULL VMA
Signal: 11
SourcePackage: pitivi
StacktraceTop:
 PyEval_EvalCodeEx (co=0x8e2c530, globals={'__builtins__': {'bytearray': <type at remote 0x826b600>, 'IndexError': <type at remote 0x8228180>, 'all': <built-in function all>, 'help': <_Helper at remote 0xb784960c>, 'vars': <built-in function vars>, 'SyntaxError': <type at remote 0x8227e00>, 'unicode': <type at remote 0x8233fa0>, 'UnicodeDecodeError': <type at remote 0x82285e0>, 'isinstance': <built-in function isinstance>, 'copyright': <_Printer(_Printer__data='Copyright (c) 2001-2010 Python Software Foundation.\nAll Rights Reserved.\n\nCopyright (c) 2000 BeOpen.com.\nAll Rights Reserved.\n\nCopyright (c) 1995-2001 Corporation for National Research Initiatives.\nAll Rights Reserved.\n\nCopyright (c) 1991-1995 Stichting Mathematisch Centrum, Amsterdam.\nAll Rights Reserved.', _Printer__lines=None, _Printer__name='copyright', _Printer__dirs=(), _Printer__files=(...)) at remote 0xb78494ac>, 'NameError': <type at remote 0x8227b60>, 'BytesWarning': <type at remote 0x8229760>, 'dict': <type at remote 0x822d260>, 'input': <built-in function input>, 'oct': <...(truncated), locals=0x0, args=0x9316378, argcount=2, kws=0x0, kwcount=0, defs=0x0, defcount=0, closure=0x0) at ../Python/ceval.c:2816
 function_call (func=<function at remote 0x8e7910c>, arg=(<Preview(_height=<float at remote 0x8b0ec54>, app=<InteractivePitivi(sourcelist_log_observer=<SourceListLogObserver(log=<UndoableActionLog(_signal_group=<SignalGroup(siglist={'begin': ['stack', 'nested'], 'rollback': ['stack', 'nested'], 'cleaned': [], 'push': ['stack', 'action'], 'commit': ['stack', 'nested'], 'redo': ['stack'], 'undo': ['stack']}, ids={7177076637320073016L: (<instancemethod at remote 0x8e6beb4>, (), {}), 16188941178818528975L: (<instancemethod at remote 0x901da54>, (...), {}), 6742783820274124036L: (<instancemethod at remote 0x901d9b4>, (...), {}), 16323606128546467657L: (<instancemethod at remote 0x8e6be64>, (...), {}), 14006536588957453220L: (<instancemethod at remote 0x8e6be3c>, (...), {}), 1410320634421093717L: (<instancemethod at remote 0x901da04>, (...), {}), 12948864329737087002L: (<instancemethod at remote 0x901d964>, (...), {}), 5749386671689983589L: (<instancemethod at remote 0x8e6bfa4>, (...), {})}, callback_ids={<instancemethod at remote 0x8e6bfa4>: [5749386671689983589L], <ins...(truncated), kw=0x0) at ../Objects/funcobject.c:524
 PyObject_Call (func=<function at remote 0x8e7910c>, arg=(<Preview(_height=<float at remote 0x8b0ec54>, app=<InteractivePitivi(sourcelist_log_observer=<SourceListLogObserver(log=<UndoableActionLog(_signal_group=<SignalGroup(siglist={'begin': ['stack', 'nested'], 'rollback': ['stack', 'nested'], 'cleaned': [], 'push': ['stack', 'action'], 'commit': ['stack', 'nested'], 'redo': ['stack'], 'undo': ['stack']}, ids={7177076637320073016L: (<instancemethod at remote 0x8e6beb4>, (), {}), 16188941178818528975L: (<instancemethod at remote 0x901da54>, (...), {}), 6742783820274124036L: (<instancemethod at remote 0x901d9b4>, (...), {}), 16323606128546467657L: (<instancemethod at remote 0x8e6be64>, (...), {}), 14006536588957453220L: (<instancemethod at remote 0x8e6be3c>, (...), {}), 1410320634421093717L: (<instancemethod at remote 0x901da04>, (...), {}), 12948864329737087002L: (<instancemethod at remote 0x901d964>, (...), {}), 5749386671689983589L: (<instancemethod at remote 0x8e6bfa4>, (...), {})}, callback_ids={<instancemethod at remote 0x8e6bfa4>: [5749386671689983589L], <ins...(truncated), kw=0x0) at ../Objects/abstract.c:2492
 instancemethod_call (func=<instancemethod at remote 0x931ed9c>, arg=(<Preview(_height=<float at remote 0x8b0ec54>, app=<InteractivePitivi(sourcelist_log_observer=<SourceListLogObserver(log=<UndoableActionLog(_signal_group=<SignalGroup(siglist={'begin': ['stack', 'nested'], 'rollback': ['stack', 'nested'], 'cleaned': [], 'push': ['stack', 'action'], 'commit': ['stack', 'nested'], 'redo': ['stack'], 'undo': ['stack']}, ids={7177076637320073016L: (<instancemethod at remote 0x8e6beb4>, (), {}), 16188941178818528975L: (<instancemethod at remote 0x901da54>, (...), {}), 6742783820274124036L: (<instancemethod at remote 0x901d9b4>, (...), {}), 16323606128546467657L: (<instancemethod at remote 0x8e6be64>, (...), {}), 14006536588957453220L: (<instancemethod at remote 0x8e6be3c>, (...), {}), 1410320634421093717L: (<instancemethod at remote 0x901da04>, (...), {}), 12948864329737087002L: (<instancemethod at remote 0x901d964>, (...), {}), 5749386671689983589L: (<instancemethod at remote 0x8e6bfa4>, (...), {})}, callback_ids={<instancemethod at remote 0x8e6bfa4>: [5749386671689983589L], <ins...(truncated), kw=0x0) at ../Objects/classobject.c:2579
 PyObject_Call (func=<instancemethod at remote 0x931ed9c>, arg=(0x0,), kw=0x0) at ../Objects/abstract.c:2492
Title: pitivi crashed with SIGSEGV in PyEval_EvalCodeEx()
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Thank you for taking the time to report this crash and helping to make Ubuntu better. This particular crash has already been reported and is a duplicate of bug #635622, so is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

visibility: private → public
tags: removed: need-i386-retrace
Jeff Fortin Tam (kiddo) wrote :

This is maverick-specific and 100% reproducible. Seems to be caused by something in goocanvas. Confirming and linking to upstream report.

Changed in pitivi (Ubuntu):
status: New → Triaged
importance: Undecided → Critical
Changed in pitivi:
importance: Unknown → Critical
status: Unknown → Confirmed
Mikael Nordfeldth (mmn) wrote :

I have disabled generating thumbnails and waveforms. The problem still affects me.

Changed in pitivi (Ubuntu):
assignee: nobody → Wuilmer Bolívar (elwuilmer)
Jeff Fortin Tam (kiddo) wrote :

Wuilmer, do not assign bugs to yourself, unless you intend to *fix* them...

Changed in pitivi (Ubuntu):
assignee: Wuilmer Bolívar (elwuilmer) → nobody
Wuilmer Bolívar (elwuilmer) wrote :

Jeam i am sorry.!

saksmlz (saksmlz) wrote :

one more debug.log

Changed in pitivi (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
affects: pitivi (Ubuntu) → pygoocanvas (Ubuntu)
Changed in pitivi (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
importance: Undecided → Critical
status: New → Triaged
Changed in pitivi (Ubuntu):
assignee: Ken VanDine (ken-vandine) → nobody
milestone: none → ubuntu-10.10
Changed in pygoocanvas (Ubuntu):
milestone: none → ubuntu-10.10
Changed in pitivi (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pygoocanvas - 0.14.1-1ubuntu2

---------------
pygoocanvas (0.14.1-1ubuntu2) maverick; urgency=low

  * debian/patches/lp_640630.patch
    - Check the return value of PycairoContext_FromContext in
      CairoParam (LP: #640630)
 -- Ken VanDine <email address hidden> Mon, 04 Oct 2010 09:25:27 -0400

Changed in pygoocanvas (Ubuntu):
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pitivi - 0.13.5-1ubuntu2

---------------
pitivi (0.13.5-1ubuntu2) maverick; urgency=low

  * debian/patches/10_canvas-fixes-lp_640630.patch
    - Don't crash when rendering thumbnails in the timeline (LP: #640630)
 -- Ken VanDine <email address hidden> Mon, 04 Oct 2010 09:21:22 -0400

Changed in pitivi (Ubuntu):
status: Triaged → Fix Released
Changed in pitivi (Ubuntu):
status: Fix Released → Triaged
assignee: Ken VanDine (ken-vandine) → nobody
Changed in pygoocanvas (Ubuntu):
assignee: Ken VanDine (ken-vandine) → nobody

Accepted pitivi into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in pitivi (Ubuntu):
status: Triaged → Fix Committed
Changed in pygoocanvas (Ubuntu Maverick):
status: New → Fix Released
Changed in pitivi (Ubuntu Maverick):
status: New → Fix Committed
tags: added: verification-needed
Jeff Fortin Tam (kiddo) wrote :

Hi Martin, I just tested the package in maveric proposed, and it indeed solves the crashes.

tags: added: verification-done
removed: verification-needed
Jeff Fortin Tam (kiddo) wrote :

Anything else needed?

Changed in pitivi (Ubuntu Maverick):
milestone: none → maverick-updates

@Jean-François, nothing else, thank you for testing that's much appreciated.
If you're willing to test more things, the full list is available at http://people.canonical.com/~ubuntu-archive/pending-sru.html

Martin Pitt (pitti) wrote :

Copied to natty as well.

Changed in pitivi (Ubuntu):
milestone: ubuntu-10.10 → none
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pitivi - 0.13.5-1ubuntu3

---------------
pitivi (0.13.5-1ubuntu3) maverick-proposed; urgency=low

  * debian/patches/series
    - Actually add 10_canvas-fixes-lp_640630.patch that fixes (LP: #640630)
 -- Ken VanDine <email address hidden> Thu, 14 Oct 2010 11:00:02 -0400

Changed in pitivi (Ubuntu Maverick):
status: Fix Committed → Fix Released
Changed in pitivi:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.