Ubuntu

Video Lens leaks memory

Reported by Sami Jaktholm on 2012-04-30
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
dee
High
Michal Hruby
pygobject
Fix Released
Medium
pygobject (Ubuntu)
Undecided
Unassigned

Bug Description

Memory consumption increases everytime you make a search.

Steps to reproduce:
1. Note the initial memory usage
2. Make 10 random searches
3. Check the memory usage

For me the usage increases about 300 KiB per search.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity-lens-video 0.3.5-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-24.37-generic 3.2.14
Uname: Linux 3.2.0-24-generic x86_64
ApportVersion: 2.0.1-0ubuntu7
Architecture: amd64
Date: Mon Apr 30 23:29:15 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Release amd64 (20120425)
PackageArchitecture: all
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 LANG=fi_FI.UTF-8
 SHELL=/bin/bash
SourcePackage: unity-lens-video
UpgradeStatus: No upgrade log present (probably fresh install)

Sami Jaktholm (sjakthol) wrote :
David Callé (davidc3) wrote :

Moving to libunity.
It's a bug easy to notice with all Python lenses, working with a large amount of results.

no longer affects: unity-lens-video (Ubuntu)
affects: unity-lens-videos → libunity
Changed in libunity:
status: New → Confirmed
Changed in libunity:
assignee: nobody → Michal Hruby (mhr3)
importance: Undecided → High
Michal Hruby (mhr3) wrote :

The issue is that the variants that get created while appending rows to the models do not get unreferenced - so it's an issue in python-gobject-introspection, and maybe we could workaround it in Dee.

affects: libunity → dee
Changed in pygobject (Ubuntu):
status: New → Confirmed
Martin Pitt (pitti) wrote :

I uploaded PyGObject 3.7.91 to raring now, which fixes tons of memleaks. This should help a lot with this particular bug as well, but I don't think it's fully fixed yet. I linked the remaining upstream bug which is related to this.

Changed in pygobject (Ubuntu):
status: Confirmed → Triaged
Changed in pygobject:
importance: Unknown → Medium
status: Unknown → In Progress
Changed in pygobject:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.