gnome-language-selector assert failure: *** glibc detected *** /usr/bin/python: munmap_chunk(): invalid pointer: 0x00007f97ec27c3b2 ***

Bug #709191 reported by Mauricio Pretto on 2011-01-28
42
This bug affects 4 people
Affects Status Importance Assigned to Milestone
pygobject (Ubuntu)
Medium
Unassigned
Natty
Medium
Unassigned

Bug Description

Binary package hint: language-selector

Occurred during automated desktop testing.

This crash happened when the user clicked on 'install / remove languages'

This is reproducible on amd64 and i386

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: language-selector 0.11
ProcVersionSignature: Ubuntu 2.6.37-12.26-generic 2.6.37
Uname: Linux 2.6.37-12-generic x86_64
Architecture: amd64
AssertionMessage: *** glibc detected *** /usr/bin/python: munmap_chunk(): invalid pointer: 0x00007f97ec27c3b2 ***
Date: Fri Jan 28 09:51:08 2011
ExecutablePath: /usr/bin/gnome-language-selector
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20101206)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/gnome-language-selector
ProcEnviron:
 LANGUAGE=en_US:en
 LANG=en_US.UTF-8
 LC_MESSAGES=en_US.utf8
 SHELL=/bin/bash
Signal: 6
SourcePackage: language-selector
StacktraceTop:
 raise () from /lib/libc.so.6
 abort () from /lib/libc.so.6
 ?? () from /lib/libc.so.6
 ?? () from /lib/libc.so.6
 ?? () from /usr/lib/pymodules/python2.7/gi/_gi.so
Title: gnome-language-selector assert failure: *** glibc detected *** /usr/bin/python: munmap_chunk(): invalid pointer: 0x00007f97ec27c3b2 ***
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Mauricio Pretto (pretto) wrote :

StacktraceTop:
 *__GI_raise (sig=6)
 *__GI_abort () at abort.c:59

Changed in language-selector (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
visibility: private → public
description: updated
description: updated
Changed in language-selector (Ubuntu Natty):
status: New → Confirmed
importance: Medium → High
Michael Vogt (mvo) wrote :

Thanks for your bugreport.

I can not reproduce this on my up-to-date natty system (amd64 as well). Could you try rm /var/cache/apt/*.bin and see if the bug can be triggered still afterwards?

Changed in language-selector (Ubuntu Natty):
status: Confirmed → Incomplete
Mauricio Pretto (pretto) wrote :

Did you try adding a language and applying ? that's usually still giving crashes here

Antono Vasiljev (antono) wrote :

@Michael i've got it on natty amd64 yesterday.

Changed in language-selector (Ubuntu Natty):
status: Incomplete → Confirmed
Martin Pitt (pitti) wrote :

Hey Mauricio,

I just tried that on current natty. I installed and removed a language, changed the language order, changed the locale, several times, and did not get a crash. Since the time of the latest duplicate we got two major bug fix releases of pygobject, so that very well could have fixed the problem. Do you still get it on current natty?

If you can still reproduce this, can you please file a new crash report? Unfortunately the reprocessed stack trace here is useless, but since then we fixed Apport to produce better stack traces, so a new report would help a lot. For that reason I'll close this one. Thanks!

affects: language-selector (Ubuntu Natty) → pygobject (Ubuntu Natty)
Changed in pygobject (Ubuntu Natty):
importance: High → Medium
status: Confirmed → Invalid
Martin Pitt (pitti) wrote :

For the record, I removed this bug from Apport's duplicate database, so the next report that will be filed won't get auto-duplicated.

Mauricio Pretto (pretto) wrote :

Hi Martin
I have tried to reproduce this again the best I could get was bug #697095 .
I will try a fresh install on another partition during the weekend, but look like this is fixed .

Martin Pitt (pitti) wrote :

There's a different crash reported in bug 707585, I'll have a look at that. It might or might not have the same root cause.

Mauricio Pretto (pretto) wrote :

Just got this bug again in my new install in my aspire one will post the bug number soon

Changed in pygobject (Ubuntu Natty):
status: Invalid → New
Mauricio Pretto (pretto) wrote :

Hi Martin
please take a look at #737524

Mauricio Pretto (pretto) wrote :

another one bug #737537

Mauricio Pretto (pretto) wrote :

FYI this machine is running i386

Martin Pitt (pitti) wrote :

Mauricio,

note that the two crashes you pointed out are completely different. I'll deal with them separately, but close this one again, as it's unreproducible.

Changed in pygobject (Ubuntu Natty):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers