FTBFS: automake-1.10 missing

Bug #445633 reported by LaMont Jones on 2009-10-07
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
pygobject (Ubuntu)
Low
Matt Wheeler

Bug Description

During rebuild testing:

 cd /build/buildd/pygobject-2.18.0 && /bin/bash /build/buildd/pygobject-2.18.0/missing --run automake-1.10 --gnu
/build/buildd/pygobject-2.18.0/missing: line 54: automake-1.10: command not found
WARNING: `automake-1.10' is missing on your system. You should only need it if
         you modified `Makefile.am', `acinclude.m4' or `configure.ac'.
         You might want to install the `Automake' and `Perl' packages.
         Grab them from any GNU archive site.
cd /build/buildd/pygobject-2.18.0 && /bin/bash /build/buildd/pygobject-2.18.0/missing --run autoconf
aclocal.m4:16: warning: this file was generated for autoconf 2.63.
You have another version of autoconf. It may work, but is not guaranteed to.
If you have problems, you may need to regenerate the build system entirely.
To do so, use the procedure documented by the package, typically `autoreconf'.
configure.ac:31: error: possibly undefined macro: AM_MAINTAINER_MODE
      If this token and others are legitimate, please use m4_pattern_allow.
      See the Autoconf documentation.
make[1]: *** [/build/buildd/pygobject-2.18.0/configure] Error 1
make[1]: Leaving directory `/build/buildd/pygobject-2.18.0/build-2.6'

Related branches

LaMont Jones (lamont) on 2009-10-07
Changed in pygobject (Ubuntu):
milestone: none → ubuntu-9.10
Matt Wheeler (funkyhat) on 2009-10-09
Changed in pygobject (Ubuntu):
assignee: nobody → Matt Wheeler (funkyhat)
Matt Wheeler (funkyhat) wrote :

Patch to fix FTBFS. This patch includes all the changes made by autoreconf -i
Also fixes a duplication in codegen/Makefile.am

StefanPotyra (sistpoty) wrote :

Nice, thanks! Will upload in a minute.

As discussed on irc: adjusted changelog a little bit and dropped autom4te.cache hunks from the patch.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pygobject - 2.18.0-0ubuntu2

---------------
pygobject (2.18.0-0ubuntu2) karmic; urgency=low

  * Fixing FTBFS due to new autotools versions (LP: #445633),
    debian/patches/65_new_autotools_version.patch
    + Removed duplicate install of defsgen.py in Makefile.am
    + Rerun autotools.

 -- Matt Wheeler <email address hidden> Fri, 09 Oct 2009 21:43:19 +0100

Changed in pygobject (Ubuntu):
status: New → Fix Released
Sebastien Bacher (seb128) wrote :

the change there is wrong, why is the autotools run required?

Changed in pygobject (Ubuntu):
importance: Undecided → Low

2009/10/12 Sebastien Bacher <email address hidden>:
> the change there is wrong, why is the autotools run required?

I don't know, sorry. Don't know enough about the package.
This was just a dumb fix, I looked at what was failing and fixed that, didn't look any deeper.

--
Matt Wheeler
<email address hidden>

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers