py-gobject crash on subclasses

Bug #378592 reported by poelzi on 2009-05-20
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
pygobject
Confirmed
Low
pygobject (Ubuntu)
Low
Ubuntu Desktop Bugs
Jaunty
High
Unassigned

Bug Description

Please apply the patch from

http://bugzilla.gnome.org/show_bug.cgi?id=566571

to the 2.16.x release. without it, gobject is totally broken and unstable.

poelzi (poelzi) wrote :

btw.
2.17.1 already contains the fix and is usable again.
by fix i ment http://bugzilla.gnome.org/attachment.cgi?id=133131

Changed in pygobject (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Fix Committed
poelzi (poelzi) wrote :

sorry that i have to knock on this again.

- the bug is not low as it causes SEGFAULT in a skripting languge, something NEVER should happen.
- the 2.16 release is so broken, that the most obvious things don't work like subclassing, wtf... something worked always good
- this bug affects many software, not just pida.

THIS IS A MAJOR BUG

so, now the question.
why is there no fix in jaunty updates ?

i already put in a http://pida.co.uk/trac/wiki/FrequentlyAskedQuestions so people may find out why it is unstable, but will most likely blame us.

Ohh, i forgott, i could put some really ugly workaround in there with a note:

Hey, this totally sucks but ubuntu doesn't like to fix obvious, severe bugs. They prefer to put the broken upstream ones in place.

NO NO NO, i will not do it. If you lucky I will say, install python-central, python-gobject and some other stuff from karmic and you will not get the crashes anymore....

Sebastien Bacher (seb128) wrote :

> why is there no fix in jaunty updates ?

because the team working on ubuntu is small and there is ten of thousand bugs and everything can't be fixed in a day, you are welcome to contribute by working on a stable update though

Sebastien Bacher (seb128) wrote :

2.18 is in karmic now and fixes the issue

Changed in pygobject (Ubuntu):
status: Fix Committed → Fix Released
Changed in pygobject:
status: Unknown → Confirmed
poelzi (poelzi) wrote :
poelzi (poelzi) wrote :

the patch i provided is not in jaunty, making gobject on it unusable

Changed in pygobject (Ubuntu):
status: Fix Released → In Progress
Sebastien Bacher (seb128) wrote :

jaunty being buggy is not a reason to reopen the bug, bugs are closed when fixed in the current package version, you can open a jaunty task if you want a fix on jaunty

Changed in pygobject (Ubuntu):
status: In Progress → Fix Released
Matthias Klose (doko) on 2009-06-12
Changed in pygobject (Ubuntu Jaunty):
importance: Undecided → High
milestone: none → jaunty-updates
status: New → Triaged
Matthias Klose (doko) wrote :

poelzi: please attach a debdiff for jaunty

poelzi (poelzi) wrote :

sorry for not being familiar with the ubuntu bug process, i just want that people can enjoy the open source software i write....

Matthias Klose (doko) wrote :

two minor nits:

 karmic -> jaunty-proposed
 Closes: -> LP:

poelzi (poelzi) wrote :
Sebastien Bacher (seb128) wrote :

could you also provide a testcase? stable update should have a way to be tested easily to verify that the change is doing its job

Martin Pitt (pitti) wrote :

Accepted pygobject into jaunty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in pygobject (Ubuntu Jaunty):
status: Triaged → Fix Committed
tags: added: verification-needed
poelzi (poelzi) wrote :

Could the update please pushed to the updates repo please.
We get bug reports of people affected by this bug as not everyone using proposed but updates is usually on. There are no bugs caused by this patch, so it is safe and I'm using it since months now.

Martin Pitt (pitti) wrote :

Yes, as soon as anyone actually tests the package in jaunty-proposed and confirms that it fixes this problem, and does not cause other regressions. We won't push it to -updates with zero feedback.

Thanks in advance!

poelzi (poelzi) wrote :

i spend the last half hour to make a simple testcase for a bug accepted and fixed upstream and i just couldn't isolate it. I give up now and just don't care about this stubborn behavior...

see http://pida.co.uk/ticket/339
or just run pida pida 0.6beta3 - http://pida.co.uk/downloads/9
if you think i'm the only one having this.

poelzi [2009-08-29 13:50 -0000]:
> i spend the last half hour to make a simple testcase for a bug accepted
> and fixed upstream and i just couldn't isolate it. I give up now and
> just don't care about this stubborn behavior...

Please note that we asked for feedback about the package, not "we
absolutely must reproduce the bug". But we at least need to know that
people running this upgraded version don't encounter any apparent
regression (misbuilt package, wrong library dependencies, and
whatnot).

poelzi (poelzi) wrote :

Nobody reported anything and this package is in proposed for many moth so it is widely tested. I'm running it since it came out and haven't got any regressions. In my opinion a proposed is stable after 2 weeks without reports for sure.
i just don't understand the concern under the given circumstances — the more i understand why people get more and more unsatisfied with ubuntu…

Martin Pitt (pitti) wrote :

They would rightfully get much more unsatisfied if we would break a working version. Bad experience has taught us to be very cautious with stable release upgrades.

Thanks for testing feedback!

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pygobject - 2.16.1-1ubuntu3

---------------
pygobject (2.16.1-1ubuntu3) jaunty-proposed; urgency=low

  * fix crash on subclassing gobject classes; LP: #378592

 -- Daniel Poelzleithner <email address hidden> Tue, 09 Jun 2009 21:36:20 +0200

Changed in pygobject (Ubuntu Jaunty):
status: Fix Committed → Fix Released
Changed in pygobject:
importance: Unknown → Low
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.