FTBFS against python3-pygments (=2.10.0+dfsg-1)

Bug #1956440 reported by Alexandre Ghiti
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
pygments (Ubuntu)
Undecided
Unassigned
ruby-pygments.rb (Debian)
Fix Released
Unknown
ruby-pygments.rb (Ubuntu)
Undecided
Unassigned

Bug Description

As can be seen in [1], the current package FTBFS against merged python3-pygments (=2.10.0+dfsg-1). A similar issue was reported on the 23th of December 2021 in Debian [2].

I locally bumped the version of ruby-pygments.rb to 2.2.0 as the current one is from 2017 and embeds lots of distro patches. I'm waiting for an answer to the report I did upstream [3] and will propose the new version.

[1] https://autopkgtest.ubuntu.com/results/autopkgtest-jammy/jammy/amd64/r/ruby-pygments.rb/20211210_140400_926ac@/log.gz
[2] https://<email address hidden>/msg1835947.html
[3] https://github.com/pygments/pygments.rb/issues/234

tags: added: update-excuse
Changed in ruby-pygments.rb (Debian):
status: Unknown → New
Revision history for this message
Mattia Rizzolo (mapreri) wrote :

ah! I didn't notice this bug...

@alexghiti: for the next time, please consider adding LP:#xxxx to the changelog. Even if uploaded in debian launchpad would pick it up automatically when the package is synced.

I'll let you close the bug manually once that happens. (please don't forget it.. launchpad already has too many stale bugs lounging around -.-)

Changed in ruby-pygments.rb (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.