pygame causes freevo to crash on amd64

Bug #138430 reported by Adapted.Cat on 2007-09-09
6
Affects Status Importance Assigned to Milestone
pygame (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: python-pygame

There is a known stack overwrite problem in version 1.7.1 of pygame. If you look at the SVN repository under revision 1004 you'll see the fix, which involves using Py_ssize_t instead of int. Without this fix freevo is a non-starter on amd64 platforms.

So, it's a known problem, with a ready-made patch upstream - should be easy to fix.

Related branches

Luca Falavigna (dktrkranz) wrote :

Thank you for your bug report.
Attached debdiff should fix this issue.

Changed in pygame:
status: New → Confirmed
Cesare Tirabassi (norsetto) wrote :

Thanks for your work Luca; it is very good, it applies and builds correctly.
Have you also tested that:

1. It indeed solves the problem of having freevo not-working on amd64 machines.
2. The patch doesn't break any other package on a sample of the applications (apt-cache rdepends python-pygame) that depends on pygames?

Changed in pygame:
assignee: nobody → dktrkranz
importance: Undecided → Wishlist
status: Confirmed → Incomplete
Luca Falavigna (dktrkranz) wrote :

I can't be definitely sure of this fix because I have no amd64 boxes to test it, but I'm confident because it has been applied upstream four months ago and no regressions have been discovered so far.

Antti Laiti (pulk) wrote :

That patch worked for me. Freevo does not crash anymore on my amd64 machine.

Luca Falavigna (dktrkranz) wrote :

Antti, thanks for your comment!
Given that, I mark this bug as Confirmed.

Changed in pygame:
assignee: dktrkranz → nobody
status: Incomplete → Confirmed
Daniel Holbach (dholbach) wrote :

Uploaded.

Changed in pygame:
status: Confirmed → Fix Committed
Luca Falavigna (dktrkranz) wrote :

pygame (1.7.1release-4.1ubuntu1) gutsy; urgency=low

  * Build-depend on dpatch
  * 01_stack_overwrite.dpatch: fix a stack overwrite issue which prevents
    pygame from starting (LP: #138430)
  * 02_documentation_fixup.dpatch: fix URL to point to the exact location
    of the online documentation (LP: #134977)
  * Update Maintainer field in debian/control

 -- Luca Falavigna <email address hidden> Sun, 23 Sep 2007 14:00:49 +0200

Changed in pygame:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers