[FFe] update to pycurl 7.19.5

Bug #1376736 reported by Barry Warsaw on 2014-10-02
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
pycurl (Ubuntu)
High
Unassigned

Bug Description

I recently uploaded 7.19.5-2 to unstable. This version fixes several Debian reported bugs and also merges in the still-relevant Ubuntu deltas. We'll need to continue to carry a delta for the cross-pocket build-deps, but these won't affect the functionality of the package. This version also re-syncs the Debian vcs with the NMU that was done by an non-team developer.

I've confirmed the new version fixes LP: #1063350 since afaict there is no longer any floating point corruptions (even dropping the Ubuntu delta).

The new version also fixes a bug that is relevant to system-image. From the upstream changelog:

        * When passing a file-like object to READDATA option, PycURL was
          mistakenly looking for write method on this object. Now read method
          is looked up, as would be expected.

http://pycurl.sourceforge.net/ChangeLog

I've verified that a 7.19.5-2ubuntu1 builds and runs on Utopic. I've tested it against the LP: #1063350 test case on physical i386 hardware and it does not exhibit the floating point corruption.

Barry Warsaw (barry) on 2014-10-02
Changed in pycurl (Ubuntu):
importance: Undecided → High
Scott Kitterman (kitterman) wrote :

Seems reasonable. Approved.

Changed in pycurl (Ubuntu):
status: New → Triaged
Barry Warsaw (barry) on 2014-10-06
Changed in pycurl (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers