Sync pycparser from Debian unstable for 22.04

Bug #1946888 reported by Bryce Harrington
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
pycparser (Ubuntu)
Undecided
Utkarsh Gupta

Bug Description

Scheduled-For: 22.11
Upstream: tbd
Debian: 2.20-4
Ubuntu: 2.20-3ubuntu1

### New Debian Changes ###

pycparser (2.20-4) unstable; urgency=medium

  [ Ondřej Nový ]
  * d/control: Update Maintainer field with new Debian Python Team
    contact address.
  * d/control: Update Vcs-* fields with new Debian Python Team Salsa
    layout.

  [ Stefano Rivera ]
  * Remove python-pycparser now that pypy & pypy3 can build without it. Thanks
    Lukas Märdian for the patch. (Closes: #937411)
  * Bump Standards-Version to 4.6.0, no changes needed.
  * Bump debhelper compat level to 13.
  * Bump copyright years.
  * Bump watch file version to 4.
  * Replace Archive with Registry in UMEGAYA, and drop Homepage.

  [ Debian Janitor ]
  * Remove constraints unnecessary since stretch:
    + Build-Depends: Drop versioned constraint on dh-python.

 -- Stefano Rivera <email address hidden> Thu, 30 Sep 2021 14:22:26 -0700

pycparser (2.20-3) unstable; urgency=medium

  * Depend on the python2.7 binary package for the 2.7 interpreter.
    (Closes: #967036)

 -- Stefano Rivera <email address hidden> Tue, 04 Aug 2020 18:56:14 -0700

pycparser (2.20-2) unstable; urgency=medium

  * Build the parse tables with the python2 binary, explicitly.

 -- Stefano Rivera <email address hidden> Wed, 06 May 2020 10:35:17 -0700

pycparser (2.20-1) unstable; urgency=medium

  [ Stefano Rivera ]
  * New upstream release.
  * Refresh patches.
  * Bump copyright years.
  * Bump Standards-Version to 4.5.0, no changes needed.
  * Bump debhelper compat level to 12.

  [ Ondřej Nový ]
  * Use debhelper-compat instead of debian/compat.

 -- Stefano Rivera <email address hidden> Sat, 07 Mar 2020 22:40:34 -0800

pycparser (2.19-1) unstable; urgency=medium

  [ Stefano Rivera ]
  * New upstream release.
  * Refresh patches.
  * Declare Rules-Requires-Root: no.
  * Bump Standards-Version to 4.2.1, no changes needed.

  [ Ondřej Nový ]
  * d/tests: Use AUTOPKGTEST_TMP instead of ADTTMP
  * d/control: Remove ancient X-Python-Version field
  * d/control: Remove ancient X-Python3-Version field

 -- Stefano Rivera <email address hidden> Sat, 13 Oct 2018 13:08:05 +0200

pycparser (2.18-2) unstable; urgency=medium

  * Rebuild against ply 3.11

 -- Stefano Rivera <email address hidden> Wed, 21 Feb 2018 16:08:55 -0800

pycparser (2.18-1) unstable; urgency=medium

  [ Stefano Rivera ]
  * New upstream release.
  * Refresh patches.
  * Update copyright.
  * Bump Standards-Version to 4.1.3, no changes needed.
  * Bump debhelper compat level to 11.

  [ Ondřej Nový ]
  * d/control: Set Vcs-* to salsa.debian.org
  * d/copyright: Use https protocol in Format field

 -- Stefano Rivera <email address hidden> Sun, 18 Feb 2018 23:53:54 -0800

pycparser (2.17-2) unstable; urgency=medium

  [ Ondřej Nový ]
  * Bumped debhelper compat level to 10
  * d/control: Removed pre-wheezy dependency version

  [ Stefano Rivera ]
  * Build with python-ply 3.9 (Closes: #844714)

 -- Stefano Rivera <email address hidden> Sun, 20 Nov 2016 21:49:30 +0100

pycparser (2.17-1) unstable; urgency=medium

  [ Stefano Rivera ]

### Old Ubuntu Delta ###

pycparser (2.20-3ubuntu1) impish; urgency=medium

  * python2-rm: drop python-pycparser package, py2 depends & autopkgtests.
  * Build the parse tables with the python3 binary, explicitly.

 -- Lukas Märdian <email address hidden> Wed, 12 May 2021 11:12:08 +0200

Changed in pycparser (Ubuntu):
assignee: nobody → Athos Ribeiro (athos-ribeiro)
Revision history for this message
Stefano Rivera (stefanor) wrote :

Looks syncable to me.

Revision history for this message
Utkarsh Gupta (utkarsh) wrote (last edit ):

Indeed, I've verified that this can be a sync. Changing the tag and re-assigning, Athos. Let me know if that's a problem. I'll go ahead and do this sync once the archive opens up again.

tags: added: needs-sync
removed: needs-merge
Changed in pycparser (Ubuntu):
assignee: Athos Ribeiro (athos-ribeiro) → Utkarsh Gupta (utkarsh)
Revision history for this message
Utkarsh Gupta (utkarsh) wrote :

This bug was fixed in the package pycparser - 2.20-4
Sponsored for Utkarsh Gupta (utkarsh)

---------------
pycparser (2.20-4) unstable; urgency=medium

  [ Ondřej Nový ]
  * d/control: Update Maintainer field with new Debian Python Team
    contact address.
  * d/control: Update Vcs-* fields with new Debian Python Team Salsa
    layout.

  [ Stefano Rivera ]
  * Remove python-pycparser now that pypy & pypy3 can build without it. Thanks
    Lukas Märdian for the patch. (Closes: #937411)
  * Bump Standards-Version to 4.6.0, no changes needed.
  * Bump debhelper compat level to 13.
  * Bump copyright years.
  * Bump watch file version to 4.
  * Replace Archive with Registry in UMEGAYA, and drop Homepage.

  [ Debian Janitor ]
  * Remove constraints unnecessary since stretch:
    + Build-Depends: Drop versioned constraint on dh-python.

 -- Stefano Rivera <email address hidden> Thu, 30 Sep 2021 14:22:26 -0700

Changed in pycparser (Ubuntu):
status: New → Fix Released
summary: - Merge pycparser from Debian unstable for 22.04
+ Sync pycparser from Debian unstable for 22.04
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers