pychess fails to run on hardy kde4

Bug #218172 reported by smlx
8
Affects Status Importance Assigned to Milestone
pychess (Debian)
Fix Released
Unknown
pychess (Ubuntu)
Medium
Siegfried Gevatter

Bug Description

Binary package hint: pychess

installed pychess from repos, fails to run when selected from the menu.

running from terminal gives:

Traceback (most recent call last):
  File "/usr/games/pychess", line 87, in <module>
    import pychess.Main
  File "/usr/lib/python2.5/site-packages/pychess/Main.py", line 19, in <module>
    from pychess.widgets import newGameDialog
  File "/usr/lib/python2.5/site-packages/pychess/widgets/newGameDialog.py", line 11, in <module>
    from gtksourceview2 import *
ImportError: No module named gtksourceview2

I installed the package 'python-gtksourceview2' from repos and now pychess will launch. this should be a dependency?

Revision history for this message
Andrew Starr-Bochicchio (andrewsomething) wrote :

I think it actually needs python-gnome2-desktop which will provide libgtksourceview. Debian has made this change as well. (Linking Debian report).

Changed in pychess:
assignee: nobody → andrewsomething
importance: Undecided → Medium
status: New → In Progress
Revision history for this message
Andrew Starr-Bochicchio (andrewsomething) wrote :

Debdiff attatched and subscribing MOTU-Release for a Freeze exception.

Changed in pychess:
assignee: andrewsomething → nobody
status: In Progress → New
Revision history for this message
Scott Kitterman (kitterman) wrote :

You think it needs or you've tested and that solves the problem?

Revision history for this message
Jonathan Thomas (echidnaman) wrote :

The game starts with python-gnome2-desktop, and does not without it.

Revision history for this message
Andrew Starr-Bochicchio (andrewsomething) wrote :

Thanks for testing Jonathan. Additionally, the linked Debian bug resolves the same Traceback by adding python-gnome2-desktop.

Also, this is found in lines 8-11 of /pychess-0.8.1/lib/pychess/widgets/newGameDialog.py

try:
    from gtksourceview import *
except ImportError:
    from gtksourceview2 import *

So it doesn't necessarily need gtksourceview2. It looks for gtksourceview first, which is provided by python-gnome2-desktop. I added that in order to stay closer to Debian.

Revision history for this message
Scott Kitterman (kitterman) wrote : Re: [Bug 218172] Re: pychess fails to run on hardy kde4

Ack from motu-release for upload then. Subscribe ubuntu-universe-sponsors if
you need a sponsor.

Revision history for this message
Andrew Starr-Bochicchio (andrewsomething) wrote :

Thanks Scott. Un-subscribing motu-release and subscribing ubuntu-universe-sponsors.

Changed in pychess:
status: New → Confirmed
Changed in pychess:
assignee: nobody → rainct
status: Confirmed → In Progress
Revision history for this message
Siegfried Gevatter (rainct) wrote :

Uploaded, thanks for your contribution to Ubuntu!

Changed in pychess:
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pychess - 0.8.1-0ubuntu2

---------------
pychess (0.8.1-0ubuntu2) hardy; urgency=low

  * debian/control
   - Added python-gnome2-desktop to Depends. (LP: #218172)

 -- Andrew Starr-Bochicchio (andrewsomething) <email address hidden> Wed, 16 Apr 2008 21:53:48 -0400

Changed in pychess:
status: Fix Committed → Fix Released
Changed in pychess:
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.