autopkgtest gutsy pychecker: erroneous package!

Bug #156953 reported by Ian Jackson autopkgtest on 2007-10-25
30
Affects Status Importance Assigned to Milestone
pychecker (Ubuntu)
High
Scott Kitterman

Bug Description

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

 affects /ubuntu/pychecker
 importance high
 # version 0.8.17-3

 Test executed for: gutsy source pychecker
 Outcome: erroneous package!
  blame: arg:tmp/pychecker/src/pychecker_0.8.17-3.dsc dsc:pychecker
  badpkg: rules build failed with exit code 2
  quitting: erroneous package: rules build failed with exit code 2

  erroneous package!

This message is automatically generated by the autopkgtest package
testing system. You are receiving it because:
 The test results appear to indicate a problem with the package
 and reports for package maintainers for gutsy are being directed to
 <email address hidden>

The top and tail of the test log, which is intended to be sufficient
to diagnose most failures, can be found below. However, in case this
is not sufficient, a complete log can be found along with output
files, saved temporary files, and so on, at:
 http://autopkgtest.ubuntu.com/autopkgtest-output/

The test environment is an amd64 Xen guest with limited amounts of
memory. The relevant dependencies are installed for each test but
very few other packages. Most autopkgtest reports are FTBFS problems.

Please forgive this bug report if the problem is due to archive skew;
in that case you've just been unlucky with the timing. Feel free to
close the bug if the skew has been fixed, or will be fixed soon.

If you have any questions about this service please contact me at:
 Ian Jackson <email address hidden>

Regards,
Ian

- -8<-
++++++ fetching http://archive.ubuntu.com/ubuntu/dists/gutsy/main/source/Sources.gz ++++++
++++++ selecting ++++++
selected pychecker (age <never-yet>, score 28433660)

Package: pychecker
Binary: pychecker
Version: 0.8.17-3
Priority: optional
Section: devel
Maintainer: Kenneth J. Pronovici <email address hidden>
Build-Depends: python-support (>= 0.3), debhelper (>= 5.0.37.2)
Architecture: all
Standards-Version: 3.7.2
Format: 1.0
Directory: pool/main/p/pychecker
Files:
 c14f5499db2d94a5c038ea797cf0a7bc 610 pychecker_0.8.17-3.dsc
 9d2a2d62b368ce503830f830a89bd230 130689 pychecker_0.8.17.orig.tar.gz
 5f3d41097065b315477e7b7fd1360441 13056 pychecker_0.8.17-3.diff.gz

++++++ fetching http://archive.ubuntu.com/ubuntu/pool/main/p/pychecker/pychecker_0.8.17-3.dsc ++++++
++++++ fetching http://archive.ubuntu.com/ubuntu/pool/main/p/pychecker/pychecker_0.8.17.orig.tar.gz ++++++
++++++ fetching http://archive.ubuntu.com/ubuntu/pool/main/p/pychecker/pychecker_0.8.17-3.diff.gz ++++++
++++++ starting test ++++++
+ adt-run --tmp-dir tmp/pychecker/tmp --output-dir tmp/pychecker/out --log-file tmp/pychecker/log --summary tmp/_summary --built-binaries-filter=__ --source tmp/pychecker/src/pychecker_0.8.17-3.dsc --- adt-virt-xenlvm --userv --distro=gutsy --
adt-run: trace: ** init
adt-run: trace: ** start
adt-run: trace: $ vserver: adt-virt-xenlvm --userv --distro=gutsy --
File descriptor 6 left open
File descriptor 7 left open
adt-run: trace: @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@ starting
adt-run: trace: ** open, scratch=None
File descriptor 6 left open
File descriptor 11 left open
File descriptor 6 left open
File descriptor 11 left open
adt-run: trace: * initialising
adt-run: trace: * no key generation needed
adt-run: trace: * reset
adt-run: trace: @@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@@ builds ...
adt-run: trace: @@@@@@@@@@@@@@@@@@@@ dsc dsc0
adt-run: trace: * publish
adt-run: trace: $ ftparchive: sh -ec <SCRIPT> x tmp/pychecker/tmp/binaries /home/iwj/.autopkgtest/gpg
adt-run: trace: $ apt-key: sh -ec <SCRIPT>
OK
Get:1 file: Release.gpg [189B]
Get:2 http://archive.ubuntu.com gutsy Release.gpg [191B]
Hit http://archive.ubuntu.com gutsy Release
Get:3 file: Release [724B]
Hit http://archive.ubuntu.com gutsy/main Packages
Hit http://archive.ubuntu.com gutsy/restricted Packages
Hit http://archive.ubuntu.com gutsy/universe Packages
Ign file: Packages
Hit http://archive.ubuntu.com gutsy/multiverse Packages
Fetched 1B in 0s (18B/s)
Reading package lists...
adt-run: trace: * publish reinstall checking...
adt-run: trace: * publish install...
adt-run: trace: * publish done
adt-run: trace: $ dsc0: python -c <SCRIPT>
adt-run: trace: $ dsc0-extract: sh -ec <SCRIPT> x /root/adt-downtmp/dsc0-build/tmpdir /root/adt-downtmp/dsc0/pychecker_0.8.17-3.dsc
+ spec=/root/adt-downtmp/dsc0/pychecker_0.8.17-3.dsc
+ pwd
+ origpwd=/root/adt-downtmp/dsc0-build
+ cd /root/adt-downtmp/dsc0-build
+ chown adtxenu .
+ TMPDIR=/root/adt-downtmp/dsc0-build/tmpdir
+ rm -rf -- /root/adt-downtmp/dsc0-build/tmpdir
+ export TMPDIR
+ su adtxenu -c mkdir -- "$TMPDIR"
+ spec=/root/adt-downtmp/dsc0/pychecker_0.8.17-3.dsc origpwd=/root/adt-downtmp/dsc0-build su adtxenu -c
\t\t\tdpkg-source -x $spec
\t\t\t
gpg: new configuration file `/home/adtxenu/.gnupg/gpg.conf' created
gpg: WARNING: options in `/home/adtxenu/.gnupg/gpg.conf' are not yet active during this run
gpg: Signature made Sat Aug 26 04:10:40 2006 UTC using DSA key ID 3CD95104
gpg: Can't check signature: public key not found
dpkg-source: extracting pychecker in pychecker-0.8.17
dpkg-source: unpacking pychecker_0.8.17.orig.tar.gz
dpkg-source: applying /root/adt-downtmp/dsc0/pychecker_0.8.17-3.diff.gz
+ cd pychecker-0.8.17/.
+ pwd
+ set +e
+ test -f debian/tests/control
+ echo 1
adt-run: trace: * <dsc:dsc0> build needed for binaries
adt-run: trace: $ dsc0: python -c <SCRIPT>
adt-run: trace: $ dsc0-build: sh -ec <SCRIPT> x /root/adt-downtmp/dsc0-build/tmpdir /root/adt-downtmp/dsc0-build/pychecker-0.8.17
+ TMPDIR=/root/adt-downtmp/dsc0-build/tmpdir
+ rm -rf -- /root/adt-downtmp/dsc0-build/tmpdir
+ export TMPDIR
+ su adtxenu -c mkdir -- "$TMPDIR"
+ cd /root/adt-downtmp/dsc0-build/pychecker-0.8.17
+ dpkg-checkbuilddeps
+ su adtxenu -c debian/rules build
dh_testdir
/usr/bin/python ./setup.py --quiet build --build-base build install --no-compile --install-purelib debian/tmp/lib/pychecker
sh debian/regression.sh # note: build will fail if regression tests fail
Running test1...
Running test2...
Running test3...
Running test4...
Running test5...
Running test6...
Running test7...
Running test8...
Running test9...
Running test10...
Running test11...
Running test12...
Running test13...
Running test14...
Running test15...
Running test16...
Running test17...
8d7
< test_input/test17.py:16: Cannot return a value from __init__
  test17 FAILED
Running test18...
Running test19...
Running test20...
Running test21...
Running test22...
31,32d30
< test_input/test22.py:79: ... % 1 may be constant
< test_input/test22.py:81: ... % 1 may be constant
  test22 FAILED
Running test23...
Running test24...
Running test25...
Running test26...
Running test27...
Running test28...
Running test29...
Running test30...
Running test31...
Running test32...
Running test33...
Running test34...
6a7,10
> locale.py:203: Local variable (digits) shadows global defined on line 4 in file test_input/test34.py
> locale.py:204: Local variable (digits) shadows global defined on line 4 in file test_input/test34.py
> locale.py:208: Local variable (digits) shadows global defined on line 4 in file test_input/test34.py
>
  test34 FAILED
Running test35...
Running test36...
Running test37...
Running test38...
Running test39...
Running test40...
Running test41...
Running test42...
Running test43...
Running test45...
Running test46...
Running test47...
Running test48...
25d24
< test_input/test48.py:57: Statement appears to have no effect
  test48 FAILED
Running test49...
Running test50...
Running test51...
Running test52...
Running test53...
5d4
< test_input/test53.py:5: Operator (~~) doesn't exist, statement has no effect
  test53 FAILED
Running test54...
Running test55...
Running test56...
Running test57...
Running test58...
Running test59...
Running test60...
Running test61...
Running test62...
Running test63...
Running test64...
Running test65...
Running test66...
Running test67...
Running test68...
Running test69...
Running test70...
Running test71...
5d4
< test_input/test71.py:8: Code appears to be unreachable
7d5
< test_input/test71.py:20: Code appears to be unreachable
  test71 FAILED
Running test72...
Running test73...
Running test74...
Running test75...
Running test76...
Running test77...
5c5
< File "test_input/test77.py", line 8
- ---
> File "test_input/test77.py", line 8, in <module>()
7c7
< MyError: **error formatting exception value**
- ---
> MyError:
  test77 FAILED
Running test78...
Running test79...
Running test80...
Running test81...
Running test82...
Running test83...
Running test84...
Running test85...
Running test86...
Running test87...
15,16c15,16
< test_input/test87.py:16: Comparisons with True are not necessary and may not work as expected
< test_input/test87.py:16: Comparisons with true are not necessary and may not work as expected
- ---
> test_input/test87.py:17: Comparisons with True are not necessary and may not work as expected
> test_input/test87.py:18: Comparisons with true are not necessary and may not work as expected
  test87 FAILED
Running test88...
1a2,3
> test_input/test88.py:7: DeprecationWarning: the gopherlib module is deprecated
> import gopherlib
  test88 FAILED
Running test89...
Running test90...
Running test92...
Running test93...
Running test94...
Running test95...
Running test96...
Running test97...
Running test98...
Running test1000...
Running test1001...
Running test1002...
Running test1003...
91/100 tests passed (9 failures).
Failed test(s): test17 test22 test34 test48 test53 test71 test77 test87 test88
make: *** [build-stamp] Error 1
blame: arg:tmp/pychecker/src/pychecker_0.8.17-3.dsc dsc:pychecker
badpkg: rules build failed with exit code 2
adt-run: erroneous package: rules build failed with exit code 2
adt-run: trace: ** stop
adt-run: trace: ** close, scratch=tb-scratch~/root/adt-downtmp:-/|/root/adt-downtmp/!
++++++ RESULTS erroneous package! ++++++
++++++ bundling ++++++
++++++ uploading ++++++
++++++ contacting maintainer_email_override ++++++
++++++ tested. ++++++

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.3 (GNU/Linux)

iD8DBQFHIB7l4qsES9Ynl2gRAq6IAJwKrQlh6gIaq6Pivh/dmxcTLNbzWACfQ0qF
irSwnmQSbxOR20UH0n7+3yU=
=bKw/
-----END PGP SIGNATURE-----

Related branches

Changed in pychecker:
assignee: nobody → kitterman
status: New → In Progress
milestone: none → ubuntu-8.04-beta
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package pychecker - 0.8.17-8ubuntu1

---------------
pychecker (0.8.17-8ubuntu1) hardy; urgency=low

  * Merge from Debian unstable
  * Fix FTBFS with Python 2.5 (Changes directly in .diff.gz since Debian
    maintainer does not use patch system) (LP: #156953)
    - test_expected/test3-debian: /usr/lib/python2.4/2/5
    - Add test17-debian using content from test17-2.4
    - Create test22-debian and remove line 79 and 81 warnings
    - Create test34-debian from test34-2.5 and adjust path and add warnings
      for lines 42, 203, 204, and 208
    - Create test48-debian and remove line 57 warning
    - Create test53-debian and remove line 5 warning
    - Create test71-debian from test71-2.5 and remove warnings for lines 8 and
      20
    - Update exception text in test77-debian
    - Create test87-debian and move line 16 warnings to lines 17 and 18
    - Create test88-debian from test88-2.4 and adjust gopher deprecation
      warning
  * Change maintainer to Ubuntu Core Developers
  * Bump standards version to 3.7.3 without further change

pychecker (0.8.17-8) unstable; urgency=low

  * Fix IndexError exposed by git-buildpackage build (closes: #460357, #460698).
    - Apply patch from Guido Guenther fixing an if/elif mistake in warn.py
    - Submitted Guido's patch upstream as SF request #1889814

pychecker (0.8.17-7) unstable; urgency=low

  * Fix bad unit tests expectations that caused FTBFS (closes: #460355).
    - Added Debian-specific results for test3 (path to UserDict changed)
    - Remove Debian-specific results for test34 (path to GetoptError changed)

pychecker (0.8.17-6) unstable; urgency=low

  * Apply patch from Dan O'Huiginn to improve manpage (closes: #456179).

 -- Scott Kitterman <email address hidden> Mon, 25 Feb 2008 20:49:13 -0500

Changed in pychecker:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers